Author Topic: Problems with avast! 4.8.1195 Home/Pro and up and regedit  (Read 8064 times)

0 Members and 1 Guest are viewing this topic.

into_you

  • Guest
I have a problem with deleting registry values in registry editor.
More specific the values are values which belong to avast!.

I am trying to delete the following value:

HKEY_Local_Machine\System\CurrentControlSet\Services\avast! Antivirus\Group

When I try to delete it, it says "Unable to delete all specified values". I cannot change the permissions either. I am logged in as Administrator.

But the funny thing is that I have only experienced this problem when I make a clean installation with version 4.8.1195 and 4.8.1201. When I first install version 4.7.1043 I can delete the values, but when I update to the newest version, I experience the above problem.

I hope others have experienced this problem and have solved it.
Or maybe others can help.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11820
    • AVAST Software
Re: Problems with avast! 4.8.1195 Home/Pro and up and regedit
« Reply #1 on: July 13, 2008, 12:36:51 PM »
That's not "a problem" - that's correct, it's the self-defense feature, preventing active malware from disabling avast!.
Why do you need to delete those values?

If you feel like you have to remove them, you can disable the whole feature in avast! settings / Troubleshooting.

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
Re: Problems with avast! 4.8.1195 Home/Pro and up and regedit
« Reply #2 on: July 13, 2008, 12:39:54 PM »
It's an added feature - not really a problem or a "funny thing".  :) See http://www.avast.com/eng/avast-free-home-antivirus-antispyware.html -> "Strong self-protection".

Since 4.8 avast! includes a self-defense module that stop virus-like actions, like deleting registry entries that will disable the loading of avast! services. You can disable self-defense in the "Troubleshooting" menu but I'm wondering why you've installed avast! if you want to stop it working?


Edit: Hi igor. Didn't see your post  :-[
« Last Edit: July 13, 2008, 12:42:31 PM by Vladimyr »
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

into_you

  • Guest
Re: Problems with avast! 4.8.1195 Home/Pro and up and regedit
« Reply #3 on: July 13, 2008, 01:03:10 PM »
OKay thx..
I didn't know that..
I am trying to delete that value because there is a minor but annoying XP startup issue.

But again thx for fast reply..

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87055
  • No support PMs thanks
Re: Problems with avast! 4.8.1195 Home/Pro and up and regedit
« Reply #4 on: July 13, 2008, 08:20:04 PM »
You could report that annoying XP startup issue here, you never know someone could help.

You could also try the 'Delay loading of avast! services after other system services in the avast! program settings, Troubleshooting.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Problems with avast! 4.8.1195 Home/Pro and up and regedit
« Reply #5 on: July 13, 2008, 09:22:19 PM »
I am trying to delete that value because there is a minor but annoying XP startup issue.
And what does this have with that particular avast registry key?
Which problem you're experiencing at startup? Why do you want to delete that key?
The best things in life are free.