Author Topic: WebShield adds garbage at start of HTML pages  (Read 4316 times)

0 Members and 1 Guest are viewing this topic.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
WebShield adds garbage at start of HTML pages
« on: July 25, 2008, 01:01:22 PM »
I use avast! WebShield AND WebWasher as a proxy (to remove ads).
The last day ONE site (that I administer) is messed up (see image).

If I either disable WebShield OR disable proxy (direct connection) all works.

But there is no error on other web-pages (only on www.badebakken.com).

Enclosed image shows what's added to the page that messes it up :-(
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86917
  • No support PMs thanks
Re: WebShield adds garbage at start of HTML pages
« Reply #1 on: July 25, 2008, 03:17:04 PM »
There is no such problem with Firefox 3.0.1 and the web shield enabled.

It appears that you problem might be you are accessing a web page directly and not via the home page as this site appears to use frames, see image 1. As your URL in the address field differs from my image 1.

I have gone to the home page link you gave and clicked the HUSORDENSREGLER link on the left and no problem.

I have even tried directly accessing the page http://www.badebakken.com/Husordensregler.html and no problem, image 2, not the URL in the address matches yours...

So I don't know what the problem is but if it were the web shield surely it would effect me also. What version of FF are you using ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: WebShield adds garbage at start of HTML pages
« Reply #2 on: July 25, 2008, 04:08:12 PM »
First. This is a page I administer. And there are no error on the pages :-)

If I access the main page I only get the extra text (not any fram part).
The pages are made to work directly as well, so I use that example.

Seems like the combination of WebShield and the WebWasher proxy causes this.
If I disable one of them the problem goes away :-(

But it IS strange because I administer web-pages on another Apache server as well.
And there this problem does NOT happend :-(

Also after I upgraded avast! to 4.8.1229 (from 4.8.1227 I think) things seem to work.

Can anyone confirm if changes were made to the WebShield in this upgrade?
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

jleezer

  • Guest
Re: WebShield adds garbage at start of HTML pages
« Reply #3 on: July 25, 2008, 04:12:18 PM »
Yes, there were changes to the webshield. See http://www.avast.com/eng/avast-4-home_pro-revision-history.html .

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: WebShield adds garbage at start of HTML pages
« Reply #4 on: July 25, 2008, 04:15:26 PM »
Hmmm... Seems like these changes also fixed the issue when combined with WebWasher.
But this problem occurred with all browsers (so maybe the WebWasher proxy has a simlar problem like Opera).
Sure hope avast! will continue to work together with WebWasher. I know of no better ads filter!
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: WebShield adds garbage at start of HTML pages
« Reply #5 on: July 25, 2008, 04:20:26 PM »
I know of no better ads filter!
Adblock Plus addon for Firefox 3 works perfectly.
The best things in life are free.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: WebShield adds garbage at start of HTML pages
« Reply #6 on: July 25, 2008, 04:25:32 PM »
For Firefox, yes. WebWasher works with ALL browsers.
And work with ALL other applications that user browser windows
(even removes ads inside Steam :-)
And the filter files for WebWasher is easy to edit.

I have not tried AdBlock (as I WebWasher works 100%) but I think a filter should be in the pipeline between the source and the browser (like WebShield is too) and not a part of the browser itself.

The thing I like about WebWasher is that it removed the HTML code that load the ads before the HTML code is sent to the browser. That way those links never reach the browser and are never downloaded at all.

I don't know how ad-block does this, but when surfing on a slow like (like GPRS/EDGE) the feature of never downloading any ad content improves speed (downloading and just not displaying won't help there).
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: WebShield adds garbage at start of HTML pages
« Reply #7 on: July 25, 2008, 04:30:15 PM »
Can you post the link to WebWasher main page? Google returns an error while searching for it...
Download could be faster, but proxy takes resources and then the overall speed could be slower. Only testing says the truth, imho.
The best things in life are free.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: WebShield adds garbage at start of HTML pages
« Reply #9 on: July 25, 2008, 04:57:44 PM »
Of course. It's here:  http://www.cyberguard.com/products/webwasher/webwasher_products/classic/download/
Take a look... but I think it's not for a home user (even the price).
The best things in life are free.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: WebShield adds garbage at start of HTML pages
« Reply #10 on: July 25, 2008, 05:02:58 PM »
WebWasher Classic is free. Just try it out.
They have more advanced products now (for companies).
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: WebShield adds garbage at start of HTML pages
« Reply #11 on: July 25, 2008, 07:12:53 PM »
WebWasher Classic is free. Just try it out.
They have more advanced products now (for companies).
Sorry, haven't noticed... it's not (seems not) Vista compatible... :'(
The best things in life are free.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: WebShield adds garbage at start of HTML pages
« Reply #12 on: July 25, 2008, 07:18:02 PM »
Works on Vista. Have installed it on a friends Vista.
BUT if you "switch user" it gives an error message.
That is just because it is allready running.
Apart from that I have seen no problem on Vista.
She is running on a non-admin account too.
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud