Author Topic: Security Warning and no tray icons  (Read 4401 times)

0 Members and 1 Guest are viewing this topic.

mikeprince

  • Guest
Security Warning and no tray icons
« on: July 27, 2008, 06:59:38 AM »
I originally had a problem with a new Avast install where I wasn't getting the system icons and whenever I startup the computer I get a "Do you wish to run..." prompt for ashDisp.exe. Eventually I got this working: http://forum.avast.com/index.php?topic=36455.

However this problem is now happening again. It happened after I let Avast install its latest program update. I have even tried uninstalling Avast and reinstalling but to no avail.

YoKenny

  • Guest
Re: Security Warning and no tray icons
« Reply #1 on: July 27, 2008, 11:09:56 AM »

mikeprince

  • Guest
Re: Security Warning and no tray icons
« Reply #2 on: July 31, 2008, 05:02:44 AM »
Thanks for the link, but no luck. It would seem that ashdisp.exe cannot run for some reason.

The registry key for this is C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe. I have tried to edit this to put the full path in, i.e. "C:\Program Files\Alwil Software\Avast4\ashDisp.exe" but I get an "Error editing value" error in regedit.

I have also created a shortcut to ashDisp.exe which does nothing when I run it. When I tried "Run as administrator" on it then it gave me the Avast welcome splash screen but still did not load the tray icon.

I've also tried a Control Panel repair which made no difference.

kiwipops

  • Guest
Re: Security Warning and no tray icons
« Reply #3 on: July 31, 2008, 10:12:05 AM »
I have been having all kinds of problems since the MS update/Zone Alarm issues arose earlier this month,one of which was my AvastPro tray icons disappearing,so I checked start/run/services.msc and found all the Avast components were disabled.Don't know if that applies in your case,I only got mine back as a side effect of some technical help,which was intended to assist on a Windows update issue.Hope you sort it out,all the best

mikeprince

  • Guest
Re: Security Warning and no tray icons
« Reply #4 on: July 31, 2008, 11:46:35 AM »
No, in my case the services all seem to be running fine. I think Avast itself is working, but the tray icon is not showing at all because for some reason ashDisp.exe is not able to run.

I've now tried a combination of running as Administrator, in XP Compatibility mode, UAC off etc. and have still got nowhere  :(

mikeprince

  • Guest
Re: Security Warning and no tray icons
« Reply #5 on: July 31, 2008, 12:05:30 PM »
Interestingly I have worked out that regardless of UAC on or off, ashDisp.exe will not launch automatically at start-up and instead gets the Open File Security Warning. The difference is that with UAC off it will then run manually, but with UAC on it will not run at all (but does not report any error).

mikeprince

  • Guest
Re: Security Warning and no tray icons
« Reply #6 on: July 31, 2008, 07:03:46 PM »
Finally got this sorted. I tried so many things it's difficult to be sure what worked, but I think it was:
  • turn UAC off
  • boot into safe mode
  • regedit delete ashDisp.exe startup key
  • delete ashDisp.exe file from Program Files/Alwil Software/Avast4/
  • boot normally
  • turn UAC on
  • Repair Avast via Control Panel
  • turn UAC on
  • reboot
Phew  :)