Author Topic: Avast and Network Copy Performance?  (Read 21668 times)

0 Members and 1 Guest are viewing this topic.

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #30 on: August 01, 2008, 03:15:01 PM »
OldDog-On your XP, High is the same as normal on Vista.  So essentially there is no normal on Vista, just high with regards to this. I would prefer the option of only having Avast on Vista scan the same unchanged file only once during the copy, just like normal on XP.
Windows 7 HP x64/Avast Free

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: Avast and Network Copy Performance?
« Reply #31 on: August 01, 2008, 03:40:49 PM »
The Standard Shield sensitivity settings should be the same as they should be independent of OS they are the same be it on Win9x through Vista, see image.

Does yours not look the same ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #32 on: August 01, 2008, 03:45:12 PM »
Yes they look the same, but if on XP (according to OldDog) avast only scans the src and tgt under High vs. only scanning the src under normal, then Vista's normal setting behaves the same as XP's high setting by scanning both during a copy.  This isn't a visual issue it is a code execution issue.
Windows 7 HP x64/Avast Free

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: Avast and Network Copy Performance?
« Reply #33 on: August 01, 2008, 03:55:05 PM »
I don't think there is any essential difference in how avast acts between the two OSes with the same sensitivity settings.

I would say it is possibly something that Igor or Vlk said in an earlier post about how Vista acts when you open a folder, e.g. trying to access the icon in the file, etc.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline olddog

  • Poster
  • *
  • Posts: 566
Re: Avast and Network Copy Performance?
« Reply #34 on: August 01, 2008, 03:57:22 PM »
DavidR,

I think what Stuck@home meant is that his Normal setting is acting the same in Vista as the High setting is acting on my XP.

Stuck@home,
As a last thought, could you set your Standard Shield on Low, then click on Customise, then select the Scanner(advanced) tab. The radio button in the Scan Created/Modified files should be on "Only Files with selected extensions" and not on "All files".  (On High, this should be reversed). If this is not toggling correctly on your installation, or on Vista, then it would explain the problem.
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #35 on: August 01, 2008, 04:00:12 PM »
I don't have XP to compare, but according to Igor and confirmed by olddog, XP scans the src and tgt when copying on High, but not on normal.  Vista as I stated earlier scans the src and tgt when copying on normal.
Windows 7 HP x64/Avast Free

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #36 on: August 01, 2008, 04:06:18 PM »
Olddog- I don't have an option for Low. Under normal it is set to scan only files with selected extensions. It toggles it the other way when set to high. But interestingly, the extension list under scan created/modified files does not contain jpg's, so I don't know why it is scanning them when copied.
Windows 7 HP x64/Avast Free

Offline olddog

  • Poster
  • *
  • Posts: 566
Re: Avast and Network Copy Performance?
« Reply #37 on: August 01, 2008, 04:18:19 PM »
Stuck@home,

Apologies - where I said Low, I should have said Normal. I have Normal/High/Custom. OK, one last thing. If you untick the "Scan Created/Modified files" then it definitely shouldn't scan them, and if you also go to the advanced tab and select "Show detailed info on performed action", you might be able to see exactly what it is scanning.
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #38 on: August 01, 2008, 04:24:17 PM »
With the scan created/modified setting unchecked it stil scans every file twice.  Once on the \\tgtcomp and once on the \\Srccomp.  You can see the files listed on the on-access scanner message. I don't need to reboot for these setting changes do I?
Windows 7 HP x64/Avast Free

Offline olddog

  • Poster
  • *
  • Posts: 566
Re: Avast and Network Copy Performance?
« Reply #39 on: August 01, 2008, 04:36:05 PM »
Stuck@home,

No you shouldn't have to reboot. If it is showing that the .jpg files themselves are being scanned during creation (write) on the destination PC with these settings, then I think there is probably nothing we can do at our level to take this further. I would hope that perhaps either Igor or Vic could look into this further to clarify just what it is scanning during the write process in Vista.   
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: Avast and Network Copy Performance?
« Reply #40 on: August 01, 2008, 05:18:24 PM »
DavidR,

I think what Stuck@home meant is that his Normal setting is acting the same in Vista as the High setting is acting on my XP.

I'm aware of what Stuck@home meant and that doesn't change my reply after he made what he meant clear, avast doesn't change how it processes files when set to Normal (there is no Low in the Standard Shield sensitivity), so it would appear to be how Vista opens/processes folders/files for copying as mentioned by Igor/Vlk. What that is I have no idea as I don't use Vista
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #41 on: August 01, 2008, 05:32:24 PM »
DavidR - It does seem odd that Avast appears to be ignoring its own settings(specifically scan modified/created files) under Vista. If vista is handling files differently than XP, maybe there is some minor code changes that Alwil can do to compensate.
Windows 7 HP x64/Avast Free

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83751
  • No support PMs thanks
Re: Avast and Network Copy Performance?
« Reply #42 on: August 01, 2008, 05:40:59 PM »
Hopefully Vlk or Igor who have now contributed to this topic can try and set-up a test system to try and replicate it. If they can replicate it then perhaps there is something they can do, if they can't than that is a whole different ball game.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #43 on: August 05, 2008, 03:37:51 PM »
It seems like this might not be an isolated incident, but a potential opportunity for vista specific improvement if the developers can investigate this behavior.  Could vlk or igor comment on whether they believe there is reason for further testing?
Windows 7 HP x64/Avast Free

Offline Stuck@home

  • Jr. Member
  • **
  • Posts: 75
Re: Avast and Network Copy Performance?
« Reply #44 on: August 09, 2008, 12:45:55 AM »
Bump....Please let us know whether this is a real issue or expected behavior.
Windows 7 HP x64/Avast Free