Author Topic: Permissions problem with new Vista install  (Read 5216 times)

0 Members and 1 Guest are viewing this topic.

mikeprince

  • Guest
Permissions problem with new Vista install
« on: June 20, 2008, 11:58:16 AM »
I have installed the latest version of Avast on my Vista Home Premium PC from an administrator account with UAC turned on but have problems with permissions. Although the installation appeared to go successfully I have no system tray icon and get the "Do you want to run this file" prompt at Windows startup and if I try to run Avast manually. If I say yes to this then Avast starts and I can run a scan properly. However I still do not get the tray icon.

I have tried uninstalling and reinstalling with UAC off but this made no difference. I have tried installing a couple of other (non anti-virus) programs since and these worked fine.

I did previously have Activevirusshield which I uninstalled first. Later I noticed that it does not uninstall all registry entries so I have since manually removed all these. Reinstalling Avast still gets the same result.

Hope someone can help!

Cheers
-- Mike --


mikeprince

  • Guest
Re: Permissions problem with new Vista install
« Reply #1 on: June 20, 2008, 12:02:43 PM »
Setup log attached.

Cheers
-- Mike --

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Permissions problem with new Vista install
« Reply #2 on: June 20, 2008, 03:32:21 PM »
Can you try an installation from the scratch?
Seems that the remains of the ActiveVirusShield blocked avast installation.

1. Uninstall avast from Control Panel first.
2. Boot.
3. Download the latest version of Avast Uninstall and use it for complete uninstallation.
4. Boot.
5. Install again the latest avast! version.
6. Boot.
7. Check and post the results.
The best things in life are free.

mikeprince

  • Guest
Re: Permissions problem with new Vista install
« Reply #3 on: June 20, 2008, 04:03:50 PM »
That's exactly what I did do after I removed the remains of AVS but it made no difference.

Incidentally I've just run a scan with Avast which seemed to work properly and I get the Avast splash screen when starting MS Outlook so it seems to be working ok, albeit that it needs to ask for the appropriate permissions each time and the tray icon is not there.
« Last Edit: June 20, 2008, 04:11:11 PM by mikeprince »

mikeprince

  • Guest
Re: Permissions problem with new Vista install
« Reply #4 on: June 20, 2008, 05:59:44 PM »
OK, might have made some progress now...

Just in case I had missed something when deleting the AVS registry entries that were left behind after uninstalling (there is no specific AVS removal tool) I decided to run a Kaspersky removal tool. Not actually sure whether it did anything or not though. I fully uninstalled Avast again, turned UAC off and activated the hidden Vista administrator account. Then I logged in to this account and installed Avast again. This time it successfully installed with the system tray icon and didn't prompt for permissions. I then logged back in to my own user account (still an administrator), turned UAC back on and hid the Vista administrator again. Now I appear to have a successful install: not sure which step or steps did the trick though :)

mabeysa

  • Guest
Re: Permissions problem with new Vista install
« Reply #5 on: August 02, 2008, 07:55:18 PM »
I had exactly the same problem after installing the new version 4.8.1229 on Windows Vista. Re-installing did not solve the problem, and even after installing an older version the problem persisted. I finally solved it by changing the integrity level of the program ashDisp.exe (I remembered that the same dialog window appears if you start a program with integrity level "low").

I did the following
* Started cmd.exe as system administrator
* Entered command

icacls  "C:\Program Files\Alwil Software\Avast4\ashDisp.exe" /setintegritylevel medium

After logging off and on again, no dialog window appeared any more, and the icon in the system tray was displayed as well.

Hope this procedure helps in similar cases as well.