Author Topic: Log Viewer won't display  (Read 11707 times)

0 Members and 1 Guest are viewing this topic.

richteratmosphere

  • Guest
Log Viewer won't display
« on: August 03, 2008, 08:09:54 AM »
I recently bought a new Dell XPS 630.  It has Windows XP Service Pack 2 installed as the OS.  I installed Avast right away, and I've noticed that I can't use the Log Viewer function with Avast.  When I try, the first time around, the little Windows hour class icon comes up for a few seconds then disappears and the log doesn't appear.  If I retry the Log Viewer function or scroll through the different options, a blue bar like "AVS Update" gets stuck on my screen until I reboot.  I've reinstalled Avast and tried to manually execute the Log Viewer executable file, and it still doesn't work.  Any ideas as to what is going on?

When I installed a bunch of software on my new computer, there was one disk in which the executable setup file would do something similar to what the Avast Log Viewer would do.  It would just show the Windows hour glass icon, then nothing would happen, so I couldn't install that software.  I tried the disk on my laptop with Windows XP SP2, and it worked fine, so I know it's not the disk. 

I'm getting a bit concerned that something might be wrong here if two programs are acting strange.

Any thoughts or suggestions?

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #1 on: August 03, 2008, 08:41:02 AM »
Also, another bit of information.

When I attempt to start the Log Viewer, ashLogV.exe does appear under the "processes" when I look at Windows Task Manager.

Also, I am using Windows XP Pro SP2.

I believe my other computers were Windows XP Home SP2.

olddog

  • Guest
Re: Log Viewer won't display
« Reply #2 on: August 03, 2008, 09:25:35 AM »
richteratmosphere,

Dell computers are usually supplied with a Security suite (the recent new ones I have seen have come with McAfee). What did yours come with, and did you uninstall any Antivrus software before your installed Avast.

If it was McAffee, then it generally doesn't uninstall easily. This link to a post from Tech may help.
http://forum.avast.com/index.php?topic=36813.msg309714#msg309714

You should note that you may need to uninstall Avast before uninstalling the old antivirus.

sanctuaryforever

  • Guest
Re: Log Viewer won't display
« Reply #3 on: August 03, 2008, 05:23:49 PM »
Also, another bit of information.

When I attempt to start the Log Viewer, ashLogV.exe does appear under the "processes" when I look at Windows Task Manager.

Also, I am using Windows XP Pro SP2.

I believe my other computers were Windows XP Home SP2.

I also brought this up a few months ago, it happened just like you said and I had to close some programs and wait a while before it appeared on screen even though it was visible under processes

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #4 on: August 03, 2008, 06:23:45 PM »
Thank you guys for the replies so far.  It did come installed with McAfee.  I installed Avast before uninstalling McAfee.  I'll look into that further and report back.

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #5 on: August 03, 2008, 07:28:01 PM »
OK, so here's a summary of what I've done so far.

Right after I set up my new Dell, I installed Avast and Zone Alarm.

Then, I removed McAfee through the add/remove programs options on Windows XP.

I couldn't see the Avast Log Viewer, so I asked for help here.

I removed Avast.

I tried some of the McAfee removal programs that were referenced in this link. 

I reinstalled Avast, and the Log Viewer still wouldn't work.

I removed Avast.

I reinstalled McAfee Suite with the disk that came with my Dell.

McAfee prompted me to remove Zone Alarm, so I removed Zone Alarm.

I used the McAfee removal program that was linked in this thread.

I downloaded one of the registry clean up tools referenced in a link on this thread called Wise Registry Cleaner.

I reinstalled Avast, and the Log Viewer still doesn't work, no matter how long I wait for it to appear on my screen.

Any other suggestions?  I am obsessed with this problem.

 ???

Thank you for your help.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Log Viewer won't display
« Reply #6 on: August 03, 2008, 08:00:48 PM »
If you try to direct run ashLogV.exe from avast folder, will it open?
Are all other avast functions working?

Can you try to repair your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove. Then choose Repair function in the popup window (Repair).
The best things in life are free.

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #7 on: August 03, 2008, 08:24:08 PM »
If I try to directly run ashLogV.exe, it doesn't open.

As far as I know, the other avast functions are working.

I did try to repair the installation multiple times, and the problem persists.

The plot has thickened, as a friend of mine described a solution to fix a similar problem that I was having with an Adobe software.  When I clicked on the setup executable file for the Adobe disk, the Windows XP hour glass icon would come on and the installation would not occur, similar to the problem with the Avast log not coming up.

It was suggested that I create a new Windows XP account and try installing the Adobe program under the new account as there might be some kind of registry corruption / user account problem with the primary account.

When I did try to install the Adobe program under the new account, the disk was recognized and the installation was successful. 

So under the new account, I had Avast running and I tried to open the Log Viewer and it worked!

However, something strange is still happening, because if I reboot Windows and log in to the second account and try to view the Avast Log Viewer, it will not show.  If I log off of that second account and go back to my first account, I can view the log.

Also, if I reboot and log in as my first account and try to view the log, it won't show.  If I log off and login under the second account, I can view the log.

So, it appears that I cannot view the log under whichever account I login to at the reboot and only when I logoff and switch to the other account.

This seems very strange to me.  I am not really familiar with registries and multiple user accounts, so I am now totally confused.

Does anyone have any suggestions as to how I might be able to solve this problem?

Once again, I am very appreciate of all of the help I've been receiving here.

Thanks for your time!

 :)


If you try to direct run ashLogV.exe from avast folder, will it open?
Are all other avast functions working?

Can you try to repair your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove. Then choose Repair function in the popup window (Repair).

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Log Viewer won't display
« Reply #8 on: August 03, 2008, 09:07:15 PM »
Hmmm... maybe a registry corruption...
Can't you try to stay just with the new account you've just created?
Maybe you can move to it the Favorites, your documents, email accounts...
I know... quite a lot of work, but I can't imagine which registry key is bringing this problem...
The best things in life are free.

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #9 on: August 03, 2008, 09:30:51 PM »
That didn't seem to solve the problem, because when I boot with the new account, the log doesn't show.  It only shows if I logoff and login to the other account.

So, it doesn't seem to matter which account I log into first, the log is only viewable if I login to another account.

Hopefully that makes sense.

Any further suggestions?

Hmmm... maybe a registry corruption...
Can't you try to stay just with the new account you've just created?
Maybe you can move to it the Favorites, your documents, email accounts...
I know... quite a lot of work, but I can't imagine which registry key is bringing this problem...

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Log Viewer won't display
« Reply #10 on: August 03, 2008, 11:09:57 PM »
Any further suggestions?
I'm empty... hope the programmers could drop some light here...
The best things in life are free.

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #11 on: August 04, 2008, 12:00:55 AM »
Okay, so just to be sure, I deleted my original profile and created an entirely new profile.  I uninstalled Avast, reinstalled it, moved over all of my documents from my old profile, re-did all of my settings, and under the new profile, the avast log viewer still does not work.

Anyone, programmers or otherwise, please help!

 ???

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11822
    • AVAST Software
Re: Log Viewer won't display
« Reply #12 on: August 04, 2008, 09:14:25 AM »
Does it help if you disable avast! self-defense? (avast! settings / Troubleshooting page)
If not, please try to create a dump of the ashLogV.exe process - with avast! self-defense still disabled. So, start the log viewer in the account where it doesn't work, make sure the process is visible in the Task Manager, and create the dump - as described e.g. here (just use ashLogV.exe, instead of ashSimpl.exe mentioned there).

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #13 on: August 04, 2008, 01:52:01 PM »
Igor,

I disabled avast! self defense and the Log Viewer still didn't work.

I created a dump of the ashLogV.exe with the self defense disabled using the hangrep.exe file.

I did notice that when I ran hangrep.exe, it said that ashLogV.exe was "not responding (no big surprise)."

Thanks for looking into this Igor.  It's been driving me crazy all weekend.

I'll be eager to check for an update from you when I return from work today.

 :)

Does it help if you disable avast! self-defense? (avast! settings / Troubleshooting page)
If not, please try to create a dump of the ashLogV.exe process - with avast! self-defense still disabled. So, start the log viewer in the account where it doesn't work, make sure the process is visible in the Task Manager, and create the dump - as described e.g. here (just use ashLogV.exe, instead of ashSimpl.exe mentioned there).

richteratmosphere

  • Guest
Re: Log Viewer won't display
« Reply #14 on: August 04, 2008, 02:08:36 PM »
Igor,

I uploaded the .dmp file to the FTP site too.

Thanks again!

 :)