Author Topic: Avast! & XP SP 3 Restore Points  (Read 3613 times)

0 Members and 1 Guest are viewing this topic.

Offline havildar

  • Full Member
  • ***
  • Posts: 125
Avast! & XP SP 3 Restore Points
« on: August 30, 2008, 12:46:33 PM »
Good Morning,

May I have a word of advice, please?

I installed XP SP3 some days ago . It arrived by automatic update and installed without any problem except one, which I noticed only yesterday:

All the System Restore Points made over several months by XP SP2 (highlighted in the calendar) have disappeared and on reading this from the Ms site, the recommendation to temporarily switch off the AV is clear enough, but too late!

http://support.microsoft.com/kb/950717/

Is it possible that my having failed to disable Avast! has caused the restore points to be wiped, or am I barking up the wrong tree, so to speak?
Windows XP Sp3 Home desktop, Windows 10 Pro laptop, Avast 17.8.2318 Free , Malwarebytes Anti-malware (free), SpywareBlaster. SuperAntispyware, WOT. Firefox Quantum.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: Avast! & XP SP 3 Restore Points
« Reply #1 on: August 30, 2008, 02:17:36 PM »
Well, as far I know, avast does not have the ability (or possibility) to remove System Restore Points. Maybe the installation of SP3 itself requires the system restore space and automatically remove the old restore points ???
The best things in life are free.

Offline havildar

  • Full Member
  • ***
  • Posts: 125
Re: Avast! & XP SP 3 Restore Points
« Reply #2 on: August 30, 2008, 05:46:28 PM »
Thanks Tech,

My problem is lack of information, I think.

By that I mean several possibilities occurred to me concerning the unexpected disappearance of my restore points, but I was unable to put them in any particular order of likelihood.

I assumed I had done something wrong at first, but then I began to wonder if these points had been wiped by design. In other words, would restore points made in SP2 be of any use to a system running SP3 and even if they were there would the new system allow you to use them?

I thought that failing to disable Avast! might have caused it, but now I`m inclined to think, as you have suggested, that it`s more likely to be related to lack of space. There was certainly a whole heap of restore points in there, perhaps too many, I don`t know ... I didn`t at any point restrict the space XP allocated for them.

Still something of a mystery then, but perhaps someone else might have something to add.
Windows XP Sp3 Home desktop, Windows 10 Pro laptop, Avast 17.8.2318 Free , Malwarebytes Anti-malware (free), SpywareBlaster. SuperAntispyware, WOT. Firefox Quantum.

donoscar

  • Guest
Re: Avast! & XP SP 3 Restore Points
« Reply #3 on: August 30, 2008, 08:41:19 PM »
I also think that SP3 erases all previous restore points. This is to be expected, since an old SP2 restore should be incompatible with SP3.

Also, I think there is no point in keeping old restore points, only recent ones. Restoring an old point can cause severe system problems, especially if apps has been installed or the system has been updated after the restore point was created. This is because these restore points are not complete system backups.

It is much better to create complete system partition images using an image app. These images include the whole system partition and can be restored at any point in time, no matter how the system has changed after they were created (after restoring an image the system must be updated, of course).
 

Offline havildar

  • Full Member
  • ***
  • Posts: 125
Re: Avast! & XP SP 3 Restore Points
« Reply #4 on: August 30, 2008, 11:45:51 PM »
Hi donoscar,

This is what I had in mind too  ... possible incompatibilty of SP2 restore points in SP3.

Things have to be pretty bad if you are put into the position of having to use System Restore but using a restore point from the previous system, I would have thought, is unlikely to make things a whole lot better.

However, I can find no reference to this in the Ms site or on the net generally, except for this from away back in May when SP3 was causing all sorts of problems (for some people anyway) ... scroll down to Fix 3 , where the writer is putting the problem down to insufficient space, even though he keeps only one restore point:

http://techtalk.pcpitstop.com/2008/05/25/pitstop-news-flash-sp3-still-no-go-flash-xp-sp3-still-not-ready-news-flash-do-not-install/

Also, several people I`ve spoken to say their restore points have not been removed by the installation of SP3 and that they are still there, though none of them has had to use one ... yet.

It seems to me that in spite of Ms`s guarded advice about switching off your AV for the installation of SP3, it looks as if switching off Avast! for this may not make any difference one way or the other.


Windows XP Sp3 Home desktop, Windows 10 Pro laptop, Avast 17.8.2318 Free , Malwarebytes Anti-malware (free), SpywareBlaster. SuperAntispyware, WOT. Firefox Quantum.

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
Re: Avast! & XP SP 3 Restore Points
« Reply #5 on: September 01, 2008, 06:14:45 AM »
I have upgraded XP Pro SP2 to SP3 with avast! 4.8 installed without disabling Standard Shield and I still have restore points created prior to SP3.

I did take note of the SP3 installer back-up warning and clone an image first but so far, have not needed it.

Restore points might "disappear" if a System Restore archive is corrupted if a virus detected within the archive (typically in the recycle bin) is quarantined/deleted during an on-demand scan (archives included) by avast!, or any AV.
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

YoKenny

  • Guest
Re: Avast! & XP SP 3 Restore Points
« Reply #6 on: September 01, 2008, 10:39:35 AM »
If you go to the hard drive Properties then click on Disk Cleanup then More Options then select System Restore then Clean up...

Offline havildar

  • Full Member
  • ***
  • Posts: 125
Re: Avast! & XP SP 3 Restore Points
« Reply #7 on: September 01, 2008, 12:36:30 PM »
Anything is possible, I suppose, but I don`t think any of my restore points were infected and there were no quarantined items in Avast! at the time of SP3 installation.

I always have Avast! running, of course, but also Windows Defender, SpywareBlaster and on-demand scanning from SpyBot S&D, and A-Squared plus a very healthy suspicion of downloading anything that looks even slightly dodgy.

Before installing SP3 I ran Eusing Registry cleaner (again), Ccleaner ( but not the advanced options), Ashampoo drive cleaner option (to get rid of the AOL junk that seems to pile up alarmingly), and did a system defrag using XP`s own tool.

The only thing unusual about the download and installation was that something else arrived first: an update for Widows Automatic Update, which I assumed would be useful for installing SP3 or perhaps updating it afterwards.

In any case, the installation went smoothly (EULA and Installation Wizard) and no error message objecting to Avast! or anything else, and it`s now running fine ... even made an automatic restore point yesterday having been left inactive for 20 minutes.

It`s just this removal of all previous restore points that I don`t understand and the absence of any information about why and in what circumstances this can occur.
Windows XP Sp3 Home desktop, Windows 10 Pro laptop, Avast 17.8.2318 Free , Malwarebytes Anti-malware (free), SpywareBlaster. SuperAntispyware, WOT. Firefox Quantum.

redman

  • Guest
Re: Avast! & XP SP 3 Restore Points
« Reply #8 on: September 01, 2008, 02:40:04 PM »
I have had problems with restore points in Vista Home Premium disappearing as well (which seemed to relate to the installation of problem software, although I can't be certain). I have had to use Acronis True Image to restore the complete disc image in those circumstances.