Author Topic: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.  (Read 34673 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #15 on: September 20, 2008, 08:10:12 PM »
Dump is 357,073 lines.... is there somewhere I should e-mail it?

Yes, mail it. Better, zip the file and send the archive ;)
The best things in life are free.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11812
    • AVAST Software
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #16 on: September 20, 2008, 08:15:13 PM »
The dump is a binary file, so I'm not sure how you count the number of "lines". I'd say it should be rather big to be sent by e-mail...
I suggest to upload it to to our FTP: ftp://ftp.avast.com/incoming

ipejasinovic

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #17 on: September 20, 2008, 08:25:29 PM »
I want to report High CPU use from ashWebSv, but only of Avast! 4.8. ashWebSv of Avast! 4.7 is just working fine, with normal CPU use.

met00

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #18 on: September 20, 2008, 09:05:53 PM »
uploaded to incoming FTP 97.03MB :-) Have fun with it.

BilhoZIX

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #19 on: September 23, 2008, 02:39:10 AM »
my money is on a p2p program that is starting those connections.

met00

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #20 on: September 24, 2008, 08:50:29 AM »
that would be a good guess... if I ran a P2P program on my systems. I run
1) secure shell
2) firefox 3.0
3) thunderbird
4) FTP.

Heck I don't even run yahoo or aim much less a p2p.

ipejasinovic

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #21 on: September 24, 2008, 09:28:47 PM »
Hello again. This is how ashwebsv looks by me. Also, I've upload my firewall log, that you can see what ashwebsv trying to do.

ashguy

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #22 on: September 29, 2008, 06:37:49 PM »
I experienced this problem against last night at home, but I had decided not to post about it.

However, today I have experienced this problem at work. Also Windows XP but SP2 and very different hardware and software installed. The avast! On-Access Scanner reported that it had last scanned www.veoh.com/dwr/exec (it may have been longer but this is all I could see).

The same entires are appearing in the AshWebSv.ws log and TCPView shows the same odd number of listening entires all on the same IP/port.

N1m0r

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #23 on: October 02, 2008, 11:26:58 AM »
I have been facing this problem for some days now and thought i could live with it until it got fixed or something but now it starts getting really irritating. It happens every day now and the only solution is to restart my computer. It always happens when i have firefox 3 (almost all the time) open and as other people said i have lots of connections in netstat when this occurs. It seems that this number keeps increasing (because i have connections like this even before ashwebsv starts hitting 50% cpu usage) and at some point when this becomes really big the problem occurs.
Quote

 TCP    127.0.0.1:12080        127.0.0.1:42233        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42234        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42235        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42236        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42237        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42238        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42239        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42245        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42250        CLOSE_WAIT
 TCP    127.0.0.1:12080        127.0.0.1:42256        CLOSE_WAIT
and so on.
I currently disabled avast (not uninstalled) hoping that you are looking into the problem. Can you please confirm you are looking into the problem and if you think it can/will be solved some time soon?
Thanks.

YoKenny

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #24 on: October 02, 2008, 01:27:45 PM »
Firefox will keep the connections open to increase speed.

High memory and CPU consumption is one of the reasons I do not use Firefox.

IE7 with IE7Pro works just as good without the Firefox problems.

By the way, TCPView will show you more information:
http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx
« Last Edit: October 02, 2008, 01:29:49 PM by YoKenny »

met00

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #25 on: October 05, 2008, 06:49:02 AM »
So, let me see if I understand this.

It's not a problem with avast webshield. Even though it didn't happen in a priopr version and does in the latest version.

It is a problem with Firefox even though the problem didn't exist in the old version with Firefox, but does in the new version.

Wow! Thanks for clearing that up.

Firefox doesn't change, webshield does, and the problem is Firefox's fault.

As a former CTO, you don't mind if I say that is the weakest excuse I have ever heard and I feel that it is a totally bogus response.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #26 on: October 05, 2008, 11:28:44 PM »
Couldn't Lukas drop some light here?
The best things in life are free.

Atron

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #27 on: October 05, 2008, 11:49:19 PM »
I want to report, that i have same problem, but taskmanager gives me 80-90% of CPU usage and proccess ashWebSV.exe takes all resources.

only reboot solves problem for a while.

Could somebody give us a recommendation for solving this problem

i'm using Dell inspiron 6400, T2300, 2GB RAM , progs: firefox 3.01. chrome, IE7. emule.

Atron

  • Guest
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #28 on: October 08, 2008, 11:37:26 PM »
Can somebody to answer to this problem? avast tech. stuff are u here????

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: High CPU from System/ashWebSv.exe. Has strange AshWebSv.ws log messages.
« Reply #29 on: October 09, 2008, 03:26:43 AM »
avast tech. stuff are u here????

Couldn't Lukas drop some light here?

It's beyond my knowledge. I need Lukas here...
The best things in life are free.