Author Topic: Scanning Gmail messages  (Read 11850 times)

0 Members and 1 Guest are viewing this topic.

TwoShoes

  • Guest
Re: Scanning Gmail messages
« Reply #15 on: October 11, 2008, 05:14:54 AM »

Not only the clean notes but your emails aren't being scanned at all...

I am not sure what you mean with this statement ??? ??? ???

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3870
  • Just an avast user
Re: Scanning Gmail messages
« Reply #16 on: October 11, 2008, 05:31:13 AM »
I must not try to speak for Tech but the point is that, without the change suggested by Tech, avast was not only not putting in the "clean message" (just in my opinion - a not very useful feature) but, more importantly, your incoming messages were not being scanned by avast at all. 

They are now being scanned - as shown by the X-Antivirus headers in the inbound messages that are, I suggest, sufficient to tell you the message has been scanned.

(Edited - to include the missing word "not" at the beginning after the follow-up post from the OP).
« Last Edit: October 11, 2008, 06:14:07 AM by alanrf »

TwoShoes

  • Guest
Re: Scanning Gmail messages
« Reply #17 on: October 11, 2008, 06:09:56 AM »
Thank you, I saw the word "aren't" (currently) and didn't realize it was meant to say "weren't" (previously).  I agree with your's  and others' thoughts about the "clean" messages, for testing it just seems to eliminate the need to look at the X-Antivirus headers.  I have been trying to get outgoing gmail scanned but am having problems connecting to the smtp server.  Right now I have Outlook Express setup as follows:  in the Servers tab, I have outgoing mail set to 127.0.0.1 and in the Advanced tab outgoing mail set at 11025 and "this server requires..." unchecked.  In Avast, I have "redirect smtp" set at 25,587,11025. and my stunnel.conf is:
cert=stunnel.pem
client=yes
# POP3 service, listens on localhost:11110
[gmail-pop3s]
accept=127.0.0.1:11110
connect=pop.gmail.com:995

# SMTP service, listens on localhost:11025
[gmail-smtps]
protocol=smtp
accept=127.0.0.1:11025
connect=smtp.gmail.com:465

It never connects to the smtp server, just times out which is set to 1 minute.  Can you see anything I may have wrong on the outgoing mail side? 

Again, thanks to everyone for their help.

sded

  • Guest
Re: Scanning Gmail messages
« Reply #18 on: October 11, 2008, 02:28:09 PM »
Couple of things to try.  1.  Use port 587 instead of 465 for SMTP.  2.  or remove the "protocol=smtp" line with port 465.

TwoShoes

  • Guest
Re: Scanning Gmail messages
« Reply #19 on: October 11, 2008, 04:26:30 PM »
Removed the protocol=smtp and retained port 465 and all appears to be working perfectly.  Thanks to all who provided help, greatly appreciated.  Hope I can return the assistance some time.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67185
Re: Scanning Gmail messages
« Reply #20 on: October 11, 2008, 11:47:27 PM »

Not only the clean notes but your emails aren't being scanned at all...

I am not sure what you mean with this statement ??? ??? ???
Sorry, I should wrote "weren't" scanned and not "aren't" scanned.
When you correct the setting, they start to be scanned.
The best things in life are free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67185
Re: Scanning Gmail messages
« Reply #21 on: October 11, 2008, 11:49:57 PM »
Remove the "protocol=smtp" line with port 465.
I think you can let it there...
http://forum.avast.com/index.php?topic=39225.msg329109#msg329109
The best things in life are free.

TwoShoes

  • Guest
Re: Scanning Gmail messages
« Reply #22 on: October 12, 2008, 12:12:35 AM »
Tech,

    I was using port 465 for Gmail because when I was setting up Gmail that is the port they wanted me to use for SMTP.  Until I removed the protocol=smtp from the stunnel.conf, outbound messages were not being scanned.  So for some reason in my case I needed to remove it.   Anyway, just glad all is working.

     Thanks again for your assistance.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67185
Re: Scanning Gmail messages
« Reply #23 on: October 12, 2008, 12:25:30 AM »
In Avast I have port redirects as follows pop 10,11110 and smtp 25,587,11025.

# SMTP service, listens on localhost:11025
[gmail-smtps]
protocol=smtp
accept=127.0.0.1:11025
connect=smtp.gmail.com:465

Check you configuration... your posts say they're not equal... or 465 or 587.
The best things in life are free.

TwoShoes

  • Guest
Re: Scanning Gmail messages
« Reply #24 on: October 12, 2008, 02:57:42 AM »
Sorry, I see where I may be causing some confusion.  My normal ports for Gmail were 965 for POP and 465 for SMTP and for Comcast mail 110 for POP and 587 for SMTP.   After I installed Avast, Comcast was my primary mail server so I needed to add 587 to the Avast redirects for SMTP but the Avast default of 110 for POP was OK. After Comcast mail was being scanned properly I then started working on Gmail.    At that point I then needed to add 11110 for POP and 11025 for SMTP to the Avast redirects so that Stunnel can then handle the Gmail needed SSL connections.    So at no point does Avast need 465 or 995 in its' redirects.  Very confusing way to handle email scanning but until Avast can work with SSL on its own we need to depend on these "mirrors" to keep thing working.   I sure hope this makes sense to you, I am confusing myself as I am typing this.  Have a great weekend.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3870
  • Just an avast user
Re: Scanning Gmail messages
« Reply #25 on: October 12, 2008, 05:20:01 AM »
Twoshoes,

to clarify are you saying that you can use SMTP on Comcast on port 587 and specify no security?

I'm off to try it myself.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3870
  • Just an avast user
Re: Scanning Gmail messages
« Reply #26 on: October 12, 2008, 05:39:03 AM »
I am amazed.  You are right - port 587 can be used without security and therefore scanned by avast.

Now the dilemma.  I find it hard to believe that Comcast intend port 587 to be used without security.  It may be enough that they require use of an account name and password but this is rather unusual.   It may well be (though I find it hard to stretch technical inadequacies of Comcast this far) that they know.  Should this be discussed with them?  In which case they may well block the path you are presently using.