Author Topic: Scans ends after first virus  (Read 3415 times)

0 Members and 1 Guest are viewing this topic.

Offline Paul1149

  • Jr. Member
  • **
  • Posts: 59
    • Following Christ
Scans ends after first virus
« on: March 31, 2004, 07:21:02 PM »
I'm scanning my Opera files, as a lot of netski .pifs are coming my way. But every time Avast Home finds an instance of the virus and I either Delete it or click Continue, the scan ends. I expect it should continue and then I will deal with all hits at the end. The current behavior doesn't make sense. Thanks.

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re:Scans ends after first virus
« Reply #1 on: April 01, 2004, 07:15:26 AM »
Do you have it set to scan certain folders or the entire local disk?
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline Paul1149

  • Jr. Member
  • **
  • Posts: 59
    • Following Christ
Re:Scans ends after first virus
« Reply #2 on: April 22, 2004, 01:24:33 AM »
Sorry for the delay, I had unknown email problems.

I'm fairly sure I was scanning individual folders via the context menu in my file explorer.

Offline whocares

  • Super Poster
  • ***
  • Posts: 1698
  • I'm not a llama! :-)
Re:Scans ends after first virus
« Reply #3 on: April 22, 2004, 08:13:42 AM »
I experience the same behaviour with the Quickscan on
Win2000-SP4
VPS: 4.1.389, VPS from 22.4.04 (but this has been for quite some time like this)

avast4.ini-Settings:
[Quick]
EnableSkins=0
InfectionExitApp=0
ShowResults=1

 ???

Offline Le Doc

  • Sr. Member
  • ****
  • Posts: 230
  • Computer obey to orders, not to intentions.
    • La Halle online
Re:Scans ends after first virus
« Reply #4 on: April 22, 2004, 10:17:15 AM »
You have to set an option for the explorer extension scan :

go to Settings... -> Common

uncheck "Exit Explorer Extension when first virus is found"

Hope it will help.

Avast HE 4.1.418 (french)
Windows 2000 PRO (french) - SP4 + patches
nforce 2 motherboard (IGP)
AMD 1800+, 512 MB, 160 GB + 40 GB

Offline whocares

  • Super Poster
  • ***
  • Posts: 1698
  • I'm not a llama! :-)
Re:AshQuick still ends after first virus - 4.1.389
« Reply #5 on: April 22, 2004, 01:25:14 PM »
uncheck "Exit Explorer Extension when first virus is found"

Hi Le Doc,

this is unchecked (imho that's what "InfectionExitApp=0" in the ini means..) ;)
« Last Edit: April 22, 2004, 01:32:46 PM by whocares »