Author Topic: Just downloaded, but doesn't seem to run?  (Read 4318 times)

0 Members and 1 Guest are viewing this topic.

fingercuffzzz

  • Guest
Just downloaded, but doesn't seem to run?
« on: April 20, 2004, 02:10:13 PM »
Hi.

I just downloaded avast! and tried to scan my computer for any viruses, but it just sat there.  It did say, "running", but for 5 minutes with nothing being scanned.  I tried it again with the same results.

Actually I just tried it again and I got the following error message, "Program can not set property into main storage"

Is it just that slow or have I done something wrong?

I run Win98, cable modem, IE 6.0, pentium II processor, 128-bit.

Thanks for any help you can offer!

edited to add: on the screen where it says, "running" it also says, "initializing engine, please wait"

It doesn't seem to be doing anything :(

Jamie  8)
« Last Edit: April 20, 2004, 03:57:51 PM by fingercuffzzz »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Just downloaded, but doesn't seem to run?
« Reply #1 on: April 20, 2004, 04:59:14 PM »
Please, on the avast4.ini file change the value Database on section [Common] from ODBC to XML

Driver for VRDB: ODBC or XML. Mostly concerning storage and databases problems may be related to the database drivers that could be downloaded from www.microsoft.com/data.

Actually, if you need more information about the avast4.ini file you can see http://www.avast.com/forum/index.php?board=2;action=display;threadid=1647
The best things in life are free.

fingercuffzzz

  • Guest
Re:Just downloaded, but doesn't seem to run?
« Reply #2 on: April 20, 2004, 05:01:00 PM »
In case anyone else has this problem, I did find the answer I needed.  I had looked everywhere including FAQ, message boards, and the tech support areas.  It was no where to be found, but then I found a section called, "other problems".

here is the answer...

Q: What should I do when I see this error message: "Unknown error. Program cannot set property into main Storage"?

A: This error message is displayed when your ODBC drivers are too old, or damaged, or if they aren´t installed properly. avast! uses this drivers by default. There are two solutions of this problem:

Install current ODBC drivers provided by Microsoft. You can download them from this page http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=en.

Don´t use the ODBC drivers and use XML. To setup avast! use XML, follow these steps:
Open the file avast4.ini located in C:\PROGRAM FILES\ALWIL SOFTWARE\AVAST4\DATA in Notepad.
Find the section [COMMON]
In this section change the row
Database=ODBC to Database=XML
Save the file
Restart your computer

Edited to add: Thank you for your help, technical

Jamie  8)
« Last Edit: April 20, 2004, 05:08:25 PM by fingercuffzzz »