Author Topic: Avast update stops my machine from booting  (Read 18224 times)

0 Members and 1 Guest are viewing this topic.

Offline Otter

  • Newbie
  • *
  • Posts: 5
Avast update stops my machine from booting
« on: November 23, 2008, 12:31:50 PM »
I 3 several machines, 2 with avast home and one with AVG. Both XP SP3 with windows auto-updated. I won't talk about the AVG machine I'm using.

A few days back I updated the program on my workstation and re-booted. The PC booted as far as the blue background for the desktop but didn't show any icons or toolbar. It wouldn't respond to ctrl+alt+del either. I powered off using the button on the front of PC.
Tried again - same.
Booted into safe mode - OK. Scheduled a hard drive scan. That went OK. Re-booted - hang again.
Uninstalled Avast in safe mode and booted normally - OK.
Downloaded clean version of Avast and installed. Hang on re-boot.
Uninstalled it and the machine is fine, but not running any anti-virus software.

My laptop was OK. Until....

Yesterday on my laptop I was notified of an update and I allowed it to load on the laptop. Re-booted and it hang at the desktop - but this time it was showing icons on the desktop and the taskbar. If I put the mouse over the taskbar I got an hourglass. I left it for a while - no activity from HDD but was still hung. Responded to ctrl+alt+del very slowly. I asked it to shut down which it attempted. I had to click a button to confirm halting explorer.exe
Blah, blah blah - same old stuff shows it's to do with AVG.
Clean install with file downloaded then and there followed by re-boot with a scan showed no virii and allowed laptop to boot and be used OK. On a re-boot I'm back to square 1 with the laptop unable to complete booting, with the hourglass etc - exactly the same as the first time.

The only machine I can safely use on the net now is the one using AVG. Well - not strictly true because the desktop with Avast! on it is dual boot with Kububtu.

What's going on and why do I seem to be the only person with this problem? On two machines too.

The desktop has no firewall apart from windows. There's no other AVG running. In fact, the only thing the machines have in common is FlashGet, although it's not set to auto-start. Is there a problem with Avast! and FlashGet? Sorry, I only just thought about that, I'll check the posts.

Offline REvK

  • Newbie
  • *
  • Posts: 2
Re: Avast update stops my machine from booting
« Reply #1 on: November 23, 2008, 01:10:27 PM »
Hello,

I just registered to tell of the same problem.
Avast Home Edition was running fine for a long time on my XP PRO SP3, yesterday I got the little green box telling me of a newer version, but I ignored it.

Today my computer starts up normal, until logon screen, after logon it just shows the background of my user but nothing else happens.
I tried several reboots and once I got the task manager up and could see a process called "avast.setup".
I could not kill it for some unknown reason.

When I ran safe mode of XP I used MSCONFIG to uncheck the avast services and after that the machine boots just fine, but avast is disabled.
As soon as i activate the avast services and reboot it will hang up again after logon.

So far so good... I then retried complete uninstall of Avast, then reboot, then the uninstall tool, reboot again, then fresh install of avast.
First reboot then went well, everything was back to normal. Then I just switched the sounds of avast off, and tried another reboot to be sure everythings working again.

And know what? It hangs up again after logon.
Now I disabled the avast services once again in safe mode to be able to use my computer at all.

Greetings

Offline BammBeee

  • Newbie
  • *
  • Posts: 1
Re: Avast update stops my machine from booting
« Reply #2 on: November 23, 2008, 02:07:59 PM »
Hi just registered as well to report same problems with the latest Avast program online update. At the end of installation it asks for reboot, all ok.
After reboot windows gets past the "loading your personal settings" screen and desktop comes up with no icons, toolbars or Taskbar at all Just the background, even ctrl alt del does not open task manager or enable shutdown.
The only solution I've found as well is to switch off power, reboot in safe mode, and uninstall Avast.
Reboot then works and all is hunky dory again but with no antivirus.
This is repeatable and I have tried it with two different XP Pro SP3 installations and my main XP Pro SP3 installation twice with the same results.

Offline Geoffo

  • Jr. Member
  • **
  • Posts: 70
Re: Avast update stops my machine from booting
« Reply #3 on: November 23, 2008, 02:27:46 PM »
I had exactly this after a previous Avast prog update. With mine, I waited 3/4 minutes and eventually it booted ok. After this, I clicked 'Prog Settings' then 'Troubleshooting' and selected 'Delay loading of Avast services til last', Reboot - and for me things worked ok after that. When it's going ok, remember to uncheck 'Delay loading etc'.
« Last Edit: November 23, 2008, 02:29:23 PM by Geoffo »
Win7, Chrome, Avast MBAM, SUS,

Offline rlm2008

  • Newbie
  • *
  • Posts: 3
Re: Avast update stops my machine from booting
« Reply #4 on: November 23, 2008, 03:53:17 PM »
Likewise, registered to report the same problem. XP latest service pack etc.

I was on the verge of doing a fresh xp install, but as others have the same prob I'll hold on.

Seems like a good suggestion Geoffo, but I've tried leaving it and nothing happens.

This a side, thanks for a fantastic product Alwil. It's been great up to this point :D

RLM


Offline Otter

  • Newbie
  • *
  • Posts: 5
Re: Avast update stops my machine from booting
« Reply #5 on: November 23, 2008, 05:23:37 PM »
OK, I thought I'd try geoffo's suggestion, so I re-intalled it but even after leaving it 2 hours it wouldn't complete booting. A forced shutdown hangs when it says "saving settings".

Offline REvK

  • Newbie
  • *
  • Posts: 2
Re: Avast update stops my machine from booting
« Reply #6 on: November 23, 2008, 05:58:47 PM »
Hi again,

I also gave geoffo's suggestion a try, but it didn't work out.
It had no effect at all.
I've set the Service "avast! Antivirus" to manuel which works well on startup.
When everything is loaded and working then im manually starting the service and avast is working again.


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast update stops my machine from booting
« Reply #7 on: November 23, 2008, 06:09:51 PM »
I would suggest that you all try a clean reinstall. Although you all have one common issue some have been experiencing other issues which might well indicate a failed update.

Download the latest version of avast http://www.avast.com/eng/download-avast-home.html and save it to your HDD, somewhere you can find it again. Use that when you reinstall.

Download the avast! Uninstall Utility, find it here and save it to your HDD.

1. Now uninstall (using add remove programs, if you can't do that start from the next step), reboot.
2. run the avast! Uninstall Utility, reboot.  If step 1 failed it may be necessary to run this from safe mode, once complete reboot into normal mode.
3. install the latest version, reboot.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline mikeinmexico

  • Newbie
  • *
  • Posts: 6
Re: Avast update stops my machine from booting
« Reply #8 on: November 23, 2008, 06:17:35 PM »
Sounds just like the problem I had. Are any of you running Online Armour firewall? See my other post about the conflict.

Offline Otter

  • Newbie
  • *
  • Posts: 5
Re: Avast update stops my machine from booting
« Reply #9 on: November 23, 2008, 09:13:31 PM »
@DavidR - Thank you for trying to help, but if you read my first post you'll see I already installed a clean version. I uninstalled in safe mode.

*There may be a solution*
Despite the scan yesterday not showing any problems I found a possible problem today.

I started the machine up in safe mode and ran a scan. It thinks it found Win32:Patched-HP[trj] in c:\windows\system32\dmserver.dll in memory. All I could do was delete it (as opposed to quarantine or delete to recycle bin).
I then did a boot time scan which took offence at FlashGets updater.exe file and found a couple of things in system restore backup files (archived versions of dmserver.dll?).
After it booted I ran the command "sfc /scannow" to replace windows system files (of which dmserver.dll is one) with the genuine versions.

All seems happy now (so far) but I'm not sure whether the file I deleted was really trojaned or whether it was a file updated by SP3. I'm running a scan now.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast update stops my machine from booting
« Reply #10 on: November 23, 2008, 10:29:33 PM »
At no point in that post did you say you used the avast uninstall utility and that is what I mean by a clean install as that ensures all registry entries are history.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Otter

  • Newbie
  • *
  • Posts: 5
Re: Avast update stops my machine from booting
« Reply #11 on: November 24, 2008, 12:00:12 AM »
Thanks DavidR. Noted.
I just had a go at my workstation again and Avast! picked up on the same dmserver.dll. I deleted it and nicked a spare copy of it as a replacement from my xp sp3 machine running AVG. The version is 2600.5512.503.0.
Avast! scans this one as OK so I guess something modified my files. It's solved for me.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast update stops my machine from booting
« Reply #12 on: November 24, 2008, 12:17:30 AM »
Yes same version as on mine also xp pro sp3.

dmserver.dll
MD5:
57EDEC2E5F59F0335E92F35184BC8631

SHA1:
80C6F2808D413AE6FA37F6FD4ADA8DC160F99A0A
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline rlm2008

  • Newbie
  • *
  • Posts: 3
Re: Avast update stops my machine from booting
« Reply #13 on: November 24, 2008, 08:43:12 AM »
Well done Otter,

Mine picked up on dmserver.dll. I did a search and there was a different version 2600.2180.503.0 in the $uninstall directory. I've copied that into system32 and so far seems to be okay.

Cheers ;D

RLM

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Avast update stops my machine from booting
« Reply #14 on: November 24, 2008, 12:40:34 PM »
It would be good an official acknowledgment of this issue.
The best things in life are free.