Author Topic: Avast update stops my machine from booting  (Read 18225 times)

0 Members and 1 Guest are viewing this topic.

Offline paslawtx

  • Newbie
  • *
  • Posts: 3
Re: Avast update stops my machine from booting
« Reply #15 on: November 24, 2008, 03:56:59 PM »
I use Vista.  I updated this morning, did not reboot right away, then shut down.  When I powered on later Outlook and IE work fine, but there was no Avast twirling icon on bottom right, and an Adobe update icon came on and I was about to install one of their updates before I realized the Avast icon was missing.  I then tried to just start the program from the menu and it seemed to come on and run through a start up procedure but still no icon and I'm afraid to try to scan a file with it or otherwise use it or reboot or anything right now.

Anyone else with a similar problem?  I will probbaly uninstall and work immunocompromised until Avast or someone comes up with a fix.

Thanks to anyone who can help!

Offline sunrisecc

  • Full Member
  • ***
  • Posts: 135
Re: Avast update stops my machine from booting
« Reply #16 on: November 24, 2008, 04:10:51 PM »
Whenever an icon is missing in the tray, I usually start the program by hand or reboot. It appears to be a timing issue with Vista. If Avast is running but no icon, (check via task manager), there is a way to get the icon back without restarting. I would have to search this forum. Other pending updates have done this to me. I just boot gain after the other program has updated.
Seymour

Offline paslawtx

  • Newbie
  • *
  • Posts: 3
Re: Avast update stops my machine from booting
« Reply #17 on: November 24, 2008, 04:16:18 PM »
Thanks, but the lack of icon is not as much a concern as the program's running properly.  I did start it and check task manager but it was not there.  I may try to reboot and see what happens. . . .

Offline paslawtx

  • Newbie
  • *
  • Posts: 3
Re: Avast update stops my machine from booting
« Reply #18 on: November 24, 2008, 04:22:56 PM »
I rebooted and everything seems to be working fine now . . . I know that doesn't help anyone else. . . .

Offline sunrisecc

  • Full Member
  • ***
  • Posts: 135
Re: Avast update stops my machine from booting
« Reply #19 on: November 24, 2008, 04:31:55 PM »
It has always worked for me  (the reboot solution). I have a APC battery backup that is connected via USB permanently and APC's program running for shutdown in lieu of Vista's. Occasionally it doesn't show up in the tray. I know it is working but I reboot and then it appears. To complicate the issue, the systray icon for my Logitech keyboard/mouse shows up instead of being hidden. I just ignore it and chalk it up to Vista.

I am glad that everything is okay now.
Seymour

Offline Fingerlakes Dave

  • Newbie
  • *
  • Posts: 6
Re: Avast update stops my machine from booting
« Reply #20 on: November 24, 2008, 07:19:22 PM »
Avast just not working, and killing my pc.  ??? ??? ??? :'( :'(

With new update .1290, loggin not allowed.  When I uninstalled (using removal tool, etc.), no issues starting my machine except no AV.

Tried reinstall, full system scan, etc.  NO issues, login not allowed.  I can s.l.o.w.l.y... enter my password, then nothing.  Machine just sits there.

Tried the dmserver.dll fix.  I have the version everyone is saying to use already installed. No joy.

It really come down to: if this software requires this degree of 'care and feeding', do I want to continue to use???  >:(

ANY insight appreciated.

Windows XP Pro SR3, Online Armour firewall,

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast update stops my machine from booting
« Reply #21 on: November 24, 2008, 07:26:37 PM »
Online Armor is getting a bit of a rep at screwing with the avast update process, try a forum search for online armor and see what it brings as there are certainly a number of posts about it.

By all accounts either putting it in learning mode or install mode or uninstalling OA install avast and reboot then reinstall OA and things should be running again. Though I doubt everyone in this topic is using OA.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
Re: Avast update stops my machine from booting
« Reply #22 on: November 24, 2008, 07:34:06 PM »
I have had the install problem with Online Armor 3 and avast! 1290 on my XP SP3 machine, but interestingly no issues on two Vista machines with the same OA/avast! configuration.  Reports on the OA forum are that installing with OA in learning mode seems to fix it for most people.  In my case, I let it sit there for several minutes and things finally loaded, along with some OA error messages.  Then I put OA in learning mode for a while, and all seems to be working now.  No update problem before 1290, BTW.  And I am using the latest OA beta, not the current release, but it seems to be a continuing problem until the next beta release at least.  Or next avast! release.
« Last Edit: November 25, 2008, 03:57:52 PM by sded »
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast update stops my machine from booting
« Reply #23 on: November 24, 2008, 07:35:54 PM »
Thanks for the input sded.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast update stops my machine from booting
« Reply #24 on: November 25, 2008, 03:53:40 PM »
That is hardly a solution but avoiding the problem and a very long winded work around/avoidance of a symptom and not a solution. 

Why bother with the safe mode shuffle if your are going to uninstall, do it add remove programs in safe mode and reboot no need for the msconfig two step.

However, when you reinstall avast what is to say the same won't happen when you update if as has been mentioned your firewall is OA. So you have to target the problem rather than the symptom.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Zach45

  • Newbie
  • *
  • Posts: 5
Re: Avast update stops my machine from booting
« Reply #25 on: November 27, 2008, 01:53:02 AM »
Hello,

I also updated my XP Pro system to the latest Avast Home version and had this message come up: "The AAVM subsystem detected a RPC error". Along with my sound not working and various other items not functioning properly. My boot time increased to an incredibly long time also.

I went to the help site and found the above error and followed the instructions to repair the installation to no avail.

I proceeded to un-install the upgraded version and re-install the previous version 4.8.1229 which corrected all of the above issues.

I will not go any further but will wait until Avast brings out a corrected update file that will update their software correctly.

Zach

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8788
Re: Avast update stops my machine from booting
« Reply #26 on: November 27, 2008, 04:52:26 AM »
Zach, i do not have a problem on my XP Pro system with the update but then I do not run a software firewall.

Have you tried Micro Malicious Software Removal Tool?
http://www.microsoft.com/downloads/details.aspx?FamilyID=ad724ae0-e72d-4f54-9ab3-75b8eb148356&displaylang=en
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Avast update stops my machine from booting
« Reply #27 on: November 27, 2008, 02:46:24 PM »
Zach45, we will need more information to be able to help you:
- Do you use a firewall? Which one?
- Do you have any other antivirus installed in your system?  Did you have in the past?
- Any other security programs that could interfere?

Besides, try updating to 4.8.1296 version.
The best things in life are free.

Offline Zach45

  • Newbie
  • *
  • Posts: 5
Re: Avast update stops my machine from booting
« Reply #28 on: November 27, 2008, 03:38:38 PM »
I use "Online Armor" as my firewall in addition to a router. I also had AVG installed as my anti-virus software but completely un-installed it using the un-install software from the vendor including searching my hard drive for any files or folders left after the un-install. I also searched my registry for any left over remnants of the AVG product.

I did this before installing the original version of Avast which works fine and continues to do so.

When I received the update notice from Avast I ran the update install from the Internet and had nothing but problems so I un-installed the upgrade and reverted back to the original version which works fine.

Like I said, I will continue with the older version until I am certain that I can upgrade with a working solution.

Thanks,

Zach

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83014
  • No support PMs thanks
Re: Avast update stops my machine from booting
« Reply #29 on: November 27, 2008, 03:54:55 PM »
<snip>
When I received the update notice from Avast I ran the update install from the Internet and had nothing but problems so I un-installed the upgrade and reverted back to the original version which works fine.

Like I said, I will continue with the older version until I am certain that I can upgrade with a working solution.
<snip>

What are these "and had nothing but problems" that you say you had ?

We might be able to help resolve then, if we only knew what they were and if they weren't resolved then perhaps Alwil might find a cause which can be resolved. If we don't know what your problems are you could be waiting a long tome for something to be fixed that no one knows about.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro