Author Topic: New program update! [4.8.1296]  (Read 12352 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
New program update! [4.8.1296]
« on: November 27, 2008, 11:51:35 AM »
Howdy,

we have released yet another program update (4.8.1296) - probably the last one in this series of updates.
Changes are minor, but somewhat important for us.

The update size (if coming from v1290) should be fairly small.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Bluesman

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 901
  • Amiga Power!
Re: New program update! [4.8.1296]
« Reply #1 on: November 27, 2008, 12:22:17 PM »
Hi,sir! I wonder whether the next version will be 5.0? ???
                                                                     from China......

Welcome to the forum! :)

Please search before you ask something, many things have been discussed before!

Vlk said Avast 5 will be released sometime in H1 (first half of 2009)

http://forum.avast.com/index.php?topic=39327.msg330271#msg330271

Edit: Sorry, now I see that you ask for IF the next update will be 5.0, and not WHEN it will be released! I have to read better next time :)
« Last Edit: November 27, 2008, 12:25:40 PM by Bluesman »
"The blues are the roots, everything else is the fruits" -Willie Dixon

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8784
Re: New program update! [4.8.1296]
« Reply #2 on: November 27, 2008, 01:31:09 PM »
I installed the update on my XP Pro system.

Reboot required.
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: New program update! [4.8.1296]
« Reply #3 on: November 27, 2008, 02:18:18 PM »
Installed...
The best things in life are free.

Offline sunrisecc

  • Full Member
  • ***
  • Posts: 135
Re: New program update! [4.8.1296]
« Reply #4 on: November 27, 2008, 02:24:07 PM »
Installed on 2 XP and 1 Vista computers.
Seymour

Offline Rumpel

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 953
  • The poster formerly known as - Rumpelstiltskin®
Re: New program update! [4.8.1296]
« Reply #5 on: November 27, 2008, 02:29:43 PM »
The below quote is from the revision history is for lazy people. ;)
Quote
Version 4.8.1296
November 26, 2008

    * minor improvements in some unpackers
    * improvements in the false positive submission system
    * speed optimization in kernel-mode components
    * XML scan reports now generated in UTF-8 format (allow for non-Latin characters)

Offline Skywarrior

  • Jr. Member
  • **
  • Posts: 30
Re: New program update! [4.8.1296]
« Reply #6 on: November 27, 2008, 02:49:08 PM »
Does this updated address the problems it has with Online Armor??
Skywarrior

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
Re: New program update! [4.8.1296]
« Reply #7 on: November 27, 2008, 02:58:06 PM »
Installed here on Vista Ultimate.
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline onlysomeone

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1270
Re: New program update! [4.8.1296]
« Reply #8 on: November 27, 2008, 03:08:54 PM »
updated and again - like expected from avast! - no problems!  ;)

yours
onlysomeone

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84901
  • No support PMs thanks
Re: New program update! [4.8.1296]
« Reply #9 on: November 27, 2008, 03:33:45 PM »
I installed the update on my XP Pro system.

Reboot required.

If that is a question rather than a statement, then yes after a program update a reboot is normally required to effect any change to running drivers, etc. So considering this update has a mod to kernel-mode components a reboot would be required.

Does this updated address the problems it has with Online Armor??

Isn't that a problem with OA interacting with the web shield or blocking avast processes after an avast update rather than avast causing a problem with OA. There is a recent update for OA which is supposed to resolve its interaction with the web shield.

If not it should be continued outside this topic.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Skywarrior

  • Jr. Member
  • **
  • Posts: 30
Re: New program update! [4.8.1296]
« Reply #10 on: November 27, 2008, 03:49:22 PM »

Does this updated address the problems it has with Online Armor??

Isn't that a problem with OA interacting with the web shield or blocking avast processes after an avast update rather than avast causing a problem with OA. There is a recent update for OA which is supposed to resolve its interaction with the web shield.

If not it should be continued outside this topic.

I believe I had changed to OA and then read about the problems both softwares were having AFTER the Avast update, both here and in OA forum. No reason to get all defensive David, seems both should attempt to work together instead of apart and blaming each other like 1st graders. You yourself used the "after an avast update" which wold indicate that Avast was last. Both are great software packages
Skywarrior

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84901
  • No support PMs thanks
Re: New program update! [4.8.1296]
« Reply #11 on: November 27, 2008, 04:07:00 PM »
I'm not being defensive, I'm just an avast user like yourself with no affiliation or sway over Alwil software or OA developers. I was simply pointing out that there has been an OA update which is supposed to resolve an issue it had with the web shield.

There are also many topics relating to how to ensure OA allows avast's updated on the reboot, such as putting it into learning mode (was one suggestion), so the potential solutions are out there, to stop OA blocking changed components of avast without any pop-up notification on a changed component, so this wouldn't just happen with avast but other program updates if they become active on boot or connect to the internet, etc.

Which is why I suggested continuing in another topic so as not to drive this one off-topic not an attempt to silence you or be defensive.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
Re: New program update! [4.8.1296]
« Reply #12 on: November 27, 2008, 04:19:25 PM »
Couple of things I am seeing with the avast! 1296 and the latest OA beta.  I have been running with OA mail shield and web shield off and avast! mail shield off because of issues with OA/avast!
1) After reboot, I found that the OA rule to allow ashwebsv.exe had changed to "block" untouched by human hands, so only 2 providers were running.  But changed it back to allow, and the avast! web shield provider restarted without incident.   Otherwise no issues at reboot.
2) Mentioning changes to kernel mode components always gets my attention, so I turned the OA web shield back on-used to cause Opera to crash consistently when both are running.  Will report back if I see another crash, but so far nothing.  Did not work with same OA and avast!1290.  Problem as early as avast! 1229 and early OA Vista betas.
3) If I don't see another Opera crash, will try the email components and Stunnel again.
Will post the same info on the OA forum.
« Last Edit: November 27, 2008, 05:07:15 PM by sded »
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline TheSpirit

  • Jr. Member
  • **
  • Posts: 77
Re: New program update! [4.8.1296]
« Reply #13 on: November 27, 2008, 04:21:41 PM »
I believe I had changed to OA and then read about the problems both softwares were having AFTER the Avast update, both here and in OA forum. No reason to get all defensive David, seems both should attempt to work together instead of apart and blaming each other like 1st graders. You yourself used the "after an avast update" which wold indicate that Avast was last. Both are great software packages
Sounds like a general firewall/HIPS problem rather than an OA problem to me. Any firewall/HIPS should block new versions of a program until allowed by the user. OA has a whitelist with known, trusted applications. Maybe some updates to the list were missing?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84901
  • No support PMs thanks
Re: New program update! [4.8.1296]
« Reply #14 on: November 27, 2008, 05:30:58 PM »
Yes they should block changed processes but to do so without notifying the user leaves them totally in the dark other than they now have a problem. The user isn't getting the opportunity to allow the changed elements as they aren't notified.

My firewall Outpost Pro notifies me of changed elements with a pop-up and I can allow them, it doesn't just block and say nothing.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security