Author Topic: Exchange crashes after 4.8.1049 program update  (Read 41743 times)

0 Members and 1 Guest are viewing this topic.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11815
    • AVAST Software
Re: Exchange crashes after 4.8.1049 program update
« Reply #30 on: December 11, 2008, 04:40:28 PM »
I did send Vlk a dump created just 5 seconds after the event occurred. Since the dump is half a gigabyte in size, and the Avast "Incoming" directory is write-only, I don't know yet whether my upload was successful.

Hello,

I don't know if you've communicated with Vlk by e-mail, but the upload on the FTP is only 2 megabytes in size - i.e. it's not complete.
Could you possibly try to upload again? (or, if you have a webspace of your own, put it there for download, probably in a form of a password-protected archive?)
Thanks.

kwg

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #31 on: December 11, 2008, 04:52:00 PM »
I don't know if you've communicated with Vlk by e-mail, but the upload on the FTP is only 2 megabytes in size - i.e. it's not complete. Could you possibly try to upload again? (or, if you have a webspace of your own, put it there for download, probably in a form of a password-protected archive?)

I am currently uploading the file to a different server. I will let Vlk know when the upload is complete and how to retrieve the file.

kwg

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #32 on: December 11, 2008, 08:20:31 PM »
I am currently uploading the file to a different server. I will let Vlk know when the upload is complete and how to retrieve the file.

I have e-mailed Vlk with instructions for retrieving the file from my server.

together

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #33 on: December 12, 2008, 10:20:00 AM »
We're experiencing the same, more details:

1) emails are being sent out just fine.
2) incoming emails are sitting on the pending queue and not being delivered to local mailboxes.
3) event log is showing IMF being restarted, which i suspect is due to a restart of the smtp service more than anything.
4) this has happened since avast auto-updated on the windows 2003 sbs on sunday. Monday morning, start of business, was a firefighting session of trying to get ever growing queues to deliver.
5) all this was solved by disabling the local exchange and smtp scanners in avast. queue sizes dropped to nothing almost straight away.

The current result is that we are getting email delivered locally, but not virus scanned however. I've not seen requirement to uninstall avast. Just disabling the exchange and smtp scanner seems to fix it (after the smtp service is restarted).

Note however, that on reboot of the server, avast will be restarted again and delivery will fail once more.

Meneerik

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #34 on: December 15, 2008, 01:54:04 PM »
Same problem here...

SBS2003 UK SP2.

Quick solution when no mail is deliverd anymore.

disable avast
start=>run=>issreset
then restart the mailstore
then from the Exchange systemmanager go to => servers => {servername} => queues
Right klik Messages pending submission and choose freeze.. Then wait 5 seconds and then klik it again and choose force connection.

Now the messages will be deliverd again......



kwg

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #35 on: December 15, 2008, 05:05:58 PM »
Quick solution when no mail is deliverd anymore.

I find that the following two-step procedure is sufficient to restore delivery:

1. Restart the Microsoft Exchange Information Store service.
2. Force a connection with the Pending queue.

The Avast Exchange provider restarts immediately on its own after Step 1.

Meneerik

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #36 on: December 15, 2008, 05:16:59 PM »
Quick solution when no mail is deliverd anymore.

I find that the following two-step procedure is sufficient to restore delivery:

1. Restart the Microsoft Exchange Information Store service.
2. Force a connection with the Pending queue.

The Avast Exchange provider restarts immediately on its own after Step 1.


sometimes an ISSRESET is necessary ;)




Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Exchange crashes after 4.8.1049 program update
« Reply #37 on: December 16, 2008, 11:46:43 AM »
Guys, just a small status update.

We're still investigating the issue. Hopefully, there will be a fix in the upcoming couple of days.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Exchange crashes after 4.8.1049 program update
« Reply #38 on: December 16, 2008, 12:01:08 PM »
BTW one thing to try:

please go to avast settings, "Update (Basic)" page, click Details, and uncheck the "Enable" box in the "Push iAVS" section. Confirm with OK, and monitor if it makes any difference.


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

alfonz

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #39 on: December 16, 2008, 01:23:17 PM »
 Try this

http://support.microsoft.com/kb/843545

and disable transport level in Avast task->Resident protection ->Exchange2000/2003 Scanning settings.

...maybe
« Last Edit: December 16, 2008, 01:28:28 PM by alfonz »

Meneerik

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #40 on: December 16, 2008, 02:31:33 PM »
BTW one thing to try:

please go to avast settings, "Update (Basic)" page, click Details, and uncheck the "Enable" box in the "Push iAVS" section. Confirm with OK, and monitor if it makes any difference.


Thanks
Vlk

I'm going to try it.. I will report the results in about 4 hours...

ToddU

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #41 on: December 16, 2008, 03:48:21 PM »
Okay.  I've unchecked the iAVS box.  We'll see if it works.  If not I'll try the hotfix noted in the MS link above.

Meneerik

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #42 on: December 16, 2008, 04:29:18 PM »
BTW one thing to try:

please go to avast settings, "Update (Basic)" page, click Details, and uncheck the "Enable" box in the "Push iAVS" section. Confirm with OK, and monitor if it makes any difference.


Thanks
Vlk


this trick didn't work..


Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Exchange crashes after 4.8.1049 program update
« Reply #43 on: December 16, 2008, 04:57:30 PM »
OK, one more thing to try:

1. disable the MS SMTP 2000/2003 provider in avast ("Terminate" it); keep the Exchange 2000/2003 provider enabled
2. use iisreset to restart the inetinfo.exe process (which hosts the SMTP service).


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Meneerik

  • Guest
Re: Exchange crashes after 4.8.1049 program update
« Reply #44 on: December 16, 2008, 05:19:40 PM »
OK, one more thing to try:

1. disable the MS SMTP 2000/2003 provider in avast ("Terminate" it); keep the Exchange 2000/2003 provider enabled
2. use iisreset to restart the inetinfo.exe process (which hosts the SMTP service).


Thanks
Vlk

I'm going to try it.. I will report the results in about 4 hours...