Author Topic: The AAVM subsystem detected an RPC error!  (Read 10574 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67199
Re: The AAVM subsystem detected an RPC error!
« Reply #15 on: January 03, 2009, 12:09:22 PM »
The best things in life are free.

MegaShark

  • Guest
Re: The AAVM subsystem detected an RPC error!
« Reply #16 on: January 05, 2009, 10:52:45 PM »
Unfortunately, after several restarts and enabling the troubleshooting option "Delay loading of avast! services after other system services", I still see the red sign and I have no real time protection.

Can you guys help me out?

MegaShark

  • Guest
Re: The AAVM subsystem detected an RPC error!
« Reply #17 on: January 06, 2009, 11:11:01 PM »
This is the message I got when trying to enable Avast through Vista's security centre.
Can you guys help me out?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88169
  • No support PMs thanks
Re: The AAVM subsystem detected an RPC error!
« Reply #18 on: January 07, 2009, 01:30:27 AM »
Looks more like a corrupt installation than anything like the subject of this Topic.

Try a repair of avast. Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow.

If that doesn't work try, a clean reinstall.
Download the latest version of avast http://www.avast.com/eng/download-avast-home.html and save it to your HDD, somewhere you can find it again. Use that when you reinstall.

Download the avast! Uninstall Utility, find it here and save it to your HDD.
1. Now uninstall (using add remove programs, if you can't do that start from the next step), reboot.
2. run the avast! Uninstall Utility, reboot.  If step 1 failed it may be necessary to run this from safe mode, once complete reboot into normal mode.
3. install the latest version, reboot.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

MegaShark

  • Guest
Re: The AAVM subsystem detected an RPC error!
« Reply #19 on: January 08, 2009, 11:33:23 PM »
Looks more like a corrupt installation than anything like the subject of this Topic.

Try a repair of avast. Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow.

Did that before when someone posted that solution, no luck.


If that doesn't work try, a clean reinstall.
Download the latest version of avast http://www.avast.com/eng/download-avast-home.html and save it to your HDD, somewhere you can find it again. Use that when you reinstall.

Download the avast! Uninstall Utility, find it here and save it to your HDD.
1. Now uninstall (using add remove programs, if you can't do that start from the next step), reboot.
2. run the avast! Uninstall Utility, reboot.  If step 1 failed it may be necessary to run this from safe mode, once complete reboot into normal mode.
3. install the latest version, reboot.


It worked, avast is back in action... I wonder what might have caused this...
« Last Edit: January 09, 2009, 07:24:04 PM by MegaShark »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88169
  • No support PMs thanks
Re: The AAVM subsystem detected an RPC error!
« Reply #20 on: January 09, 2009, 12:28:23 AM »
It doesn't take much for a computer to cause some corruption, normally after a crash though. It is however for the most part a very fruitless exercise trying to find out why.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

MegaShark

  • Guest
Re: The AAVM subsystem detected an RPC error!
« Reply #21 on: January 09, 2009, 07:24:17 PM »
Thanks! All is well now...!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88169
  • No support PMs thanks
Re: The AAVM subsystem detected an RPC error!
« Reply #22 on: January 09, 2009, 07:31:52 PM »
You're welcome, glad that youyr system is running as it should now.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security