Author Topic: Mailmate Antispam  (Read 19202 times)

0 Members and 1 Guest are viewing this topic.

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #15 on: April 28, 2004, 10:30:57 AM »
Sean
I did try quickly last night but it was late. No joy but I did try different ways. I also tried altering the ports on Outlook and Mailmate but got confused in the end. There is a facility for specifying which port to use so that is easy also one under Advanced tab in Properties.
Can't quite be sure you meant to alter Outlook when you said
"
Assuming for your Mailmate config your current pop user name in Outlook looks like jsmith@yourisp.com,  modify your pop user Name to be:

jsmith#yourisp.com@127.0.0.1:8110
"

Whowever I have tried all ways and everything is OK until I make this alteration. I have probably got something wrong around this area.

Aplogies for not grasping this immediately but as I said I am no expert with computers, but need to keep trying
Working till about 6pm GMT.
Thanks again
Regards
Clive


Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #16 on: April 28, 2004, 01:56:16 PM »
Clive,

Sorry it is so difficult.  Debugging multiple proxies gets difficult.

Best way to start is get one of them working and tested before trying to chain a second one.

So if you dont mind please start with configuring Outlook and Mailmate to work and ignore avast for now.  Given that you can change the pop server port that Mailmate works on, the first step I would ask is the you pick an unused port (like 7110) for Mailmate to listen on and then config your Outlook to work with Mailmate by changing your pop server port in Outlook to 7110 and the pop user name to YourPopName@YourISP.com  e.g. you@pipex.com (whatever worked for Mailmate before you tried chaining avast)

Once this is done and tested to be working we are ready to go to then next step.  

I am just leaving for work now and should be able to get back on about 11 AM NY time  -0400 hours.  If possible send me email and let me know if you get Outlook and Mailmate working along with the port and pop user name in Outlook and when I sign back on I will figure out the config changes to insert avast in the chain so that all mail is filtered before getting to Mailmate.

Sean D

edit: Please double check the Mailmate docs and make sure it does not use the '#' as part of the seperator char when you set up the pop user name in Outlook. (The online docs says it uses the '@' char but it may use a secondary one.).  Also when changing the port for Mailmate to listen on you may have to reboot for it to take effect (I dont know).

« Last Edit: April 28, 2004, 02:06:36 PM by seand »

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #17 on: April 28, 2004, 06:24:15 PM »
Sean
I tried as you suggested with 7110 but got an error mesage saying another programme was using this port. I then changed both ports to 8110 and everything seemed to go through the sequence fine with no error message.
Mailmate only appears to change pop settings to 127.0.0.1 and alters my username to my email address. This is not the same as my pipex username which is a combination of letters and numbers. I remember SpamPal as being more complicated and using two @ chars.
I suppose Maimate picks up the mail using my Pipex settings and then Outlook picks it up from MailMate using my email address and 127.0.0.1
Am I correct? All we have to do now is to link in Avast ???
Well that's me lost!!!
Cheers
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #18 on: April 28, 2004, 07:20:48 PM »
Clive,

OK, based on your post I "think" that Outlook and Mailmate are now running correctly and avast is not scanning your mail yet,  is that right?

Now if you dont mind please post  just what the settings are for each of the following:

Outlook: what is the pop3 port number?
Outlook: what is the pop server?
Outlook: what is the pop user name?

Mailmate: what pop port is it listening on?

With that info we should be able to put avast in the loop and handle multiple accounts (hopefully)

If you can please take a look at the avast4.ini and tell me what the PopListen and DefaultPopServer entries are right now (before we change them)

Sean D



Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #19 on: April 28, 2004, 07:54:48 PM »
Sean
Incoming Mail Port      8110
Incoming Pop3 Server   127.0.0.1
Pop username              csturnbull@dsl.pipex.com

Avast4.ini I will email this for you

Is that OK
Cheers
Clive

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #20 on: April 28, 2004, 08:13:51 PM »
Sean
Forgot to say Outlook & Mailmate working fine.
Cheers
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #21 on: April 28, 2004, 09:38:12 PM »
Clive, From looking at your avast4.ini it appears you have not yet configured the Internet Mail Provider in the avast! On Access scanner.  The complication going on here is that I suspect you have enabled the Exchange/Outlook Plugin and what we are doing here is trying to treat Outlook as a "generic" Internet mail client since that is how it is behaving with Mailmate.

Let's try faking it out by putting this section in the avast4.ini

[MailScanner]
ShowTrayIcon=0
UseDefaultSmtp=1
AutoSetProtection=0
PopListen=127.0.0.1:110
Trust=127.0.0.1
DefaultPopServer=dsl.pipex.com

Once you have done this save the file and try starting the Internet Mail Provider in the avast! On Access scanner.

If it starts and there are no port conflict messages shown by anything then the last thing to do is to go back into Outlook, change  pop user name from csturnbull@dsl.pipex.com to ----> csturnbull#dsl.pipex.com@127.0.01

This should now put avast! in the chain.  I imagine that with the Exchange/Outlook plug-in enabled you will actually have your mail in Outlook scanned by avast twice, once on the way in from the server (by Internet mail Provider before it is scanned by Mailmate) and the second time when it arrives in your Inbox by the Exchange/Outlook Provider.  You probably can/should disable the Exchange/Outlook Provider-in but I do not know what additional services it provides Outlook users so lets check with avast! Tech Support on that.

I hope this works for you now.  Hang in there, its a learning experience for me too and I am enjoying it, hope you are.

Sean D
« Last Edit: April 28, 2004, 10:47:20 PM by seand »

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #22 on: April 28, 2004, 10:44:42 PM »
By the way Clive, I owe you an apology.  I completly missed the fact that with Outlook installed you were probably running the Exchange/Outlook plugin.  I don't run Outlook anymore and had chosen not to install that feature weeks ago.

I dont know how the Exchange plugin works, but suspect it does not act as a proxy but rather scans the outlook.pst file as mails are added during the download.  If it does act as a proxy there might be a port conflict on 110 but for the proxy filtering to work with Mailmate we need the Internet Provider to use that port, so whether we like it or not the Exchange plugin may have to be disabled for any of this to work.  Your mail will be scanned by the Internet Mail Provider in the proxy chain so I dont think you lose any protection by doing it this way.

Again, sorry for not paying full attention.

Sean D
« Last Edit: April 28, 2004, 10:44:58 PM by seand »

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #23 on: April 28, 2004, 11:56:52 PM »
Sean
No problem, I am really forced into the Outlook thing as My PDA & Notebook both sync with it. I used to use Poco Mail which was fine but it seemed a bit silly to not go along with the integration.
Update
All went well until I pressed send & receive on Outlook where I am prompted for a password because of altering the username, I presume
anyway.
Sorry for the delay someone called.
Regards
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #24 on: April 29, 2004, 01:56:49 AM »
Clive,

Yes, when you change the user name Outlook will/may prompt you the first time for a password but you should be able  click on the "remember" option and not have to do that again.

Besides all that does the chain work now (I am dying to know)

You can verify by checking the headers of the emails, you should be able to find two avast headers at the bottom of the header section.  If Mailmate inserts headers those should be below the avast ones, demonstrating that the mail was filtered by avast them by Mailmate.

Sean D

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #25 on: April 29, 2004, 02:05:27 AM »
Sean
I don't know yet as this password will not be accepted and just gives a mail delivery error which pops back up everytime I ok it
Cheers
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #26 on: April 29, 2004, 11:22:57 AM »
If I remember correctly Outlook pops up that Password Prompt on most errors but when you click on cancel and then view the details of the failed session you may see a better explanation of the problem e.g. "Cannot connect to server", etc.  

Debugging multiple proxies in a chain is troublesome but you do know ithat Mailmate was  working before you put avast in the chain so the next thing to do is to take Mailmate out of the chain and test  with Outlook and the avast proxy alone (no spam filtering by Mailmate).

To do that you would change the Incoming Mail Port in Outlook back to 110 (should be 8110 before the change) and change the pop user name to csturnbull#dsl.pipex.com  (should be csturnbull#dsl.pipex.com@127.0.0.1 before this change)


This config will cause Outlook to bypass Mailmate completly (Mailmate is listening on 8110, and the avast Internet Provier is listening on 110)

Try collecting mail (it will not be filtered for spam, but you will be testing the avast Internet Mail Provider.

To summarize:

If all proxies are setup and running correctly all the following tests shoud work:

Outlook using Maimate only:
Incoming Mail Port      8110
Incoming Pop3 Server  127.0.0.1
Pop username              csturnbull@dsl.pipex.com

Outlook using Avast Internet Mail only:
Incoming Mail Port      110
Incoming Pop3 Server  127.0.0.1
Pop username              csturnbull#dsl.pipex.com

Outlook using Mailmate chained to avast Internet Mail
Incoming Mail Port      8110
Incoming Pop3 Server  127.0.0.1
Pop username              csturnbull#dsl.pipex.com@127.0.0.1

Things to look for.

Is the Internet Mail Provider running in the avast On-Access Scanner?
Is there any port conflict on 110 preventing avast from running?
After entering the password and clicking OK at the Outlook Password prompt if the password prompt reappears immediately click on Cancel and view details of the error.

Sean D



Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #27 on: April 29, 2004, 12:27:03 PM »
Sean
Well test 1 works fine but not test 2 which I think points to a problem with Avast and Outlook. I have shutdown mailmate altogether, still an error which reads "unable to connect to server 127.0.0.1 err 0x800ccc0e"
Couple of things I would like to mention.
It is Mailmate that changes my popserver name to csturnbull@dsl.pipex.com which is usually ****90@dsl.pipex.com given to me by Pipex also we have changed the avast4.ini from how it was. I have altered these back and to  try but still the same error so I feel that it is something to do with Avast setup. Would like to mention that as it was originally after installing Avast and already having Mailmate, Avast was scanning my inbox ok.
I feel I am putting you to a lot of trouble but it would be really good to see it setup to work. Sorry I am not a bit more savvy! That way I could be more help.
Regards
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #28 on: April 29, 2004, 12:58:58 PM »
Clive,

I am willing to hang in there if you are!

Just to backtrack a bit.  If you revert to the original settings and just use Outlook and Mailmate is the avast Exchange/Outlook plugin still scanning you inbox? (sure hope so!)

The error reported by Outlook might mean something else already is listening to port 110 which means avast cannot open it and get in the chain.

Avast needs your real user name to be used in order to work so using the test scenario #2 (Outlook with avast only) that I outlined above you should try putting ****90@dsl.pipex.com#dsl.pipex.com in the user name and port 110 for testing Oultook with avast only,

This assumes that your pop user name is ****90@dsl.pipex.com and pop server is dsl.pipex.com

If this is the case and the test works, the problem we are experiencing is that Mailmate cannot deal correctly with an "@" in the user name because it is using the "@" as a seperator.  The only other alternative is to ask Mailmate if it can be configured to use a different seperator char.

Sean D
« Last Edit: April 29, 2004, 02:13:28 PM by seand »

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #29 on: April 29, 2004, 01:32:06 PM »
If there is an "@" in your pop user name there is another alternative that might work but only  for your main account, not multiple, so if that is the case I can figure out the avast settings to do that if you want to try. This all depends if the test2 with Outlook, your real pipex user name  and avast only, worked based on the previous post.

edit:  Actually if you get test2 to work with the new settings, there may be a way to insert avast in the Mailmate chain for ALL accounts at dsl.pipex.com but not for other isp's

Sean D
« Last Edit: April 29, 2004, 02:10:08 PM by seand »