Author Topic: Web Shield Question  (Read 2047 times)

0 Members and 1 Guest are viewing this topic.

Offline jimb11

  • Sr. Member
  • ****
  • Posts: 221
Web Shield Question
« on: February 14, 2009, 06:21:32 PM »
When web shield is enabled I can surf the internet but if I disable it kills my internet! Can someone tell me what could be causing this?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86674
  • No support PMs thanks
Re: Web Shield Question
« Reply #1 on: February 14, 2009, 07:07:02 PM »
That is unusual it is usually the reverse as a firewall could be blocking the web shies (ashWebSv.exe).

This just doesn't make sense to me, but why would you want to disable it ?

What is your OS ?
What other security applications do you have ?
What is your firewall ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline jimb11

  • Sr. Member
  • ****
  • Posts: 221
Re: Web Shield Question
« Reply #2 on: February 14, 2009, 07:20:23 PM »
Windows vista
Windows firewall

I'm so confused what should my ie 7 proxy settings be? What should my avast proxy settings be?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86674
  • No support PMs thanks
Re: Web Shield Question
« Reply #3 on: February 14, 2009, 07:30:41 PM »
With Vista you shouldn't need to have any proxy settings in IE7 as the avast web shield proxy is transparent. So if you set your browser to use the web shield proxy and then terminate the web shield proxy, guess what is going to happen. Yes, you guessed it no connection as it is trying to use a proxy that isn't running.

So reverse the changes you made in IE7, there is no need to declare a proxy.

The same is true of the avast web shield, no change from the default settings.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline jimb11

  • Sr. Member
  • ****
  • Posts: 221
Re: Web Shield Question
« Reply #4 on: February 14, 2009, 07:40:23 PM »
That makes sense but when I do that the scanned count is 0 and the last scanned is blank. Does that mean that the web shield isn't working?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86674
  • No support PMs thanks
Re: Web Shield Question
« Reply #5 on: February 14, 2009, 08:51:27 PM »
It doesn't mean the web shield isn't working, just that it isn't scanning your browser downloads.

Do you use any other application that uses a proxy, e.g. ad blocker or web accelerator, etc. ?

Does your ISP insist you use a proxy ?

As they are the only reasons I can think of that would mean the web shield has no content to scan. I don't know if you have made any other tweaks to avast, etc. (based on your question as to what should your avast proxy settings be) ?

If you have no other proxy settings (as in my questions) that you would have to co-ordinate with the web shield proxy, then it could be a painful exercise in trying to pin down what it might be. It may be quickest to do a clean reinstall of avast, thereby setting everything back to its defaults.

Download the latest version of avast http://www.avast.com/eng/download-avast-home.html and save it to your HDD, somewhere you can find it again. Use that when you reinstall.

Download the avast! Uninstall Utility, find it here and save it to your HDD.
1. Now uninstall (using add remove programs, if you can't do that start from the next step), reboot.
2. run the avast! Uninstall Utility, reboot.  If step 1 failed it may be necessary to run this from safe mode, once complete reboot into normal mode.
3. install the latest version, reboot.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security