Author Topic: WebShield blocks browsing  (Read 21599 times)

0 Members and 1 Guest are viewing this topic.

Offline greendager

  • Newbie
  • *
  • Posts: 6
Re: WebShield blocks browsing
« Reply #15 on: February 24, 2009, 04:05:47 PM »
I connect to a wireless broadband net work that to my knowledge does not use proxy. I found a link to a patch on the avast technical support page  it was for people who where having this same problem with vista, but as it was the same problem I am having I tried it, but it didn't fix it.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: SOLUTION FOUND!
« Reply #16 on: February 25, 2009, 01:20:07 AM »
Plenty of people on this forum use avast!, Threatfire, and the Firewall component of Comodo CIS in combination (as they use Avira, AVG, PC-Tools AV, etc.)

Hi, Vladimir. My point exactly. In perusing this forum re. Webshield blocking the browser, I see Avast representatives constantly proposing the removal of Threatfire and Comodo...with statements like  "Serious conflicts with Avast". I don't think you've read my original posts very well, or you'd not respond with a statement that totally agrees with my posts.

Be that as it may, I think Avast is excellent, but some "experts" here not so excellent.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: WebShield blocks browsing
« Reply #17 on: February 25, 2009, 01:30:07 AM »
Since I updated the avast program to 4.8 I am unable to browse any web pages with the web shield turned on. I've tried searching the forums and help topics for answers but I can't find one that works. Any ideas as to what is causing this problem and how to fix it?

Have you tried my solution yet, posted in this thread? (I am the OP.) My solution, which may  well work for you, is to change the port that Webshield checks, from 80 to any other. Here's how:

1) Right-click on the Avast "a" icon in your Windows quicklaunch toolbar, and select "On-Access Protection Control".

2) Select "details" to call up a more detailed menu. Then scroll down on the left column to the final option, "Webshield" and click on that.

3) Select the "customize" button on the right side.

4) The first tab option "basic" should show, if not, click on it. See the number 80 for "redirected http port(s)"? Change it to any other number, I put "12020" in there.

5) Save the change by clicking "OK" twice, and you're good.

Now, see if you can browse the web again. If not, you have some other problem...but still, keep the new port option intact, anyway.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: WebShield blocks browsing
« Reply #18 on: February 25, 2009, 01:36:40 AM »
The fact that you don't appear to understand how to do this (allow a process permissions) in comodo is what the problem is and when you find how to do that I believe you will be able to browse as normal. I can't help in that regard as I don't use comodo.

What drivel! I do understand how to change permissions for any program in Comodo. But if you bothered to read my post in full, you'll see that permissions were already granted for Alwil software, dufus! And you will also learn that I resolved the issue, no thanks to the lousy "help" I was offered. The answer was so simple (change the http port for Webshield), I am suprised that was not a suggestion offered by anyone here. It should have been the first! So you have me to thanks for resolving what seems to be a common problem for Avast users, for which many wrong answers have been posted.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: SOLUTION FOUND!
« Reply #19 on: February 25, 2009, 01:42:20 AM »
Both links quoted above refer to superseded Threatfire and Comodo Firewall product versions discussed by people whose knowledge is not quantifiable and of questionable value, apparent  in their descriptions of how Threatfire works and the 'solution' which effectively disables the avast!

Hogwash. Those links I gave, present a simple solution to unblock your browser with Avast webshield running. It is simply to change the http port webshield uses, from 80, to another number. In fact, my very clear solution is right in my message that you quoted, the same message where you accused me of not knowing what I'm doing!

Granted, the links may not have been as recent as the ones you gave...but what does it matter when the provided the correct answer? Oh, and BTW, how nice of you for thanking me for getting the solution so quickly, that others may not suffer the obfuscation  and disinformation that certain "experts"  prefer to spew.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 84114
  • No support PMs thanks
Re: WebShield blocks browsing
« Reply #20 on: February 25, 2009, 01:54:27 AM »
And if you had read many of the posts relating to possible firewall blocking it advises that you delete the entry if present and force the firewall to ask permission again when you browse when the web shield (ashWebSv.exe).

There are many occasions when a firewall even with apparent permissions granted is blocking Zone Alarm more than most, but I have also had it happen on my own firewall and the deletion of the entry forcing the firewall to ask permission, recreating the entry.

As to why we didn't suggest the change of redirect port, because as has already been said that effectively disabled the web shield so we might as well have offered that as a suggestion. But that isn't the point we have been trying to get things working 'with' the web shield enabled and not as your title suggests blocking browsing.

So at almost 1a.m. here I'm calling it a day.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.9.2437 (build 20.9.5758.0) UI-1.0.579/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: WebShield blocks browsing
« Reply #21 on: February 25, 2009, 02:09:39 AM »
For Firefox users - Tutorial - Web Shield Proxy Set-up for Firefox

Doesn't work, when Webshield is access port 80 (the default). As I said twice before, change that port to any other, and you will never have your browser blocked. Install Threatfire as an adjunct to Avast, and you'll be quite  secure. I recommend Comodo firewall pro, to complete tight-as-a-drum security.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: WebShield blocks browsing
« Reply #22 on: February 25, 2009, 02:22:20 AM »
And if you had read many of the posts relating to possible firewall blocking it advises that you delete the entry if present and force the firewall to ask permission again when you browse when the web shield (ashWebSv.exe).

I made it very clear already, that all Alwil software is in the safe zone of my firewall. I just did a triple-check: yes, ashWebSv.exe is also there, and has been. Even so, using port 80 for webshield effectively blocks my web browsing (except for https of course). Even when I set up my Firefox per Avast's online video instruction (returning to port 80 for webshield)...my browser remains blocked.

FYI, my comodo firewall has NEVER popped up against ashWebSv.exe...so that has never been the problem, ever. My browser gets blocked, nonetheless. Posters here and in other topic areas, persist in telling users w/this problem to remove Threatfire and or Comodo, claiming they are major obstructions to running Avast. This is totally wrong, yet you have NOT criticized them in doing so...including right here in this thread. Yet  you persist in dismissing my solution.

Now how pathetic is that?

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: WebShield blocks browsing
« Reply #23 on: February 25, 2009, 06:14:11 AM »
About as pathetic as your uninformed, ignorant and abusive posts.

We are (I wonder under Heaven why) still trying to assist you despite your "I know better than you" attitude.

We really want you to succeed with avast ... if you do not want to please go somewhere else and let them deal with your attitude.

If you want avast to work for you ... please take a deep breath ... calm down and at least work with us to see if we can get you working.  Please understand that we know avast far better than you do ... at least for now.   

Can we work together ... or do you need to move on?

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1878
    • AVAST Software
Re: WebShield blocks browsing
« Reply #24 on: February 25, 2009, 09:27:53 AM »
Hi,
it was a real mistake that we put the "Redirected port" field on the first tab in WebShield settings. Now I now it and it will be removed in future versions.

Therefore we can not blame people that don't know what they are talking about for such non-sense advice like pewterbot9 or other similary confused users on Comodo forums are suggesting.

Pewterbot9: If you want to protect your browsing, than Web Shield must protect the port 80 - known as HTTP port, or simply Web port. You can of course change the "80" to anything else, if you want to protect communication on other ports. As I currently don't know about any application using port 12020, that you are suggesting I am sure with this setup WebShield would not do anything. It will just wait for the traffic on 12020, but since there is none, nothing will ever happen. You can terminate the whole WebShield provider, same effect but uses even less resources.

I have just one plea on you: please stop repeting this non-sense. It might hurt other users and disable WebShield for them in a similar way that it already hurt your understanding of how avast! WebShield works.

Secondly, WebShield needs to connect with your browser and connect with the web pages on the Internet. If is unable to do that, your browsing will be blocked. Blocking network access for certain applications that is the typical task of firewall. Hence the first step is to verify that this is not the case. We usually suggest to remove the WebShield process from the firewall database (ashWebSv.exe), stop the provider and start it again. Now the firewall should either popup or automatically detect it as safe program and reenter it into its database. If this happens we at least know that WebShield is trying to make some network related work (connect, accept connections) and that this is working.

Have you done that? Can you configure you firewall to display you the popup? What was on the popup - accepting connection from localhost or connecting to the Internet, opening listening port on 12080? This information can help us guess what is happening on your system.
 

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: WebShield blocks browsing
« Reply #25 on: February 25, 2009, 10:01:00 AM »
While we anticipate the response of the original poster I want to thank the participation of a member of the avast team in this discussion.

Many thanks Lukas,

Alan   

Jahn

  • Guest
Re: WebShield blocks browsing
« Reply #26 on: February 25, 2009, 10:59:15 AM »
Comodo developers have acknowledged an issue between CIS 3.8x and Avast. A fix is forthcoming.

Comodo Forum

Re: Avast Forum

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: WebShield blocks browsing
« Reply #27 on: February 25, 2009, 01:20:37 PM »
Comodo developers have acknowledged an issue between CIS 3.8x and Avast. A fix is forthcoming.
Why does this always happen? ??? ::)
I've gave up on Comodo due to a lot of issues with avast WebShield. Sooner or later, problems...
The best things in life are free.

Offline greendager

  • Newbie
  • *
  • Posts: 6
Re: WebShield blocks browsing
« Reply #28 on: February 25, 2009, 10:59:53 PM »
I never had to set any kind of proxy stuff up when I first connected so I'm pretty sure that there is no proxy problems. I read in one of the above posts about forcing avast to ask the fire wall for permission, again, but I don't see where you say how to do this.  ???

Jahn

  • Guest
Re: WebShield blocks browsing
« Reply #29 on: February 26, 2009, 02:44:24 AM »
Comodo developers have acknowledged an issue between CIS 3.8x and Avast. A fix is forthcoming.
Why does this always happen? ??? ::)
I've gave up on Comodo due to a lot of issues with avast WebShield. Sooner or later, problems...
I guess I'm one of the lucky ones - never had a problem with Comodo on 2 XP machines in 2¬Ĺ years.

Edit: BTW, the current problem seems to be with Defense+, not the firewall.
« Last Edit: February 26, 2009, 02:50:30 AM by Jahn »