Author Topic: WebShield blocks browsing  (Read 21571 times)

0 Members and 1 Guest are viewing this topic.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
WebShield blocks browsing
« on: February 23, 2009, 12:29:31 PM »
I'm running Avast! 4,8 free home version on Windows XP-SP3, (Firefox 3 browser, Comodo Firewall 3.8, Threatfire 4.1), and I do not use a proxy. Just installed your excellent program less than an hour ago:

Web Shield blocks most URL's...at least, I can't log onto any sites, until I Terminate it. Even "Pause" will not unblock my web access. None of the pages or sites I'm talking about are pornographic, or in any other way, suspicious. For example:

http://www.pcworld.com
http://ezinearticles.com

I can, however, log onto my Google e-mail, which is secured, as in "https". I do NOT have URL blocking turned on.

(I also tried Web Shield "on" but with web scanning disabled. Still, I couldn't load those pages. The only answer seems to be, to turn Web Shield off, entirely.)

I'm spanking new to Avast!, so perhaps the answer lies somewhere in the help files. However, I find it upsetting that the default setup causes over 98% of the web to be inaccessible! I think web shield is a great concept, but what good is it, under such an over-the-top blocking?

BTW: I've read some messages regarding same problem, and I assure you it has nothing to do with Norton, as I've never installed their product on my present system (Asus eee PC 1000HA, a fabulous "netbook". Same goes for ZoneAlarm. I have, however, tried out Avir and AVG antivirus software...but have uninstalled each, thoroughly (using a registry cleaner afterward). And Windows own firewall is definitely turned off, replaced by Comodo. I don't do P2P or torrent software, and I am a standalone system using dialup at home, wifi at public venues.

Thanks for your help...I think Avast! is great, regardless. (Maybe your program is haunted with a NanoPoltergeist? I know some good voodoo freeware on the dark side of cyberspace!)   :P

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: WebShield blocks browsing
« Reply #1 on: February 23, 2009, 01:54:05 PM »
Comodo Firewall and Threatfire are a serious candidate to connections issues with avast...
Check if ashWebSv.exe is allowed to connect into Comodo settings and try uninstall Threatfire to see if it is not conflicting with Defense+ from Comodo.
The best things in life are free.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: WebShield blocks browsing
« Reply #2 on: February 24, 2009, 01:55:22 AM »
Comodo Firewall and Threatfire are a serious candidate to connections issues with avast...

No way! What are the issues, specifically? I  can search for those topics on this forum, or you could post the links, if not an inconvenience.

Quote
Check if ashWebSv.exe is allowed to connect into Comodo settings and try uninstall Threatfire to see if it is not conflicting with Defense+ from Comodo.

How on goddess's green earth do I go about that? Why on earth would I allow ashWebSv.exe to connect into Comodo's settings? I don't capiche. Hopefully, there is a step-by-step instructional page for that...otherwise, I'm lost!  ???

Thanks for your efforts. Both Comodo and Threatfire are highly rated across the board, by many PC experts. So is Avast. But if push comes to shove, I'll remove Avast before I do either of the other two.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: WebShield blocks browsing
« Reply #3 on: February 24, 2009, 02:15:38 AM »
If you want avast to work for you then you need to cooperate.  The same is just as true for any other antivirus product.

The avast Webshield (ashWebSv.exe) works by intercepting the http calls made by your browser.  It then acts on behalf of your browser to make the connection so that it can scan the results before passing them back to your browser. 

So, just like you need to tell Comodo to allow your browser to access the Internet you must do the same for ashWebSv.exe. 

If you are using an email client and the avast Internet Mail provider you need to give permission in Comodo to ashMaiSv.exe and to allow avast virus updates to be obtained you need to allow svast.setup access in Comodo permissions.

By the way avast does not attempt to scan https connections (they whole point of them being that they are secured and cannot be scanned).

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: WebShield blocks browsing
« Reply #4 on: February 24, 2009, 03:14:37 AM »
If you want avast to work for you then you need to cooperate.  The same is just as true for any other antivirus product.

Cooperate? I haven't even gotten any suggestions yet...so stop demonizing me. That is plain rude. I just read your post, after more online research to this matter, and discovered the solution, which is NOT at all what you've suggested. Your original explanation was incomprehensible, period...so obviously I had to ask for details.

Quote
So, just like you need to tell Comodo to allow your browser to access the Internet you must do the same for ashWebSv.exe.

Glad to see you can speak in plain English, finally. Your assumption is that Comodo is blocking Avast's webshield, but I doubt it, as Comodo did not alert me about this. Therefore, it had no conflict with webshield in the first place. In fact, Alwill software is already listed in Comodo's trusted zone!

Quote
If you are using an email client and the avast Internet Mail provider you need to give permission in Comodo to ashMaiSv.exe and to allow avast virus updates to be obtained you need to allow svast.setup access in Comodo permissions.

I am definitely not using an emial client...I get all my mail via webmail services. My Avast updates work just fine, BTW, no doubt because Alwil software is already in Comodo's trusted zone.

Quote
By the way avast does not attempt to scan https connections (they whole point of them being that they are secured and cannot be scanned).

That makes sense...however the rest of your theories don't. Well, I had already composed an update to the issue, which I resolved on my own today. Now, after responding to your present message, I will post my update in a seperate message.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: WebShield blocks browsing
« Reply #5 on: February 24, 2009, 03:17:24 AM »
They are not theories ... they are pure fact. 

If you do not want to listen that is your choice.

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
SOLUTION FOUND!
« Reply #6 on: February 24, 2009, 03:19:34 AM »
 ;)

Couldn't find any messages in this forum re. "Comodo" or "Threatfire", when I used the embedded search engine. i KNOW those programs are discussed; the search engine is lacking.

So I googled "conflicts avast threatfire", and found the likely reason for the webshield glitch.

Two statements found in another forum:

http://forums.vnunet.com/message.jspa?messageID=1144195

--begin comments:

1) It turns out that there is a compatibilty problem between Avast and the latest update of Threatfire. To get around the problem you can either un-install one of them or do as I have done and pause the Web Shield in Avast.

2) ThreatFire was designed to work alongside conventional anti virus programs as it uses a `behavioural' method of detection. It was fine with Avast until ThreatFire was updated. It is only because Avast has it`s own WebShield which works in a similar fashion that there was a problem.

--end comments

Apparantly, Threatfire already has its own webshield...and since it is a most useful adjunct for any antivirus program already running, I will keep it, w/Avast's webshield turned "off". I'm sure the conflict will be resolved in the next update of either program.

I think it's a disservice to suggest removing Threatfire as the solution, scaring people from believing that with Avast's webshield turned off, your system is dangerously exposed. It most certainly is not, for Threatfire has it covered...and provides a more robust security than Avast! does, alone.

ADDENDUM

I did a web search for "avast comodo conflict" to discover others had the same problem w/Avast's webshield, and blamed it on a conflict w/Comodo's firewall. One person found a simple solution:

Change Webshield's http forwarding from port 80 to port 12020. In fact, you can change it to any port number, so long as it's not 80, and it should work just fine. I did that, and "voila": no more blocking web sites. I gleaned the answer from the following page:

http://forums.comodo.com/cfp_beta_corner/cfp_and_avast_web_sheild_ashwebsvexe_resolved-t11435.0.html

I checked ashWebSv.exe under Task Manager Processes: it's definitely running now! And I did NOT need to uninstall either Threatfire or Comodo. Seeing as this problem appears over and over again in Avast forums, I'm surprised the answer is not readily provided. Competitive product envy, perhaps?

Offline pewterbot9

  • Newbie
  • *
  • Posts: 13
Re: WebShield blocks browsing
« Reply #7 on: February 24, 2009, 03:29:59 AM »
They are not theories ... they are pure fact. 

If you do not want to listen that is your choice.

Nonsense. Pure fact? More like pure obfuscation. The solution is simple: just change the http port in webshield. THAT is pure fact, and I bet you knew it all along. To make Avast users paranoid of other excellent anti-malware programs smacks of competitive envy towards those products...likewise, for getting them to dance through hoops with convoluted and useless solutions, with the regular suggestion that one remove either "offending" program.

When ALL you need do is change the Webshield http port. And you don't know that, eh? I find THAT rather hard to believe...and you did not make that your first suggestion; in fact you never mentioned it at all.

Deception regarding your product in order to wipe out perceived competition does not make Avast look very good, now does it? Why would you feel the need to do that, if you really believe your product is excellent? Microsoft set a bad business precedent, that's for sure! Their example is not to be followed, if you regard your product as one that is reputable.

Sad to see you as a representative of Avast! You're not helping them any!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83982
  • No support PMs thanks
Re: WebShield blocks browsing
« Reply #8 on: February 24, 2009, 03:49:14 AM »
Alan doesn't work for Alwil software he is an avast user just like you and I, he volunteers of his time freely to help other avast users.

What he said is 'fact' the comodo firewall is most likely blocking ashWebSv.exe (it's what firewalls do deny access to new applications connecting to the internet) and two people have suggested that you have comodo allow the ashWebSv.exe permission to connect or no internet browsing.

The fact that you don't appear to understand how to do this (allow a process permissions) in comodo is what the problem is and when you find how to do that I believe you will be able to browse as normal. I can't help in that regard as I don't use comodo.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: WebShield blocks browsing
« Reply #9 on: February 24, 2009, 04:51:26 AM »
David,

thanks for your comments.  I hope that the poster will listen to you and Tech, as the members in this forum who have, over the years, provided the highest level of support to other users.  I still have to learn from the calm level of support that you and Tech provide to the users most certain in their lack of knowledge and most resistant to the help they suggest they need.   

Quote
When ALL you need do is change the Webshield http port. And you don't know that, eh? I find THAT rather hard to believe...and you did not make that your first suggestion; in fact you never mentioned it at all.

With complete respect to the poster, who (as a relatively new avast user) has to be totally technically unaware of the implications ... for anyone who follows this thread in the future  ... please understand that this is total nonsense ... it is most certainly the equivalent of just turning off the avast Webshield.  So please just ignore it. 
 

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1640
  • Super(massive black hole) Poster
Re: SOLUTION FOUND!
« Reply #10 on: February 24, 2009, 04:51:36 AM »
;)

Couldn't find any messages in this forum re. "Comodo" or "Threatfire", when I used the embedded search engine. i KNOW those programs are discussed; the search engine is lacking.

So I googled "conflicts avast threatfire", and found the likely reason for the webshield glitch.

Two statements found in another forum:

http://forums.vnunet.com/message.jspa?messageID=1144195

--begin comments:

1) It turns out that there is a compatibilty problem between Avast and the latest update of Threatfire. To get around the problem you can either un-install one of them or do as I have done and pause the Web Shield in Avast.

2) ThreatFire was designed to work alongside conventional anti virus programs as it uses a `behavioural' method of detection. It was fine with Avast until ThreatFire was updated. It is only because Avast has it`s own WebShield which works in a similar fashion that there was a problem.

--end comments

Apparantly, Threatfire already has its own webshield...and since it is a most useful adjunct for any antivirus program already running, I will keep it, w/Avast's webshield turned "off". I'm sure the conflict will be resolved in the next update of either program.

I think it's a disservice to suggest removing Threatfire as the solution, scaring people from believing that with Avast's webshield turned off, your system is dangerously exposed. It most certainly is not, for Threatfire has it covered...and provides a more robust security than Avast! does, alone.

ADDENDUM

I did a web search for "avast comodo conflict" to discover others had the same problem w/Avast's webshield, and blamed it on a conflict w/Comodo's firewall. One person found a simple solution:

Change Webshield's http forwarding from port 80 to port 12020. In fact, you can change it to any port number, so long as it's not 80, and it should work just fine. I did that, and "voila": no more blocking web sites. I gleaned the answer from the following page:

http://forums.comodo.com/cfp_beta_corner/cfp_and_avast_web_sheild_ashwebsvexe_resolved-t11435.0.html

I checked ashWebSv.exe under Task Manager Processes: it's definitely running now! And I did NOT need to uninstall either Threatfire or Comodo. Seeing as this problem appears over and over again in Avast forums, I'm surprised the answer is not readily provided. Competitive product envy, perhaps?


The suggestions of alanrf and Tech may well be described as unadorned, direct, even blunt, but
"Competitive product envy"??
Plenty of people on this forum use avast!, Threatfire, and the Firewall component of Comodo CIS in combination (as they use Avira, AVG, PC-Tools AV, etc.) How are we "competitors"?
Threatfire 4.1 and avast 4.8 are coexisting perfectly well on this PC as I write this without any modification to either, so speaking only for myself, I'm not holding out on providing the "answer".

Important note, especially for anyone else experiencing this kind of problem with this software combination. Both links quoted above refer to superseded Threatfire and Comodo Firewall product versions discussed by people whose knowledge is not quantifiable and of questionable value, apparent  in their descriptions of how Threatfire works and the 'solution' which effectively disables the avast! webshield. The Threatfire and current Comodo CIS forums would be more useful.

« Last Edit: February 24, 2009, 04:59:22 AM by Vladimyr »
There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

Offline greendager

  • Newbie
  • *
  • Posts: 6
Re: WebShield blocks browsing
« Reply #11 on: February 24, 2009, 02:44:50 PM »
Hi,
I'm running windows xp with windows firewall only. Since I updated the avast program to 4.8 I am unable to browse any web pages with the web shield turned on. I've tried searching the forums and help topics for answers but I can't find one that works. Any ideas as to what is causing this problem and how to fix it?
I can however ping out to web pages with no problems and get the replies.
« Last Edit: February 24, 2009, 02:48:55 PM by greendager »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83982
  • No support PMs thanks
Re: WebShield blocks browsing
« Reply #12 on: February 24, 2009, 03:44:17 PM »
What is your browser ?
Have you tried an different browser ?

What have you tried, for fear of repeating that ?
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline greendager

  • Newbie
  • *
  • Posts: 6
Re: WebShield blocks browsing
« Reply #13 on: February 24, 2009, 03:50:23 PM »
I use firefox 3.06 and google chrome. I've tried going back to older versions of avast with no luck. I've even tried disabling all firewalls but the only thing that works is to shout off the web shield. I also tried installing the patch that avast suggested, also with no luck.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83982
  • No support PMs thanks
Re: WebShield blocks browsing
« Reply #14 on: February 24, 2009, 03:57:28 PM »
What patch, I haven't heard of this ?
Do you connect to the internet using a proxy (web accelerator, ISP, etc.) if so you would have to co-ordinate that with the web shield proxy ?

Chrome is as far as I'm aware currently an unsupported browser, so you would have to manually set it to use the web shield proxy, see examples below for other browsers, you would have find the equivalent in Chrome.

For IE - broadband users: - Tutorial - Web Shield Proxy Set-up for IE
For IE - dialup users - Tutorial - Web Shield Proxy Set-up for IE (Dial-up)
For Firefox users - Tutorial - Web Shield Proxy Set-up for Firefox
Opera Users - Tools> Preferences> Advanced> Network> Proxy Servers, see image.

If you find How to do this please report how you do it for Chrome.
« Last Edit: February 24, 2009, 04:09:41 PM by DavidR »
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security