Author Topic: Assistance Required.  (Read 4979 times)

0 Members and 1 Guest are viewing this topic.

Offline Vyr

  • Newbie
  • *
  • Posts: 3
Assistance Required.
« on: March 13, 2009, 12:38:32 AM »
"I have installed 'avast! 4 Home' and everytime I try to open it, I get an error message stating: "unknown error message", "Application cannot load skin. Function usiGetSkin Failed". How can I fix this?"

This is one FAQ that doesn't help everyone.  I've got Vista.  Wondering if there wasn't anything I could do about this.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Assistance Required.
« Reply #1 on: March 13, 2009, 01:13:55 AM »
Was this what you tried ?
If you have Windows XP/Vista:
C:\WINDOWS\SYSTEM32\REGSVR32.EXE ACTSKIN4.OCX
If you have Windows XP/Vista x64:
"C:\WINDOWS\SysWOW64\REGSVR32.EXE" ACTSKIN4.OCX
Press OK (or Enter).
A message saying that the file was successfully registered should appear...

For some reason, ActiveSkin (the 3rd party library avast uses for skinning) does not seem to be working on your system. As a workaround, we may disable skinning in avast - that should solve the problem. Program Settings, Common, and uncheck any option with skins mentioned (see image, avast-no-skin).

If you are unable to access the above you can do this manually. To do that, open the file using notepad <avast4>\data\avast4.ini, look up the [UserInterface] section, and add the following entry: StartWithSkin=0 - Save the changes, the avast self-defence module will ask if it is OK answer Yes.

If it is what you tried and it didn't work what was the error ?

In Vista with UAC, you may have to jump through some more hoops, by opening a command window using the run as function and log in as the administrator before entering the regsvr32.exe command line.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Vyr

  • Newbie
  • *
  • Posts: 3
Re: Assistance Required.
« Reply #2 on: March 13, 2009, 01:56:01 AM »
Woah mass techie stuff.  I've tried those two Vista commands and still got nothing.  I have no idea what's with the rest of the stuff you gave me.  But started to happen after a powercut had turned off my computer while I was using it.  Might be part of the problem?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Assistance Required.
« Reply #3 on: March 13, 2009, 03:23:00 AM »
OK so you tried the first two, you should only have to have tried the one appropriate to your OS, 32bit or 64bit version of Vista. But I would have thought there would have been an associated error message displayed if it/they didn't work ?

I don't use vista so I can't be any help with regard to the UAC (User Access Control) side, but frequently this needs to be elevated to be able to a) open a command window, b) actually run the regsvr32.exe command line.

A power spike or disruption could cause file corruption (the registry is also a file of sorts) so it is possible, but I would have though it would show more problems than just this. However, XP/Vista with the NTFS format is more resistant to these problems.

It really isn't that hard to edit the avast4.ini file, using windows explorer navigate to the folder where avast is installed, and the data folder to find the avast4.ini file (Configuration Settings file). Right click on it and select Open With and select Notepad.

Find the [UserInterface] section, and add the following entry: StartWithSkin=0 - Save the changes, the avast self-defence module will ask if it is OK answer Yes.

That is me for the night, 2:25 a.m. here.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re: Assistance Required.
« Reply #4 on: March 13, 2009, 03:56:59 PM »
Server edition board? ???
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Assistance Required.
« Reply #5 on: March 13, 2009, 04:03:58 PM »
Yes it is but it is the Home version.

"I have installed 'avast! 4 Home'
<snip>
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Vyr

  • Newbie
  • *
  • Posts: 3
Re: Assistance Required.
« Reply #6 on: March 14, 2009, 10:14:45 AM »
After giving up for a bit then becoming extremely bored I managed to figure out how I could get to all that stuff.  I managed to fix it and now my computer is protected again.  Thanks for the help.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re: Assistance Required.
« Reply #7 on: March 14, 2009, 03:44:31 PM »
You're welcome.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security