Author Topic: Automatic update not active  (Read 2875 times)

0 Members and 1 Guest are viewing this topic.

Offline fujibike

  • Newbie
  • *
  • Posts: 3
Automatic update not active
« on: June 28, 2009, 05:04:04 PM »
I did a quick search and could not find similar problems.  My Avast HAS automatically connected for updates and announced that it had updated.  Then several weeks ago it stopped.  I became aware after a week, nothing had changed in the system.  No new firewall, no malware scanner even the same ISP.  It is still configured for auto update for signatures and program and will manually update.

I guess a bit got flipped in the registry by some random impulse.  Short of a re-install what ?  Or should I just be content that I can still manually update.  But supposed there is some other 'glitch' hiding that has not yet shown its self?  Thanks

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82696
  • No support PMs thanks
Re: Automatic update not active
« Reply #1 on: June 28, 2009, 05:32:13 PM »
Well avast doesn't automatically connect, it can't create a connection, it checks for updates when a connection is present.

Are you getting any errors displayed ?

What is your firewall ?
Does it allow avast.setup internet access ?
- If it does delete the entry for it and do a manual update, this should force the firewall to ask permission again.

What happens when you try a manual VPS update ?
e.g. right click the avast 'a' icon, select Updating, iAVS Update.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.1.2397 (build 20.1.5069.558) UI-1.0.460/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline fujibike

  • Newbie
  • *
  • Posts: 3
Re: Automatic update not active
« Reply #2 on: June 28, 2009, 06:03:20 PM »
Avast would sometimes update before my FF was even loaded.  As soon as it detected a connection it would check and update.  The firewall was Comodo, with no interventions.  It is now Outpost(3 days since install) again with no interventions.  And yes Outpost has an issue with Avast but they 'patch' for peaceful-coexistence.

There are no errors displayed at all.  The manual update works fine, again no errors or problems.

Internet access was never an issue with the Comodo FW or now with Outpost.  I have several other programs that auto update and several that I manually update.  All work well.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82696
  • No support PMs thanks
Re: Automatic update not active
« Reply #3 on: June 28, 2009, 07:21:39 PM »
The avast update doesn't require your browser FF to be loaded to be able to update.

Well I have been using Outpost Pro for many years and no issues, however, I never have the anti-spyware module as it is just duplicating scans (especially at boot). Nor do I have any other modules other than firewall related as I like my firewall to be just that a firewall.

It may be that OP is not fully loaded and may block outbound connections until it is. You could try delaying the auto update check to enable everything to be loaded.

You need to edit (using notepad) the [InetWD] section of the C:\Program Files\Alwil Software\Avast4\Data\avast4.ini file and add the following line (depending on your connection type enter one or other of the Bold lines below):
Dial-up connections, add this line: RASWaitSeconds=120
Broadband connections, add this line: AlwaysConnectedWaitSeconds=120
Quote
[InetWD]
AlwaysConnectedWaitSeconds=120
Or
RASWaitSeconds=120
When complete save the changes, avast's self-defence module will ask for confirmation, etc. answer Yes.

The figure is seconds and the above equates to two minutes, you could try that and adjust upwards if required, 180, 240, etc.

Edit:
Something you could try first - avast Program Settings, Update (Connections), set the method you use for connection, one or the other. Click the Proxy button and set the proxy to Direct connection (no proxy) if you don't have to connect by proxy.
« Last Edit: June 28, 2009, 07:26:22 PM by DavidR »
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.1.2397 (build 20.1.5069.558) UI-1.0.460/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline fujibike

  • Newbie
  • *
  • Posts: 3
Re: Automatic update not active
« Reply #4 on: June 29, 2009, 12:07:51 AM »
OK...DavidR your last comment was worth exploring.  I went to the connections page, something I have never done, nor felt the need to and adjusted for direct connect (again never had to before).  Saved all the appropriate parameters and exited.

Within 5 minutes the auto update announced new data was installed.  Go figure...for 3+ years it worked without any proxy/connection adjustment and now it needed it.

Thanks for the tip and have a great day. 

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82696
  • No support PMs thanks
Re: Automatic update not active
« Reply #5 on: June 29, 2009, 12:40:40 AM »
No problem, glad I could help.

Computers, don't you just love them ;D

Welcome to the forums.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.1.2397 (build 20.1.5069.558) UI-1.0.460/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline chica80

  • Newbie
  • *
  • Posts: 1
Re: Automatic update not active
« Reply #6 on: June 29, 2009, 12:42:27 AM »
i am having the say problem worse still my security panel tells me my system is not protected cos my antivirus isn't updating. so please what do i do. have u found any solutions yet?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82696
  • No support PMs thanks
Re: Automatic update not active
« Reply #7 on: June 29, 2009, 01:21:40 AM »
Have you tried what I suggested earlier ?

Answer the questions I asked earlier.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.1.2397 (build 20.1.5069.558) UI-1.0.460/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Automatic update not active
« Reply #8 on: June 30, 2009, 01:10:03 AM »
Please check if the file C:\Program Files\Alwil Software\Avast4\Setup\servers.def is displayed correctly, it should contain [servers] on the first line.

You can try and download the servers.def file, http://files.avast.com/iavs4x/servers.def and replace the one in the avast setup folder, disabling the avast self-defense module first.

How do you connect to internet, is it ADSL? And do you have other computers with working avast updates using the same connection?

Try to open avast settings - Update (Connections), press Proxy button, and select Direct connection, press OK to confirm. Then try to start iAVS update manually again.
The best things in life are free.