Author Topic: Weird font in Firefox  (Read 3525 times)

0 Members and 1 Guest are viewing this topic.

Avastfan1

  • Guest
Weird font in Firefox
« on: April 19, 2009, 03:07:03 AM »
Dear Forum,

Could someone please tell me how to make Firefox or Window$ (not sure which is the culprit) read some weird fonts?

I noticed that when foreign language websites are loaded up in Firefox that sometimes the characters are displayed in little boxes with numbers in them. They look like dice from a casino or something.

I have tried the same websites (reluctantly) with Shiternet Explorer to no avail.

Would appreciate any help or tips!

Thanks,

Avastfan1

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87053
  • No support PMs thanks
Re: Weird font in Firefox
« Reply #1 on: April 19, 2009, 03:12:00 AM »
A small image of said weird fonts might help.

Basically you don't have that language font loaded in windows so you can't display it and that is why you see this representation, those weird little boxes actually mean quite a lot.

When you do a search on say google any foreign web site may also have a Translate link next to it so you can see an English language version.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Avastfan1

  • Guest
Re: Weird font in Firefox
« Reply #2 on: April 19, 2009, 04:52:15 PM »
Hi,

Thank you for your response. As requested I have attached a screen shot of the weird font.

Is there anyway to load that language?

Best regards,

Avastfan1

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87053
  • No support PMs thanks
Re: Weird font in Firefox
« Reply #3 on: April 19, 2009, 05:04:19 PM »
Yes if you notice the different numbers and letters in the box, this means something to the language translators and they convert that into the correct language symbol, if you haven't got that language font installed then this is what you see.

Some times a site may say you haven't got that font do you want to download it, always say no, as this has in the past been used to load malware. You should only install language fonts that you actually use and you should be the one to initiate the download rather than have it offered to you as you really don't know what you might get.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Omid Farhang

  • Frontend Developer
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1660
  • I wish I could write longer personal text!!
    • Homepage
Re: Weird font in Firefox
« Reply #4 on: April 19, 2009, 05:33:28 PM »
Hi,

Thank you for your response. As requested I have attached a screen shot of the weird font.

Is there anyway to load that language?

Best regards,

Avastfan1

Try these:
go to view menu and go to character encoding and choose other (such as UTF-8 and...)
use Registry Cleaner ( http://www.auslogics.com/en/software/registry-cleaner/download ), beside all the benefites it would remove invlid fonts too
if you use windows XP, go to control panel and go to regional and language setting and install all other code-pages too

hope one of these help you!
Twitter: OmidFarhangEn - OS: Manjaro KDE