Author Topic: autoupdates dont work  (Read 3515 times)

0 Members and 1 Guest are viewing this topic.

rubendgl

  • Guest
autoupdates dont work
« on: April 29, 2009, 04:18:51 PM »
Hi,

I have installed version 4.8 home.
My problem is that automatic updates do not work but manually the program updates perfectly.
What is the problem.

Thanks,

Rubendgl
Spain.

Offline Bluesman

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 926
  • Amiga Power!
Re: autoupdates dont work
« Reply #1 on: April 29, 2009, 08:58:46 PM »
I have installed version 4.8 home.
My problem is that automatic updates do not work but manually the program updates perfectly.
What is the problem.
Welcome to the forum! :)

Do you get any error messages?

Do you use any firewall?
"The blues are the roots, everything else is the fruits" -Willie Dixon

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89056
  • No support PMs thanks
Re: autoupdates dont work
« Reply #2 on: April 29, 2009, 11:01:56 PM »
What is your firewall ?
Does it allow avast.setup internet access ?
- If it does delete the entry for it and do a manual update, this will force the firewall to ask permission again.

Have (or did) you another AV installed in this system, if so what was it and how did you get rid of it ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

rubendgl

  • Guest
Re: autoupdates dont work
« Reply #3 on: April 30, 2009, 04:27:23 PM »
My firewall is windows firewall ( vista ultimate x64).

I do not get any error, manual updates work perfectly. The problem are automatic updates.
I have avast antivirus only.

ashAvast.exe is open through windows firewall, is that ok ?.


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89056
  • No support PMs thanks
Re: autoupdates dont work
« Reply #4 on: April 30, 2009, 04:48:09 PM »
Well by default the Vista firewall has the outbound checking disabled, so that shouldn't be getting in the way unless you enabled it.

The ashAvast.exe doesn't need permission as it is just used to start an on-demand scan (doesn't connect) or to start avast from safe mode, do a memory scan and start the Simple User Interface so that you can run an on-demand scan.

Since the manual scan works if it were the vista firewall blocking then that wouldn't work either. So I would say you need to delay the update check as it might be that although you may have a connection present it isn't fully ready that close to boot.

You need to edit (using notepad) the [InetWD] section of the C:\Program Files\Alwil Software\Avast4\Data\avast4.ini file and add the following line (depending on your connection type enter one or other of the Bold lines below):
Dial-up connections, add this line: RASWaitSeconds=120
Broadband connections, add this line: AlwaysConnectedWaitSeconds=120
Quote
[InetWD]
AlwaysConnectedWaitSeconds=120
Or
RASWaitSeconds=120
When complete save the changes, avast's self-defence module will ask for confirmation, etc. answer Yes.

The figure is seconds and the above equates to two minutes, you could try that and adjust upwards if required, 180, 240, etc.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

rubendgl

  • Guest
Re: autoupdates dont work
« Reply #5 on: May 01, 2009, 04:40:50 PM »
I do what you tell me but automatic updates does not work.
Then i try to modify this parameter in avast.ini:
[InetWD]
UseRAS=0
AssumeAlwaysConnected=1   <--- the original value was 0 and i change it to 1
UpdatePeriod=30

I restarted windows and avast updates perfectly.

I do not know if this is correct but it works.

Thanks for your help.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89056
  • No support PMs thanks
Re: autoupdates dont work
« Reply #6 on: May 01, 2009, 04:56:10 PM »
Your welcome.

Well that tells avast specifically that you are on broadband, with both UseRAS=0 and AssumeAlwaysConnected=0 avast would check if either connection were present (just uses a different method).

If it works fine, but you didn't apply any delay, adding the line AlwaysConnectedWaitSeconds=120, which was the whole purpose of the suggestion to delay the check.

The main thing is that it now works.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.3.6108 (build 24.3.8975.762) UI 1.0.801/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security