Author Topic: Avast! Icon On Taskbar Gone?  (Read 8325 times)

0 Members and 1 Guest are viewing this topic.

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Avast! Icon On Taskbar Gone?
« on: May 03, 2009, 08:13:34 PM »
Ok, I'll start from the beginning. I was having fun and then decided that I wanted CCleaner to clean some space for me. It found 554 megabytes and a choosed to remove. Then I did a registy or whatever they call it scan with all of the boxes checked. It detected a lot of them so I choosed to remove them all without saving the registy file. Then when I went back to Internet Explorer, it woulden't load the pages, so then I tryed firefox, didn't work. So I just called a professional to fix my Internet because I didn't have a Internet Explorer CD so I can repair it. While he was fixing the computer, I was watching TV. Anyway, it took all night and finally, it was finished. Well, when I logged on to my computer, Avast! didn't show in the taskbar. Why wasn't Avast! in the taskbar? Could the professional done something wrong? Will I have to reinstall Avast? Is Avast! still protecting me?

When I opened the Task Manager, it didn't show any Avast! processes.
« Last Edit: May 03, 2009, 08:18:30 PM by Donovansrb10 »
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Re: Avast! Icon On Taskbar Gone?
« Reply #1 on: May 04, 2009, 12:48:10 AM »
Did some searching and found this:
Hi roro,
What version of Avast do you have on this computer? Current version is 4.8.1335
Try going to "add/remove programs" and carry out a repair install. This is done by clicking "change/remove" and clicking "repair" at the next prompt.
Check that the system date and time is correct, also.

Then I tryed to repair but it said that it was already uninstalled and i'm like >:( and :o and ??? and :'( because now I have to use the removal tool, restart, redownload, restart and get a new licence key.
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Re: Avast! Icon On Taskbar Gone?
« Reply #2 on: May 04, 2009, 12:52:42 AM »
When I downloaded the removal tool, it said:
The avast! self protection module is enabled. For this reason, the operation cannot be completed.

To complete the operation, either run this program from Windows Safe Mode or disable the avast! self protection (via Settings -> Troubleshooting page).

----------------------

Only the Avast! Icon is gone and I think a virus removed my safe boot mode so now, how do I use the removal tool?

For my next course of action, I'm just going to try to reinstall avast because I think only some registy keys were removed from CCleaner...
« Last Edit: May 04, 2009, 12:55:36 AM by Donovansrb10 »
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline nevet

  • Newbie
  • *
  • Posts: 6
Re: Avast! Icon On Taskbar Gone?
« Reply #3 on: May 04, 2009, 01:22:07 AM »
FWIW Donovan (I'm a new-to-Avast newbie), after installing latest Avast 4 to my XP Home SP3 yesterday, the animated blue a ball (assuming that's what your note's referring to), didn't show up on the bottom right task bar, along with all the various screens for settings/status and overall Resident protection it provides.  After searching this forum, a prior note commented that the ashDisp.exe application should be running for that to show.  Checking the Task Mgr verified the process wasn't active.

Long story short, after trying several deadends, I eventually had to manually add a shortcut to that ap to my Startup folder to make it work through reboots. 

(Attn any Avast people viewing this...methinks this may be a compatibility bug in v. 4.8.1335 as the installation should have precluded this problem...plus searching gets a number of hits on the XP SP3 task bar missing "blue ball a."  Also, the manual I browsed through initially doesn't speak to either the requirement or problem...and should, IMO.)
« Last Edit: May 04, 2009, 01:24:59 AM by nevet »

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Re: Avast! Icon On Taskbar Gone?
« Reply #4 on: May 04, 2009, 02:09:13 AM »
Got it to work by reinsalling and restarting.
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline crissy.s

  • Newbie
  • *
  • Posts: 1
Re: Avast! Icon On Taskbar Gone?
« Reply #5 on: May 04, 2009, 06:31:59 PM »
Got it to work by reinsalling and restarting.

I just got avast. There is no blu ball icon on the taskbar. What shall I do? Help! Is there an easy way? Why is avast not userfriendly?????? I'm regretting i got this now. I heard it was the best antivirus program. But now I'm in doubt....   :(

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82544
  • No support PMs thanks
Re: Avast! Icon On Taskbar Gone?
« Reply #6 on: May 04, 2009, 06:35:54 PM »
Well there is more to this than simply reinstalling as, if the problem causing the icon to be missing still exists, then a reinstall won't resolve that problem.

avast! icon missing - As a temporary measure until this is resolved you can create a desktop shortcut for this file C:\Program Files\Alwil Software\Avast4\ashDisp.exe (the avast icon and interface to the providers).  Right click on the file and select Send To, Desktop (create shortcut). You will need to run this after each boot until the problem is resolved.

What other security based software do you have that might block new startup entries, e.g. Spybot S&D (TeaTimer), AdAware (AdWatch), SpySweeper, Spyware Doctor (StartUpGuard or OnGuard), PrevX, WinPatrol, ProcessGuard, etc. ?

Check the option in the Appearance tab of Program Settings. Or Make a link to ashdisp.exe in your startup folder.

You are still protected as the avast icon is only an interface to access other elements and not the protection. What avast processes are running in Task Manager, they begin with ash or asw ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline nevet

  • Newbie
  • *
  • Posts: 6
Re: Avast! Icon On Taskbar Gone?
« Reply #7 on: May 04, 2009, 07:48:12 PM »
Quote
As a temporary measure until this is resolved you can create a desktop shortcut for this file C:\Program Files\Alwil Software\Avast4\ashDisp.exe (the avast icon and interface to the providers).  Right click on the file and select Send To, Desktop (create shortcut). You will need to run this after each boot until the problem is resolved.

David...I gather you didn't see my note above?  Adding a shortcut to ashDisp.exe to the Startup folder obviates the need to manually start the ap after each boot...and solved the problem for me.

Quote
You are still protected as the avast icon is only an interface to access other elements and not the protection. What avast processes are running in Task Manager, they begin with ash or asw ?

I disagree.  With ashDisp.exe not running (as verified in Task Mgr processes tab) several of the continuous protection exe's aren't running either.  Without design detail available to confirm, I'm assuming that part of the function of the ashDisp ap is to initiate all the other necessary ash and asw aps to provide the overall complete protection.  Do you have insights that say otherwise?
« Last Edit: May 04, 2009, 08:00:29 PM by nevet »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67273
Re: Avast! Icon On Taskbar Gone?
« Reply #8 on: May 04, 2009, 07:50:01 PM »
Other way would be repairing your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove. Then choose Repair function in the popup window (Repair).
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 82544
  • No support PMs thanks
Re: Avast! Icon On Taskbar Gone?
« Reply #9 on: May 04, 2009, 08:45:14 PM »
Quote
As a temporary measure until this is resolved you can create a desktop shortcut for this file C:\Program Files\Alwil Software\Avast4\ashDisp.exe (the avast icon and interface to the providers).  Right click on the file and select Send To, Desktop (create shortcut). You will need to run this after each boot until the problem is resolved.

David...I gather you didn't see my note above?  Adding a shortcut to ashDisp.exe to the Startup folder obviates the need to manually start the ap after each boot...and solved the problem for me.

Firstly I wasn't responding directly to your post, but that of crissy.s whose post was directly above mine, otherwise I would have quoted part of your post or it can get confusing as to whom you are answering when there are multiple forum member reporting the a problem in the same topic.

But your right in a way, I didn't notice it as I hadn't read it and was a response to crissy.s, but even so it is a copy and paste job of what options to check and that was just one of them. Though having added it to the startup folder would mean you can't find the true cause.

Quote
You are still protected as the avast icon is only an interface to access other elements and not the protection. What avast processes are running in Task Manager, they begin with ash or asw ?

I disagree.  With ashDisp.exe not running (as verified in Task Mgr processes tab) several of the continuous protection exe's aren't running either.  Without design detail available to confirm, I'm assuming that part of the function of the ashDisp ap is to initiate all the other necessary ash and asw aps to provide the overall complete protection.  Do you have insights that say otherwise?

Again my post was a direct respons to crissy.s post, but the same statement is correct in your case.

You have every right to disagree, but it is a fact that the ashDisp.exe has nothing to do with the protection. So in reporting that other avast processes aren't running escalates this into something entirely different that just the avast icon being missing. This is why I posted the image with what processes should normally be running so crissy.s could check his.

As I first said to crissy.s "Well there is more to this than simply reinstalling as, if the problem causing the icon to be missing still exists, then a reinstall won't resolve that problem."

This is one such problem and it is usually associated with having another AV installed or remnants of a previous AV on your system.

WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline nevet

  • Newbie
  • *
  • Posts: 6
Re: Avast! Icon On Taskbar Gone?
« Reply #10 on: May 04, 2009, 09:19:18 PM »
Sorry, David, I guess I should have specifically said what I thought was implicit in my stating my problem was solved, which certainly wouldn't have been the case if full background protection didn't activate along with the ashDisp ap running, something I had verified of course.

You're obviously correct in saying this workaround doesn't solve whatever the underlying reason was for the improper installation...which could be many things requiring possibly tons of effort by customers of varying technical skills and troubleshooting experience, and with little or no insights into the detailed design mechanizations, in order to eliminate each possibility...and even then still not ID the specific design element that may be at the root of the problem.  Although I agree it's always desirable to reach that objective so the real problem can be fixed (reason I pointed out a possible design bug was involved in my note), once a workaround has been identified, it's neither desirable nor practical IMO to recommend various isolating techniques to customers who generally come to this forum for help, not to jump through hoops to act as a distributed test bed for others to use. 

If an easily implemented workaround works, as verified by the observables, I would argue that further troubleshooting to identify the specific fault should be left up to the Avast design group to pursue, using the configurations and related data provided by customers in initial attempts to duplicate the fault in their test bed so as to enable appropriate fault isolation testing by appropriate design team members qualified to do so.

Btw, I asked you if you had further insights into the design which might either confirm or refute my speculation regarding the criticality of the task bar blu icon showing.  Did you not see the question, or can I assume no answer means you don't have any detailed design knowledge of Avast mechanizations?
« Last Edit: May 04, 2009, 09:29:18 PM by nevet »

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2220
    • The WAR Against Malware
Re: Avast! Icon On Taskbar Gone?
« Reply #11 on: May 04, 2009, 11:25:34 PM »
Well there is more to this than simply reinstalling as, if the problem causing the icon to be missing still exists, then a reinstall won't resolve that problem.

avast! icon missing - As a temporary measure until this is resolved you can create a desktop shortcut for this file C:\Program Files\Alwil Software\Avast4\ashDisp.exe (the avast icon and interface to the providers).  Right click on the file and select Send To, Desktop (create shortcut). You will need to run this after each boot until the problem is resolved.

What other security based software do you have that might block new startup entries, e.g. Spybot S&D (TeaTimer), AdAware (AdWatch), SpySweeper, Spyware Doctor (StartUpGuard or OnGuard), PrevX, WinPatrol, ProcessGuard, etc. ?

Check the option in the Appearance tab of Program Settings. Or Make a link to ashdisp.exe in your startup folder.

You are still protected as the avast icon is only an interface to access other elements and not the protection. What avast processes are running in Task Manager, they begin with ash or asw ?

At least it worked! ;D
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67273
Re: Avast! Icon On Taskbar Gone?
« Reply #12 on: May 05, 2009, 12:24:12 AM »
Sorry, David, I guess I should have specifically said what I thought was implicit in my stating my problem was solved, which certainly wouldn't have been the case if full background protection didn't activate along with the ashDisp ap running, something I had verified of course.
ashdisp.exe is the icon on system tray, not the resident protection (ashserv.exe service).
The best things in life are free.