Author Topic: avast + sygate Firewall probs  (Read 6454 times)

0 Members and 1 Guest are viewing this topic.

deadeye

  • Guest
avast + sygate Firewall probs
« on: May 16, 2004, 03:48:18 PM »
Hi, I'm using avast for a while now, and it's great, except for the combination with the sygate firewall.  When avast is doing an update, the firewall asks if I want to allow the avast application to contact the server.  When you choose 'yes' and 'allow every time' in the firewall options, then the firewall asks it again and again... every time you allow the application to contact the server it gives it again the same question. The problem is that the avast is every time 'a different' program for the firewall... I don't understand how this can be.  

Offline .: Mac :.

  • Avast √úberevangelist
  • Ultra Poster
  • *****
  • Posts: 5093
Re:avast + sygate Firewall probs
« Reply #1 on: May 16, 2004, 04:05:13 PM »
I dont know How this happens. But mabye you should contact the developers and let them know you would like this in a future version
"People who are really serious about software should make their own hardware." - Alan Kay

Iso-G

  • Guest
Re:avast + sygate Firewall probs
« Reply #2 on: May 16, 2004, 04:33:47 PM »
Could you please make sure if you allow avast! programs to connect internet on the "Applications" window ?
( Right click on the icon of sygate and select "Applications" )

Thank you

Max M.Wachtel III

  • Guest
Re:avast + sygate Firewall probs
« Reply #3 on: May 17, 2004, 04:48:37 AM »
Try uninstalling and then reinstalling sygate.It seems to have worked for me so far.
-max

beck

  • Guest
Re:avast + sygate Firewall probs
« Reply #4 on: May 17, 2004, 05:08:16 AM »
Uninstalling and reinstalling either program will "fix" the problem, but probably only until the next program update from avast. To work around this problem,  in Sygate:

1. open Tools, then advanced rules.
2. In there, pick Add, enter whatever name you want the rule to have (such as avast).
3. click allow this traffic.
4. pick all interfaces (or the one you want)
5. Click hosts and click IP addresses.
6. Enter the following addresses:
195.70.130.34,66.98.166.72,216.127.72.135,216.12.202.5,66.98.196.85,67.15.0.83,67.15.0.90,217.31.49.244,195.47.75.50
7. click ports and protocols.
8. in protocol pick TCP.
9. in traffic direction pick outgoing.

You can pick a schedule or not.  No application since that setup.avast changes all the time.

Sygate is doing what it should be doing by blocking an on the fly changed program from connecting to the outside world.

What this will do is to allow ALL outgoing traffic to connect to the avast servers and stop asking you over and over if it can connect.

OR, you can go into Tools, Options, Security and uncheck the anti-application hijacking option. However, if some virus/trojan/worm/whatever does what this option protects you from, you would not be protected.  I decided that I didn't want this turned off, so used the above approach.

Either one of these works for me and several others I installed avast on their systems.

Max M.Wachtel III

  • Guest
Re:avast + sygate Firewall probs
« Reply #5 on: May 17, 2004, 05:26:24 AM »
I use a home network.Are the IP addys going to be the same as you have listed?I already created the rule just as you said to and applied it.
thanks-max :)

Iso-G

  • Guest
Re:avast + sygate Firewall probs
« Reply #6 on: May 17, 2004, 02:18:29 PM »
avast! has run with sygate on my pc for about half year, but it is no problem after avast! updatings.   My settings are as follow,

ADVANCED RULE
IP Address:
  195.70.130.34,64.246.6.135,207.44.156.15,62.168.45.69
Applications:
  avast! antivirus service, aswupdsv.exe, Virus scanner, avast! e-Mail Scanner Service

APPLICATIONS
  avast! antivirus service, avast! e-Mail Scanner, avast! service GUI component, aswUpdSv.exe, avast.setup, Virus scanner

deadeye

  • Guest
Re:avast + sygate Firewall probs
« Reply #7 on: May 17, 2004, 07:53:47 PM »
Thanks man, this actually worked fine...  I didn't bother to do this as I didn't know the exact server range of avast, and I thought sygate would keep blocking it anyway because the programm changes all teh time after an update... big thanks!

deadeye


Uninstalling and reinstalling either program will "fix" the problem, but probably only until the next program update from avast. To work around this problem,  in Sygate:

1. open Tools, then advanced rules.
2. In there, pick Add, enter whatever name you want the rule to have (such as avast).
3. click allow this traffic.
4. pick all interfaces (or the one you want)
5. Click hosts and click IP addresses.
6. Enter the following addresses:
195.70.130.34,66.98.166.72,216.127.72.135,216.12.202.5,66.98.196.85,67.15.0.83,67.15.0.90,217.31.49.244,195.47.75.50
7. click ports and protocols.
8. in protocol pick TCP.
9. in traffic direction pick outgoing.

You can pick a schedule or not.  No application since that setup.avast changes all the time.

Sygate is doing what it should be doing by blocking an on the fly changed program from connecting to the outside world.

What this will do is to allow ALL outgoing traffic to connect to the avast servers and stop asking you over and over if it can connect.

OR, you can go into Tools, Options, Security and uncheck the anti-application hijacking option. However, if some virus/trojan/worm/whatever does what this option protects you from, you would not be protected.  I decided that I didn't want this turned off, so used the above approach.

Either one of these works for me and several others I installed avast on their systems.

saoir

  • Guest
Re:avast + sygate Firewall probs
« Reply #8 on: June 13, 2004, 03:03:19 PM »
Uninstalling and reinstalling either program will "fix" the problem, but probably only until the next program update from avast. To work around this problem,  in Sygate:

1. open Tools, then advanced rules.
2. In there, pick Add, enter whatever name you want the rule to have (such as avast).
3. click allow this traffic.
4. pick all interfaces (or the one you want)
5. Click hosts and click IP addresses.
6. Enter the following addresses:
195.70.130.34,66.98.166.72,216.127.72.135,216.12.202.5,66.98.196.85,67.15.0.83,67.15.0.90,217.31.49.244,195.47.75.50
7. click ports and protocols.
8. in protocol pick TCP.
9. in traffic direction pick outgoing.

You can pick a schedule or not.  No application since that setup.avast changes all the time.

Sygate is doing what it should be doing by blocking an on the fly changed program from connecting to the outside world.

What this will do is to allow ALL outgoing traffic to connect to the avast servers and stop asking you over and over if it can connect.

OR, you can go into Tools, Options, Security and uncheck the anti-application hijacking option. However, if some virus/trojan/worm/whatever does what this option protects you from, you would not be protected.  I decided that I didn't want this turned off, so used the above approach.

Either one of these works for me and several others I installed avast on their systems.

Sorry guys I can't get this to work.  I followed the instructions completely but Avast is still doing it's thing about 25 times before it gives up and it's driving me crazy...
It is trying to get through to 66.98.196.85 which I can see is in that list .  It says it is trying to go through http port 80.  

Anyone give me a hand with this ?

gwheaton

  • Guest
Re:avast + sygate Firewall probs
« Reply #9 on: June 13, 2004, 08:44:42 PM »
Thanks for the info.  It worked great.

I did not have this problem before the 412 update.  After the 412 update, that is when this problem started for me.


So, my question is, did something get changed in Avast?

Just wondering.

prmlscrm

  • Guest
Re:avast + sygate Firewall probs
« Reply #10 on: June 14, 2004, 04:00:51 AM »
 >:(hey i have the same exactly problem! any solutions?? cheers!

prmlscrm

  • Guest
Re:avast + sygate Firewall probs
« Reply #11 on: June 14, 2004, 04:09:16 AM »
 ;D ok i read it above! nice to have the anti-hijacking activated!!!