Author Topic: Manual SSL proxy setting?  (Read 10799 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Manual SSL proxy setting?
« Reply #15 on: July 20, 2009, 09:47:57 PM »
Thanks David... but really I can't understand. For me, if the port is not listed in the redirected ports of WebShield, the traffic won't be scanned. It will bypass WebShield. But you're saying that we'll get in a circle, I believe, just I can't understand.
The best things in life are free.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87082
  • No support PMs thanks
Re: Manual SSL proxy setting?
« Reply #16 on: July 20, 2009, 10:05:40 PM »
It is effectively redirecting to itself, which is an unnecessary step as it works without that as the browser if manually set to use the localhost port 12080 already directs web traffic to the web shield proxy.

It still works if you have the ignore local communication unchecked, but I don't know if it is going to have any overhead as there isn't any need to effectively redirect traffic twice.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline MikeBCda

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2248
Re: Manual SSL proxy setting?
« Reply #17 on: July 21, 2009, 07:40:25 PM »
One last comment (at least from me).  I thought I'd already mentioned this, but maybe I forgot (or worded it badly) or you missed it.

With the Firefox HTTP proxy set as I'd noted, 127.0.0.1 port 12080, and avast's web shield redirect set to port 80 (I think that's default anyway), the web shield does seem to scan HTTP traffic normally.  If I open the resident protection options, the web shield is showing a reasonable figure for number of items scanned, and "last scanned" is right up to date.

So any speed improvement (which as David said would probably be marginal anyway) is not from having lost web shield protection.
Intel Atom D2700, 2 gig RAM, Win 7 x64 SP1 & IE-11, Firefox 51.0
(default). 320 gig HD, 15Mb DSL, Win firewall, Avast 12.3.2280 free, SpywareBlaster, MBAM Prem., Crypto-Prevent

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87082
  • No support PMs thanks
Re: Manual SSL proxy setting?
« Reply #18 on: July 21, 2009, 08:19:34 PM »
Thanks for the update Mike.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security