Author Topic: Repository Folder.  (Read 3139 times)

0 Members and 1 Guest are viewing this topic.

Ted.

  • Guest
Repository Folder.
« on: August 19, 2009, 01:47:30 AM »
 Why can't Avast find the Repository folder with %SystemRoot%\System32\Wbem on the PATH file, but will if I replace it with: C:\WINDOWS\System32\Wbem.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88128
  • No support PMs thanks
Re: Repository Folder.
« Reply #1 on: August 19, 2009, 02:29:27 AM »
Why would avast need to find it ?
I presume that the WSC doesn't recognise avast ?

My Environment Variable, Path is set to the default (%SystemRoot%\System32\Wbem ) and no problem, see image.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Ted.

  • Guest
Re: Repository Folder.
« Reply #2 on: August 19, 2009, 02:42:29 AM »
Hi, DavidR,

Thank you for your reply.

Yes, WSC didn't recognise it and displayed the usual "Your Computer may be at Risk" Error message. It's strange because it used to work okay and does now with the amended PATH. but I wonder why?
 

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88128
  • No support PMs thanks
Re: Repository Folder.
« Reply #3 on: August 19, 2009, 02:51:24 AM »
The WSC can be flaky at times and much of that isn't related to the Path, though when all other avenues have been tried, some find that the path to the Wbem isn't even in the Path variable. There doesn't seem to be any rhyme nor reason why all of a sudden it no longer works.

Commonly it is the WSC/Wbem repository being corrupt and there are some ways to repair that. I shan't go into those as having got it fixed you don't want to go trying to fix it again.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Ted.

  • Guest
Re: Repository Folder.
« Reply #4 on: August 19, 2009, 04:26:00 AM »
Hi, DavidR,

Quote
Commonly it is the WSC/Wbem repository being corrupt and there are some ways to repair that.

Yes, it was after I'd stopped the two recommended services and deleted the Repository folder that the Error message reappeared and I discovered that the Repository folder was not being rebuilt.