Author Topic: "rootkit" virus got me...  (Read 5498 times)

0 Members and 1 Guest are viewing this topic.

Icek531

  • Guest
"rootkit" virus got me...
« on: September 15, 2009, 04:00:07 AM »
Anyone have any ideas how to fix this?...Please need help!!

yawetage

  • Guest
Re: "rootkit" virus got me...
« Reply #1 on: September 15, 2009, 06:13:41 AM »
Well, I can suggest some rootkit scanners, but without more info I'm not really sure what you need.

Blacklight
Panda
Rootrepeal
Sophos
Trend Micro

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89228
  • No support PMs thanks
Re: "rootkit" virus got me...
« Reply #2 on: September 15, 2009, 03:00:05 PM »
Anyone have any ideas how to fix this?...Please need help!!

How do you know that a rootkit got you ?
What detected it and what other information do you have ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Icek531

  • Guest
Re: "rootkit" virus got me...
« Reply #3 on: September 15, 2009, 03:11:39 PM »
When Avast ran a scan it says "Malware Detected" and it gives the file that is infected and the name "Rootkit" is in the file name.  I went on to Avast Website to look up different names of Viruses and Worms and I saw that there was a virus named "Rootkit" on the list.  I just assumed that that was the virus that got my computer.

In the bottom right corner of my toolbar there is an icon that is named "TrueSecurity" version 2.45 or something like that.  It keeps on popping up telling me that there is a virus in my computer and in order to fix it I must click on that icon.  I am scared to do that because I do not have such software in my computer and I am scared that it is a trick to infect my computer even more. 

Ice

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89228
  • No support PMs thanks
Re: "rootkit" virus got me...
« Reply #4 on: September 15, 2009, 03:29:28 PM »
And what was that file name and location reported ?

Is this what was reported ?
"A suspicious file has been detected (using a heuristic method). This may be a sign of malware infection. Please allow the file to be submitted to our virus lab for analysis."

If so that is the anti-rootkit scan that runs 8 minutes after boot, does that fall in line with when the alert happens ?
If so check the C:\Program Files\Alwil Software\Avast4\DATA\log\aswAr.log which contains details of the anti-rootkit scan, which will give you the file name and location of the detection.

That is a rogue application/fake AV pumping out fake alerts, don't click on the icon or you could become properly infected.
If you haven't already got this software (freeware), download, install, update and run it and report the findings (it should product a log file).

Don't worry about reported tracking cookies they are a minor issue and not one of security, allow SAS to deal with them though. - See http://en.wikipedia.org/wiki/HTTP_cookie.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Icek531

  • Guest
Re: "rootkit" virus got me...
« Reply #5 on: September 17, 2009, 06:10:54 PM »
Somehow it let me download the Superantispyware software....I ran the scan in Safe Mode and then quarantined and deleted the viruses that were in the computer.  Now I cannot connect at all to the computer in regular mode.   :(

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89228
  • No support PMs thanks
Re: "rootkit" virus got me...
« Reply #6 on: September 17, 2009, 06:21:59 PM »
Yes, but what were they, that is why we ask you to post the log. Without information we have no idea what was found/removed and can't offer any advice.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.4.6112 (build 24.4.9067.762) UI 1.0.803/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: "rootkit" virus got me...
« Reply #7 on: September 17, 2009, 06:26:07 PM »
Now I cannot connect at all to the computer in regular mode.   :(
Do you mean you can't login? Or you can't connect the Internet?
The best things in life are free.

John2009

  • Guest
Re: "rootkit" virus got me...
« Reply #8 on: September 20, 2009, 03:51:43 AM »
Most likely true security is rogue