Author Topic: Unable to run Avast, keep getting error code  (Read 4900 times)

0 Members and 1 Guest are viewing this topic.

Offline mrsnj20

  • Newbie
  • *
  • Posts: 1
Unable to run Avast, keep getting error code
« on: October 06, 2009, 05:35:09 PM »
I tried to open avast and I get this error code:The virus scanner engine does not seem to be available: try please to re-install the application, or consult the support.
I have tried to reinstall several times and get the same error. I am using mac 10.5.8.

 Any suggestions as to how to get the program to run?

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: Unable to run Avast, keep getting error code
« Reply #1 on: October 07, 2009, 11:06:31 AM »
I tried to open avast and I get this error code:The virus scanner engine does not seem to be available: try please to re-install the application, or consult the support.
I have tried to reinstall several times and get the same error. I am using mac 10.5.8.

 Any suggestions as to how to get the program to run?
Hallo,
this doesn't look like verbatim copy of the message. Engine = com.avast.MacAvast.MAD, is installed with the application, and should be always available.

There were only 3 problems observed so far:
- custom partitioning (just copy 400.vps from /Applications/avast!.app/Contents/Resources to your ~/Library/Application Support/com.avast.MacAvast)
- crash/freeze of the scanner on very long subpath  (try the newer engine, intended for new version - sticky post on the top of this forum)
- socket, gthat can't be bound to (usually 10.5 system, upgraded to10.6, with avast installed - it's some nasty quirk of 10.6, but the slution is to delete ~/Library/Application Support/com.avast.MacAvast/socket)

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)