Author Topic: Avast Pro 4.8 disrupting Web access  (Read 3478 times)

0 Members and 1 Guest are viewing this topic.

ChuckD

  • Guest
Avast Pro 4.8 disrupting Web access
« on: October 19, 2009, 05:00:25 AM »
I know others have posted about this. I've been involved in troubleshooting these kinds of things for many years and I thought I could offer a bit more info toward resolving it.

This is happening on two machines here in my home. There appears to be a clear connection between something in Avast and the ability to access web pages. It doesn't seem to affect other forms of internet access, email, nntp, ftp. Only http. And it affects both IE and FireFox, even websites entered into the Exclusions section. The only solution is to bypass the localhost proxy, port 12080. Pausing, or stopping doesn't affect it, web requests still time out.

I'll give here the basic info and if anyone from Avast would be willing to work with me I'd gladly take it offline to do so. I think Avast is a great product otherwise and have been a paid user for several years.

Windows XP Professional version 2002 SP3 (32 bit)
IE 8, fully patched
FireFox 3.5.3

ChuckD

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86684
  • No support PMs thanks
Re: Avast Pro 4.8 disrupting Web access
« Reply #1 on: October 19, 2009, 03:18:35 PM »
All those other post you talk about will no doubt have asked what is the most important question which you haven't answered, what is your firewall ?

This is by far the most common cause of the web shield being blocked.
What is your firewall ?
Does it allow ashWebSv.exe internet access ?
- If it does delete the entry for it and reconnect to the internet, this should force the firewall to ask permission again.

The second most common cause another AV or remnants of one still installed and this is another question that needs answered.
Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

ChuckD

  • Guest
Re: Avast Pro 4.8 disrupting Web access
« Reply #2 on: October 19, 2009, 04:06:30 PM »
Good points.

No firewall. Standard NAT behind a LinkSys router with no filtering.
No previous antivirus product.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86684
  • No support PMs thanks
Re: Avast Pro 4.8 disrupting Web access
« Reply #3 on: October 19, 2009, 05:08:46 PM »
Do you connect to the internet using a proxy (not talking about avast's localhost proxy) ?
If so you would need to add that port to the web shield redirects.

Not having a router my self, I'm not too familiar with their setup or software, but some come with firewalls, so I don't know if there might be a setting in there.

Have you tried to manually set your browsers to use the avast web shield proxy ?
For IE - broadband users: - Tutorial - Web Shield Proxy Set-up for IE
For Firefox users - Tutorial - Web Shield Proxy Set-up for Firefox

These may differ for your browser version/s but you should be able to find the relevant setting in your browser.

As you said you have been using it for some time, presumably without problem, what has changed recently before this problem occurred ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

ChuckD

  • Guest
Re: Avast Pro 4.8 disrupting Web access
« Reply #4 on: October 19, 2009, 05:50:03 PM »
No proxy at the router, just a direct, NAT'ed connection. As I said in my original post, the only way to make things normal is to bypass the Avast localhost proxy in the browsers, so, yes, I do manually set the proxy in both browsers to use the Avast proxy.

Can't say when this started happening exactly. it's sometimes hard to distinguish between this and possible network congestion at the ISP, or elsewhere. Tempted to say it was after a specific Avast update, but i can't be certain. It has been going on for the past 6 months or so.

I should add that it's not always a problem. For a while it seemed like restarting the Avast services seeme to clear it for a while. Now nothing seems to make a difference, except for bypassing the Avast proxy.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86684
  • No support PMs thanks
Re: Avast Pro 4.8 disrupting Web access
« Reply #5 on: October 19, 2009, 07:14:08 PM »
Not so much a proxy at the router but some ISP and or web accelerators insist or require that you use a proxy. I you aren't aware of that it is unlikely that you have to do this.

So you haven't made any customisations inside the web shield, primarily in the Basic tab, see image ?

It may be worth removing the manual browser settings to use the web shield proxy, then try a repair of avast. Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow.

If these options don't resolve it, given what you said "For a while it seemed like restarting the Avast services seems to clear it for a while." Then I would suggest a clean re-install.

Download the latest version of avast! Pro - http://www.avast.com/eng/download-avast-professional.html and save it to your HDD, somewhere you can find it again. Use that when you reinstall. Ensure that you scroll down and select the avast direct download link for the English version and not Cnet as that is for an on-line installation (not what you want to do).

Download the avast! Uninstall Utility, find it here and save it to your HDD.
  • 1. Now uninstall (using add remove programs, if you can't do that start from the next step), reboot.
  • 2. run the avast! Uninstall Utility, reboot.  If step 1 failed it may be necessary to run this from safe mode, once complete reboot into normal mode.
  • 3. install the latest version, reboot.

Note: before doing this you will need to find your pro license key that was emailed to you before.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

ChuckD

  • Guest
Re: Avast Pro 4.8 disrupting Web access
« Reply #6 on: October 20, 2009, 09:15:19 PM »
OK, I guess predictably, that made a huge difference and everything seems normal.
But right now I'm not confident this is the solution. Thanks for the help.

C.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86684
  • No support PMs thanks
Re: Avast Pro 4.8 disrupting Web access
« Reply #7 on: October 20, 2009, 10:46:37 PM »
You're welcome.

Though which of the suggested steps made the difference Repair or clean reinstall ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

ChuckD

  • Guest
Re: Avast Pro 4.8 disrupting Web access
« Reply #8 on: October 22, 2009, 05:37:52 AM »
You're welcome.

Though which of the suggested steps made the difference Repair or clean reinstall ?

I only did a reinstall. At my age I've gotten weary of the academics of troubleshooting.
Get it working again, get on with life.

C.