Author Topic: avast: relocation error: /usr/lib/libavastengine.so.4b  (Read 12985 times)

0 Members and 1 Guest are viewing this topic.

David

  • Guest
avast: relocation error: /usr/lib/libavastengine.so.4b
« on: June 18, 2003, 01:03:09 PM »
I got this message when I launch avast or avastd (with service avastd start) :
avast: relocation error: /usr/lib/libavastengine.so.4b: symbol __rpc_thread_destroy, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

My system is Redhat 9 (2.4.20-13.9) with all updates.

Regards.

David.

Dublin

  • Guest
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #1 on: June 23, 2003, 07:06:30 PM »
It should be fixed with the beta2b version.
(edit by Vlk) ...which is available for download here: http://www.avast.com/i_idt_172.html .
« Last Edit: June 23, 2003, 07:23:52 PM by Vlk »

David

  • Guest
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #2 on: June 23, 2003, 07:39:00 PM »
I have installed the beta2b so the results are :
It seem to work but during the complete scan of my disk I got a ¨Floating point exception¨
And when you start avast without a parameter you got a Segmentation Fault !!!

Regards.

Dublin

  • Guest
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #3 on: June 27, 2003, 05:47:34 PM »
I'll release a new version on monday. It will fix that.
« Last Edit: June 27, 2003, 11:09:22 PM by dublin »

David

  • Guest
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #4 on: July 01, 2003, 02:01:02 PM »
Ok the segmentation fult is solved but (sorry) I got now two errors
- on a particular file : [scan error: Error in macro viruses code]
- And a 'Floating point exception' on an another file !

I can give the files that generate these errors is you want.

Regards.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11820
    • AVAST Software
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #5 on: July 01, 2003, 02:20:55 PM »
I don't think you have to apologize for finding errors... on contrary - that's what betatesting is for  :)

If possible, send the mentioned files do Dublin's e-mail, I guess he would like to check.

David

  • Guest
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #6 on: July 01, 2003, 02:39:31 PM »
Yes I am agree with you.
I just report errors for helping Dublin to target a great final release.

I have sended the two faulty files to Dublin.

Offline nerijus

  • Newbie
  • *
  • Posts: 11
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #7 on: August 01, 2003, 02:28:18 AM »
Segmentation fault is here again when I just run avast. 'avast filename' works OK. BTW, 'avast filename' also segfaults when there are no AVAST environment variables set. I think you should include the following info - "please logout and login again before starting avast" after installation (so that env. vars are set by /etc/profile.d/avast4.sh script). Oh, and you could include avast4.csh script for C shell also.

P.S. I have some files with viruses which avast for linux does not recognise, I could send them if you are interested.

Dublin

  • Guest
Re:avast: relocation error: /usr/lib/libavastengine.so.4b
« Reply #8 on: August 01, 2003, 08:53:19 AM »
OK, I'll do that.
Can you send me those files at mensik@asw.cz, please.

Thank you