Author Topic: Web shield not aborting connection  (Read 2091 times)

0 Members and 1 Guest are viewing this topic.

SpacemanSpiff

  • Guest
Web shield not aborting connection
« on: November 19, 2009, 11:08:05 PM »
I just formatted & reinstalled a friend's XP Home machine due to being too infected to fix.
It goes without saying, I installed Avast as part of my normal ritual.

In showing her how Avast's web shield module protects her, and would have prevented her last infection, I launched Opera and loaded a known infected website [JS Fake AV] that I use to show people how awesome Avast is.  ;D

Avast triggered as expected, however, the JS executed regardless behind the Avast warning.
I clicked the abort connection button and the damn script continued to run.

I can go to the same site with my machine and the JS never loads as Avast holds the connection and nukes it completely as soon as I click abort.

What could be wrong in her installation?

Offline FreewheelinFrank

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 4872
  • I'm a GNU
    • Don't Surf in the Nude!
Re: Web shield not aborting connection
« Reply #1 on: November 19, 2009, 11:32:04 PM »
Do you do a complete update after reinstalling?

The installation disc can be months or years out of date.

It's possible there was an exploit on the site that avast! didn't detect and which took advantage of vulnerable software to run.

After a re-installation, run Windows update, reboot, run it again, reboot until no more updates come through.

Then use Secunia OSI or PSI to check all other software on the computer is up to date.

http://secunia.com/vulnerability_scanning/personal/
     Bambleweeny 57 sub-meson brain     Don't Surf in the Nude Blog

SpacemanSpiff

  • Guest
Re: Web shield not aborting connection
« Reply #2 on: November 20, 2009, 01:23:53 AM »
Yea, the OS and Avast both were fully updated.

As I said, Avast detects the threat and brings up the "abort connection" dialog box.
But, it doesn't abort when I press the button. The warning goes away and the script continues to run.

SpacemanSpiff

  • Guest
Re: Web shield not aborting connection
« Reply #3 on: November 21, 2009, 11:02:58 PM »
A new example.

My daughter just called me into her room because Avast warned her about a website...
http://get-freescan.in/l/41f1f1917cw81v76u

The javascript launches *first* and *then* Avast warns us.
If we abort the connection, it doesn't abort and the site continues.

If I go there on my machine, Avast comes up first, the javascript never executes and the connection aborts when clicked.

We have the same versions of all our software. In fact, other than processor and hard drive speeds, our machines are identical.

I'm going to test the site on my wife's and son's machines and report back.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Web shield not aborting connection
« Reply #4 on: November 22, 2009, 12:35:35 AM »
This can unfortunately sometimes happen with v4.x... given the way it works, and the way the server sends the data.
Avast 5 should not have this problem.
If at first you don't succeed, then skydiving's not for you.