Author Topic: Avast 5.0.396 Activex Error with IE8  (Read 13210 times)

0 Members and 1 Guest are viewing this topic.

pauloaragao

  • Guest
Avast 5.0.396 Activex Error with IE8
« on: January 30, 2010, 05:54:14 PM »
Hello Everyone.

I used to have the Avast Pro 4.x and I decided to change that to the newer version, the 5.0. After I installed it and restarted, it came up with an error message ""An ActiveX control on this page might be unsafe to interact with other parts of the page. Do you want to allow this interaction?". No matter what I click (yes or no) it still comes up. Basic websites are not loading properly such as Hotmail.com (screen goes completely blank), youtube (the video area is reduced and nothing happens), microsoft.com (clicking the menu on the top wont go anywhere) and also the Windows Vista sidebar (none of the gadgets show).
I already uninstalled and then installed the previous avast version again but it did not work. Now i have the 5.0 version installed again.
I am using a Dell computer, windows vista home basic SP2.

This never happened with the previous Avast versions.

Can someone please tell me how to fix this? I am currently using Safari browser which I'm not really a good fan of...

Many thanks from Brazil!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86671
  • No support PMs thanks
Re: Avast 5.0.396 Activex Error with IE8
« Reply #1 on: January 30, 2010, 06:00:56 PM »
Since the error message doesn't come from avast but IE8 you need to look at IE8 or the web site rather than avast. avast 4 or 5 doesn't change any activeX settings in your browser.

Reinstalling won't make any difference as it is unrelated to avast (so I'm not surprised it didn't work), but the security settings in IE8.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

pauloaragao

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #2 on: January 30, 2010, 06:24:25 PM »
Okay, I understand that. But this problem started happening AFTER I installed the new version of Avast, never before... I uninstalled IE8, re-installed it and message still comes up...

what about the sidebar in Vista? What do I do with that? Re-install Windows Vista?? If I do that and install AVAST 5 again, will it still happen?

I dont mean to be a pain, but Im frustrated with not being able to use my browser properly again...
There must be something that Avast changed in the Activex controls made it not function correctly.

Many thanks!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86671
  • No support PMs thanks
Re: Avast 5.0.396 Activex Error with IE8
« Reply #3 on: January 30, 2010, 06:33:41 PM »
It doesn't matter when the problem happened, coincidences happen and as you have found even with no avast the problem is still there.

Again as I said avast doesn't mess with your settings, it scans and alerts to infection it doesn't block.

What other security programs do you have installed, include your firewall in this list ?

What happens if you Stop the Web Shield ?
If it works then there is likely to be some conflict with another application involved.

It is possible that this could be malware related:
If you haven't already got this software (freeware), download, install, update and run it and report the findings (it should product a log file).

Don't worry about reported tracking cookies they are a minor issue and not one of security, allow SAS to deal with them though. - See http://en.wikipedia.org/wiki/HTTP_cookie.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

pauloaragao

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #4 on: January 31, 2010, 03:59:00 AM »
Okay!

I dont have the WebShield.

So I've downloaded both applications, installed and ran them.
Nothing was found by Malwarebytes or SAS (except those cookies you said I shouldnt worry about - still I let SAS delete all of them).

Still same message comes up once Windows starts or trying to open a page in IE8.

What else should I do?

Thanks!
« Last Edit: January 31, 2010, 04:04:55 AM by pauloaragao »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86671
  • No support PMs thanks
Re: Avast 5.0.396 Activex Error with IE8
« Reply #5 on: January 31, 2010, 04:44:42 AM »
What do you mean you don't have the web shield - do you mean you took my advice and stopped it ?
If so that just confirms that the web shield isn't involved.

As I said before you still had the problem even when you uninstalled avast.

So there has to be something in your IE security settings, don't ask me what, I avoid IE like the plague and activeX is one of the reasons not because of this problem, but the fact it is a huge target for exploitation.

Unfortunately I have no other ideas as my experience of IE is extremely limited as I don't use it other than for visits to windows update.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

YoKenny

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #6 on: January 31, 2010, 07:24:15 AM »
In IE8 go to Tools then Internet Options then Advanced then click Reset... to reset IE8 to default settings.

You can try Restore advanced settings as well.

pauloaragao

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #7 on: January 31, 2010, 02:53:02 PM »
Hey YoKenny!

Thanks for the tip man, but it didnt work...

About to pull my hair off!!!
 :o

frustrated2453

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #8 on: July 06, 2010, 05:49:36 PM »
I am having the exact same problem. The error message shows up as soon as I start my computer (have not even opened IE8) and it was only on the one computer I upgraded to 5.whatever.  I thought I was doing a good thing but now can't access things on my computer that I need daily for my job. Also, I had a few more months left on the previous license which did not transfer over to the software update. I wish I would have known that before I downloaded the update because now I get the daily "you need to register" pop-up.


smwabill

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #9 on: September 18, 2010, 06:09:05 PM »
No, it is an error with Avast 5.0

I have the error logged with Avast Tech support

I believe in my case it is a problem between Avast 5.0 and the Vista OS.

Avast 5.0 will not run scripts on IE7 or IE8 and many websites will not run correctly.

I have duplicated the problem about 20 times by uninstalling Avast and running a restore point.

I have uploaded all the latest versions of Avast 5.0 including 5.0.677 and shutdown everything and reinstalled it and it has the same exact problem.

I cannot afford to upgrade to Windows 7 at this time, but rest assured it is a problem within Avast 5.0 no matter what anybody tells you. I have done enough error checking to fill up a small stadium.

Thanks and have a good day.

p.s. I hope Alwil comes up with a patch to fix this.---they are working on it (this problem) as I have been communicating with them.


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86671
  • No support PMs thanks
Re: Avast 5.0.396 Activex Error with IE8
« Reply #10 on: September 18, 2010, 06:44:03 PM »
If it were truly a problem only within avast and IE7&8 have a large user base these forums would be buzzing with activity; so you wouldn't have had to add your post to one that is over two months old. Given what you have said I believe there is some form of conflict going on, usually with another security program/AV or remnants of one, but that really should be dealt with in a new topic entirely of your own, to avoid any confusion in this topic for an old version.

I don't use IE as my primary browser, but when I do have to use IE8, I don't appear to have any problems with ie8 and avast 5.0.677.

How avast interacts with browsers would be the same across XP, Vista or Win7 should be the same, so I don't see how upgrading to win7 would resolve the problem (even if you could afford it).
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

YoKenny

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #11 on: September 18, 2010, 06:53:16 PM »
How avast interacts with browsers would be the same across XP, Vista or Win7 should be the same, so I don't see how upgrading to win7 would resolve the problem (even if you could afford it).
Once you upgrade to Win7 you will realize why Dinosaurs became extinct.

Aligators survived because they could afford it.  8)

By the way I use IE9 now but XP users can't use it.  ;)
« Last Edit: September 18, 2010, 06:58:07 PM by YoKenny »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86671
  • No support PMs thanks
Re: Avast 5.0.396 Activex Error with IE8
« Reply #12 on: September 18, 2010, 07:02:07 PM »
I can't understand how your comments are in any way related to the selective text you quoted.

Upgrading to Win7 from Vista would have no bearing on how avast interacts with browsers IE7 or IE8 which the OP has used. It has sod all to do with XP or IE9 as the OP isn't using either.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Dch48

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #13 on: September 18, 2010, 07:10:07 PM »
I have seen no problems of any kind running IE8 and Avast! 5 on either XP or Vista. I don't believe it's a problem relating to that combination. Something else has to be at play.

Beechmontgirl

  • Guest
Re: Avast 5.0.396 Activex Error with IE8
« Reply #14 on: November 20, 2010, 01:08:22 AM »
Hello -I copied and pasted this from january post.  I am on exactly the same type of computer. Dell, Vista, etc and having the exact same problem.  How did you fix it??

I used to have the Avast Pro 4.x and I decided to change that to the newer version, the 5.0. After I installed it and restarted, it came up with an error message ""An ActiveX control on this page might be unsafe to interact with other parts of the page. Do you want to allow this interaction?". No matter what I click (yes or no) it still comes up. Basic websites are not loading properly such as Hotmail.com (screen goes completely blank), youtube (the video area is reduced and nothing happens), microsoft.com (clicking the menu on the top wont go anywhere) and also the Windows Vista sidebar (none of the gadgets show).
I already uninstalled and then installed the previous avast version again but it did not work. Now i have the 5.0 version installed again.
I am using a Dell computer, windows vista home basic SP2.

This never happened with the previous Avast versions.