Author Topic: Avast Internet Security Antispam in thunderbird 3 using IMAP  (Read 10397 times)

0 Members and 1 Guest are viewing this topic.

hegedusa

  • Guest
Avast Internet Security Antispam in thunderbird 3 using IMAP
« on: February 06, 2010, 09:20:08 PM »
Could you confirm how antispam is supposed to work using IMAP-based mail in Thunderbird?

Right now, I've installed this on one PC, and it is unable to reach its mail server at all ever since installing Avast Internet Security. It says the mail server is not found.

I was going to do a reboot, but had to leave the customer, and unfortunately our remote support tool failed to work after reboot so I don't know if it works yet or not  :(

GYL

  • Guest
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #1 on: February 07, 2010, 03:52:41 PM »
Hello! I've XP pro SP3 with Thunderbird and Imap for my job more or less 100 mails per day and no problem wiht avast IS and his antispam

Blackadder

  • Guest
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #2 on: February 24, 2010, 11:30:02 AM »
I have seen this too. The latest update of Avast Antivirus seems to break something. Thunderbird with IMAP have always worked just fine with Avast, but not any more. As far as I know you have to disable the mail shield. I hope they fix this soon.

I have seen this on Windows 7, Thunderbird 3.0.1 and Avast 5.0.418.

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2604
  • I can resist anything except temptation.
    • tex62
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #3 on: February 24, 2010, 11:39:14 AM »
No, that's not true.
TBird 3 and Avast work together perfectly - as I use this combination.

You are probably using a ssl / tls encrypted account in TBird? Then you should:
Disable ssl/tls for POP/IMAP/SMTP in TBird
Set POP/IMAP/SMTP ports to standard non ssl number (143/25 or 110/25)

Avat will scan the unencrypted mail and provide ssl/tls for transmission to the mailserver.

Check MailShield settings "accounts" and set the ssl/tls and port numbers as you would in TBird without avast.
Set Mailshield to scan inbound/outbound mail.

You may also want to check the "behaviour" setting and enable "insert clean message" which will then put a "Message clean" text under each mail you send/receive.

Zyndstoff
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Hermite15

  • Guest
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #4 on: February 24, 2010, 11:46:44 AM »
Could you confirm how antispam is supposed to work using IMAP-based mail in Thunderbird?



It does (almost) nothing, I've deactivated it. It's completely unable to move anything to any junk folder. All it does is sometimes mark a message as *spam* in the subject line and that's it... until you put it in the white list because it's an FP most of the time. If you want a good anti-spam in Thunderbird, use the one that's built in.

ps: according to the options, it should be able to move spam to the junk folder... in Outlook exclusively, but I didn't check that.

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2604
  • I can resist anything except temptation.
    • tex62
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #5 on: February 24, 2010, 12:02:13 PM »
Could you confirm how antispam is supposed to work using IMAP-based mail in Thunderbird?



It does (almost) nothing, I've deactivated it. It's completely unable to move anything to any junk folder. All it does is sometimes mark a message as *spam* in the subject line and that's it... until you put it in the white list because it's an FP most of the time. If you want a good anti-spam in Thunderbird, use the one that's built in.

ps: according to the options, it should be able to move spam to the junk folder... in Outlook exclusively, but I didn't check that.

+1

Not using avast antispam either.
I'm employing a combination of ISP-filtering and build-in TBird antispam for my imap-account.
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Blackadder

  • Guest
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #6 on: February 24, 2010, 12:05:52 PM »
No, that's not true.
TBird 3 and Avast work together perfectly - as I use this combination.

You are probably using a ssl / tls encrypted account in TBird? Then you should:
Disable ssl/tls for POP/IMAP/SMTP in TBird
Set POP/IMAP/SMTP ports to standard non ssl number (143/25 or 110/25)

Avat will scan the unencrypted mail and provide ssl/tls for transmission to the mailserver.

Check MailShield settings "accounts" and set the ssl/tls and port numbers as you would in TBird without avast.
Set Mailshield to scan inbound/outbound mail.

You may also want to check the "behaviour" setting and enable "insert clean message" which will then put a "Message clean" text under each mail you send/receive.

Zyndstoff

Yes it is true. No SSL/TSL in use at all. IMAP just stopped working after the last Avast program update. SMTP send still works however.

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2604
  • I can resist anything except temptation.
    • tex62
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #7 on: February 24, 2010, 12:08:43 PM »
It is working like a charme for me.
IMAP and SMTP.
Did you check the settings? It can only be a settings problem. What is your email-provider?
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Blackadder

  • Guest
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #8 on: February 24, 2010, 11:46:59 PM »
Yes, I have checked the settings. I have been using this particular PC with unchanged settings with Thunderbird 3.0.1 and Avast for some time. But after the latest Avast program update it stopped working. The email server is my own. So I have full control over that, and I have tested with different setups. Outlook works fine on the same computer and with the same IMAP account. Other PC's are using the same server without any problems. The only failure I have seen so far is with Windows 7 64-bit, Thunderbird 3.0.1 and the latest Avast version.

The only thing I can think about that changed about the same time as Avast was updated and IMAP stopped working was that I configured Outlook to use the same IMAP account. However, I can't see how that would affect Avast's IMAP filter in combination with Thunderbird.

I might do a test; Make a clean Windows 7 install in a VM with only Avast and Thunderbird.

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2604
  • I can resist anything except temptation.
    • tex62
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #9 on: February 25, 2010, 07:35:23 AM »
The only failure I have seen so far is with Windows 7 64-bit, Thunderbird 3.0.1 and the latest Avast version.

That is strange indeed, since that is exactly my configuration (see my signature), and it's working, as I said, like a charme.
If you don't mind: please give feedback if you happen to find the cause for your probs, will you?
Thnx
Zyndstoff
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Blackadder

  • Guest
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #10 on: March 11, 2010, 11:19:04 PM »
Well... Problem seems to be solved, but I still really don't understand what happened.

Anyway. What I did was to:
1. Shut down Thunderbird.
2. Go to Real-time shields / Mail shield / Expert settings / SSL Accounts.
3. Select the IMAP account in the list and delete it.
4. Start Thunderbird and get new emails.

Thats it. The IMAP account entry under "SSL Accounts" was then automaticly added again. And now it works. When manually verifying the settings of the IMAP entry it looks indentical to before I deleted it. Same protocol, same port and no encryption.

I hope this helps if someone else runs into this problem.

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2604
  • I can resist anything except temptation.
    • tex62
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #11 on: March 12, 2010, 08:10:29 AM »
Thx for the feedback.
Great to hear it's working for you.
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

garybarnes

  • Guest
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #12 on: March 15, 2010, 09:52:55 AM »
I have upgraded Avast on two computers with Thunderbird 3, and there is absolutely no noubt that there is a problem here.
Avast will allow TB3 to work if you remove the account from the SSL Accounts list in the Mail Shield Expert settings, but will then add it back in. This has been a known issue for months now, it's about time it was fixed.

Offline Zyndstoff (aka Steven Gail)

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2604
  • I can resist anything except temptation.
    • tex62
Re: Avast Internet Security Antispam in thunderbird 3 using IMAP
« Reply #13 on: March 15, 2010, 10:09:26 AM »
You can post this in another 250 threads, but it won't help you.
Since it is working for millions of users, I should think the problem is not Avast but your specific setup.

Give enough information and you will be helped if possible.
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear