Author Topic: Avast causing serious errors with Kerio 2.1.5  (Read 13897 times)

0 Members and 1 Guest are viewing this topic.

Offline Blu3Flame

  • Newbie
  • *
  • Posts: 4
Avast causing serious errors with Kerio 2.1.5
« on: June 29, 2004, 12:06:22 AM »
I've recently bought a new computer and moved over to XP and I have encountered this problem:

When Avast comes across a virus, everything seems fine and it deletes it ok. No sign of any trouble.

Then apon the next reboot of the computer Kerio 2.1.5, apon loading, pops up an error message of "PfVarLibInit: var_server_start error: 1 (10022: socket() failed)", then when Avast loads I get an error along the lines of "Error 1002" outlining that POP3/SMTP features will be unavailable.

It actually totally impairs Kerio and I can't access many things within windows including the internet/task manager until I have sucessfully uninstalled the firewall.

Any light on this situation at all would be of great help.

Offline techie101returns

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1900
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #1 on: June 29, 2004, 12:11:31 AM »
Blue,

Kerio is not one of my favorites because of the learning curve.
Kerio is application/rule based which means that if you are not careful, you can block needed processes and applications.

I would not modify or change the default "out of the box" settings.  If Kerio asks whether you want to grant permission for something to access the internet, make sure you know what it is before you say NO.

There is no reason why Avast and Kerio will not work together.  At one time I had them both on my system and they were fine.  I just didn't like the Kerio popups which lack sufficient information on the "subject process" to make a good decision to access or not.

I recommend Sygate or Zone Alarm.  Another good choice would be Agnitum Outpost.  All are freeware.

Offline Blu3Flame

  • Newbie
  • *
  • Posts: 4
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #2 on: June 29, 2004, 12:25:01 AM »
I have been using Kerio for a long time on a 98SE based system and never had any trouble with it. I have tried both the out of the box settings and the BZ settings file: http://www.dslreports.com/r0/download/433116~b4e2ac2e47750bb04ff99d9e226bcc10/DFstandard.gif

I did decide try a few other firewalls but after using Kerio for so long I couldn't get my head around the way other firewalls work. So if possible it would be nice to know what could have caused this.
« Last Edit: June 29, 2004, 12:25:54 AM by Blu3Flame »

Offline inthewildteam

  • Advanced Poster
  • **
  • Posts: 772
  • Computers can do that?
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #3 on: June 29, 2004, 12:28:48 AM »
I've recently bought a new computer and moved over to XP and I have encountered this problem:

When Avast comes across a virus, everything seems fine and it deletes it ok. No sign of any trouble.

Then apon the next reboot of the computer Kerio 2.1.5, apon loading, pops up an error message of "PfVarLibInit: var_server_start error: 1 (10022: socket() failed)", then when Avast loads I get an error along the lines of "Error 1002" outlining that POP3/SMTP features will be unavailable.

It actually totally impairs Kerio and I can't access many things within windows including the internet/task manager until I have sucessfully uninstalled the firewall.

Any light on this situation at all would be of great help.

Hi, I also use Kerio on a Windoze XP Pro set-up with no problems.  My (Kerio) version number is 4.0.16

Have you got Kerio from an old magazine CD or a back-up CD?

You can download the newest version from www.kerio.com

Hope this helps
So? I drive a Citroen

Offline Blu3Flame

  • Newbie
  • *
  • Posts: 4
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #4 on: June 29, 2004, 12:34:05 AM »
I am using Kerio 2.1.5, its the version most people use as Kerio completly changed the Firewall and including lots of extra bumpf for the later versions.

Offline inthewildteam

  • Advanced Poster
  • **
  • Posts: 772
  • Computers can do that?
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #5 on: June 29, 2004, 12:38:40 AM »
I am using Kerio 2.1.5, its the version most people use as Kerio completly changed the Firewall and including lots of extra bumpf for the later versions.

Wasn't aware of that!

Can only say that ver 4 works flawlessly for me and it's hardly "bloatware"

How old is version 2.1.5 btw?
So? I drive a Citroen

Offline inthewildteam

  • Advanced Poster
  • **
  • Posts: 772
  • Computers can do that?
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #6 on: June 29, 2004, 12:49:23 AM »
Just found this, if it's of any help

http://www.wilderssecurity.com/showthread.php?t=34039
So? I drive a Citroen

Offline Blu3Flame

  • Newbie
  • *
  • Posts: 4
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #7 on: June 29, 2004, 12:50:11 AM »
I believe its about 30/Apr/2003 without installing the application and checking myself.

4 certainly isn't bloatware but the last time I tried it the direction it was going in didn't please me personally. Containing things like "NO POPUPS IN IE" and stuff I felt it was branching out of the Firewall world. 2.1.5 suited me perfectly as it uses very little system resources compared to others. Its a shame Avast seems to conflict with it in this way, I'm unsure if its solely down to Avast and rather down to some corrupted/conflicting dll/service/error in the registry so it would be nice to know where to start looking to find out whats wrong.

Offline Darren

  • Jr. Member
  • **
  • Posts: 55
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #8 on: June 29, 2004, 12:55:08 AM »
I have always used Kerio 2.1.5 and avast! together with no problems. As mentioned in a previous reply, you have a something blocked that is needed during the windows boot process.
Delete the persfw.conf file from kerio's directory, and a fresh default one will be created when it is next started.

Offline inthewildteam

  • Advanced Poster
  • **
  • Posts: 772
  • Computers can do that?
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #9 on: June 29, 2004, 12:59:16 AM »
I'm no tech but have noticed that some of my older (favourite) progs refuse to work with XP Pro unless I use compatability mode.  

Not that I'd reccomend doing that for a firewall programme btw.

I'm at a loss to help you further other than having used Sygate's prog a long time ago (on Win98se) and found it quite good.

Hopefully someone with more knowledge will be able to help you as I guess Kerio doesn't support your version now.

Best regards
So? I drive a Citroen

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #10 on: June 29, 2004, 04:13:52 AM »
I am using Kerio 2.1.5, its the version most people use as Kerio completly changed the Firewall and including lots of extra bumpf for the later versions.

That's why I stop to look to Kerio with charm... From version 2 to 4 we get a bloatware-all-in-one-systemworks-like-application  :'(

Besides this is what Techie said: the learning curve. It's more dangerous to have a bad configuration in your firewall than a simple firewall.  ;)

I won't make merchandising of 'my' firewall as I'm forbiden by Bob  ;D
« Last Edit: June 29, 2004, 04:17:04 AM by Technical »
The best things in life are free.

Offline whocares

  • Super Poster
  • ***
  • Posts: 1698
  • I'm not a llama! :-)
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #11 on: June 29, 2004, 09:35:20 AM »
Hi,

With WHAT viruses does this happen exactly ?
exact name & location = path/folder/filename ?

maybe you deleted some part of KERIO, of WINDOWS socket or inet-connection files ?

*

here, avast always works fine with Kerio 2.1.5 on Win2000-SP4




Offline lian

  • Jr. Member
  • **
  • Posts: 24
  • I'm a french llama!
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #12 on: June 29, 2004, 12:04:02 PM »
I have no problem with WinXP, Avast and Kerio 2.1.5

Offline Delta

  • Full Member
  • ***
  • Posts: 105
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #13 on: June 29, 2004, 01:38:11 PM »
Dupe post. Sorry. :-[
« Last Edit: June 29, 2004, 01:50:57 PM by Delta »

Offline Delta

  • Full Member
  • ***
  • Posts: 105
Re:Avast causing serious errors with Kerio 2.1.5
« Reply #14 on: June 29, 2004, 01:42:31 PM »
Hi,

With WHAT viruses does this happen exactly ?
exact name & location = path/folder/filename ?

maybe you deleted some part of KERIO, of WINDOWS socket or inet-connection files ?

*

here, avast always works fine with Kerio 2.1.5 on Win2000-SP4



Hi, I agree with whocares.
I had the same problem once, though in my case it was self-inflicted :D

Somehow your firewall has become corrupted, re-installing it should help if you have completely removed the virus.

Delta.
« Last Edit: June 29, 2004, 01:45:08 PM by Delta »