Author Topic: Firewall stops working. Can't turn it back on.  (Read 1797 times)

0 Members and 1 Guest are viewing this topic.

Offline wile_e

  • Jr. Member
  • **
  • Posts: 20
Firewall stops working. Can't turn it back on.
« on: February 21, 2010, 08:38:56 PM »
I am having a problem with the firewall. This is on a clean install of Windows 7 64bit Ultimate. Sometimes the firewall won't start and I can't turn it on. I press the "Fix Now" button, but it gives me error message "The following components could not be started: Firewall". I try to restart the firewall service, but can't get it started. Windows says the service started, then stopped.

Once it gets in this state, the only thing that fixes it, is to do a "repair install" of Avast. But after awhile, the firewall stops working again. What could be causing the problem? I do occasionally use CCleaner to clean out registry. Would this mess up the firewall service?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Firewall stops working. Can't turn it back on.
« Reply #1 on: February 22, 2010, 03:53:54 PM »
Did you have any other firewall before AIS?
Sometimes, installation from the scratch could help.

1. Download the latest version of avast! Uninstall Utility and save it.
2. Download the latest avast! version and save it.
3. Uninstall avast from Control Panel (if possible). If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after that.
4. Run the avast! Uninstall Utility saved on 1. If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after you've run it.
5. Install avast! using the setup saved on 2. Boot.
6. Register your free copy or add the license key for Pro.
7. Check and post the results.
The best things in life are free.