Author Topic: Can't install version 5.... SOLVED!  (Read 3866 times)

0 Members and 1 Guest are viewing this topic.

cimmind

  • Guest
Can't install version 5.... SOLVED!
« on: February 23, 2010, 03:08:07 AM »
Hi... Facing a huge problem here.
I had downloaded v5 yesterday and installed it after  uninstalling v4.8 using the official uninstall utility from the avast site. It installed alright, but none of the shields were working. Even the 'Fix now' button did nothing.

Went back to the site, downloaded the v5 uninstall utility and tried doing a fresh install. But since then the quandry has started. Trying to install v5 now throws up the error message "you do not have sufficient user rights" . I was installing from the Admin account all times.

The same msg comes up even when trying to install 4.8 now. So i am stuck with no antivirus as of now!

What i can add for information:
- OS is Windows XP SP2
- I have Comodo firewall and WinPatrol, but i had used CCleaner to disable both of them from starting at computer startup. Also disabled cmdagent.exe service of Comodo directly from Services.
- No other security program was in autostart list, while trying the installs.
- Searching through the registry for the word 'avast' showed me that there are three Legacy keys - avast, avast web scanner, avast mail scanner; in the Current control set and also in two-three previous control sets. These keys i could not delete even in Safe mode.

The error message log (from the last tried v5 install) is as follows:

23.02.2010 07:08:35 general: Started: 23.02.2010, 07:08:35
23.02.2010 07:08:35 general: Running setup_av_pro-558 (1368)
23.02.2010 07:08:35 system: Operating system: WindowsXP ver 5.1, build 2600, sp 2.0 [Service Pack 2]
23.02.2010 07:08:35 system: Memory: 49% load. Phys:199264/391664K free, Page:640864/748604K free, Virt:2068912/2097024K free
23.02.2010 07:08:35 system: Computer WinName: *****
23.02.2010 07:08:35 system: Windows Net User: *****\******
23.02.2010 07:08:35 general: Cmdline: /sfx /sfxstorage "G:\DOCUME~1\*****~1\LOCALS~1\Temp\_av_sfx.tm~a00356"  /srcpath "H:\INSTAL~1\ANTIVI~1" /sfxname "setupeng"
23.02.2010 07:08:35 general: DldSrc set to sfx
23.02.2010 07:08:35 general: Old version: ffffffff (-1)
23.02.2010 07:08:35 registry: Deleted registry: Software\Alwil Software\Avast\4.0\UpdateReady
23.02.2010 07:08:35 general: Install check: SetupVersion does NOT exist
23.02.2010 07:08:35 general: SGW32P::CheckIfInstalled set m_bAlreadyInstalled to 0
23.02.2010 07:08:35 registry: ERROR!:Cannot access registry HKLM\SYSTEM\CurrentControlSet\Services\avastTestService, error code: 0x00000005
23.02.2010 07:08:35 general: Err:Not enough user rights to continue.


Thanks in advance.

[PS: Go to go to office now, so please bear with some delay in trying out your given suggestions]
« Last Edit: February 23, 2010, 04:40:07 PM by Cimmind »

cimmind

  • Guest
Re: Can't install version 5 (& not even 4.8 now)
« Reply #1 on: February 23, 2010, 03:32:27 PM »
Hi.. Just back.
Installed v5 (same copy) on a separate comp with a fresh installed WinXP SP2. Installed like a breeze! So its not a SP2 issue.

What do i do to get it working on this comp?  Still without an antivirus on this one. I have downloaded Avira 9, just in case.

But would dearly wish to retain Avast on both comps.   


cimmind

  • Guest
Re: Can't install version 5 (& not even 4.8 now)
« Reply #2 on: February 23, 2010, 04:38:19 PM »
 SOLVED

Avira can wait!  ;)

What solved the problem:
I was about to settle in for the long haul of having to reinstall the OS.
Just as a last try, tried installing v5 again. Again it showed the same error message.
Did a scan of full registry again for 'avast'.. This time there were 3-4 extra software entries for Alwil/Avast, besides the legacy ones. Removed them all. with Legacy keys not removable.
Just out of the blue, did a explorer search for 'avast' in my C drive.
To my surprise there were 4-5 _avast temp folders in each of my user profiles, along with a avast .ini file somewhere in the admin profile folder. I was not expecting this, considering that i had used the aswclear utility tool as advised.
Did a full computer search for 'avast'  as a precaution. 

Did a reboot and this time i set about doing a install with a hunch that things will work. And presto! v5 installed.

And it installed despite having made the Comodo firewall+HIPS ACTIVE, as i was browsing this forum!

A few take-home points for me:
- To do a full comp search for any remnant files of any program i uninstall
- Never to fully trust the uninstall utilities of software!
- Win XP SP2 makes no difference to avast v5 install
- Avast v5 can be installed even while having Comodo +HIPS on.