Author Topic: Severe DPC latency problems (avast free 5.0.462/5.0.418)  (Read 15069 times)

0 Members and 1 Guest are viewing this topic.

Offline mut@NT

  • Newbie
  • *
  • Posts: 5
Severe DPC latency problems (avast free 5.0.462/5.0.418)
« on: March 16, 2010, 12:25:42 PM »
I noticed that avast 5 resident protection causes DPC latencies to become real ugly (up to 10 seconds and more!). This occured on 2 of my machines after updating from 396 to 418 and makes playback of any streaming content a very unpleasing experience. Problem still persists in version 462.
Maybe most of the users don't notice this because latencies reach disturbing levels only after several hours of uptime. I made a couple of measurments (on current version 5.0.462):

1. This is just after startup, nothing to complain about



2. About 12 hours of uptime, things are not so good, but still no drop-outs



3. About 48 hours of uptime, major problems here, any activity of any shield causes drop-out in multimedia playback



4. Measurments taken at the same time as 3, but with all shields disabled. No problems here.



Version 5.0.396 was OK after a two weeks of uptime, version 4 was also fine. Looks like something must have been screwed up in 418 and wasn't fixed in 462.
Same situation on 2 machines - desktop (CPU Atlhon 64x2 4200+, 2 gb of RAM, nvidia nForce 4 Ultra platform, nvidia 8800GT-based video card, ESI Juli@ PCI audio interface, I don't think rest of the devices matters much regarding to this problem) and Lenovo S10 netbook (I know it's not very powerful, but I didn't experience any problems with avast 396 on it). Both running Windows XP 32bit with SP3 and all updates.
« Last Edit: March 16, 2010, 12:34:25 PM by mut@NT »

Offline mut@NT

  • Newbie
  • *
  • Posts: 5
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #1 on: March 17, 2010, 04:59:04 PM »
Anybody else experienced such problems? ::)

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • My system Protector is avast
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #2 on: March 17, 2010, 06:18:55 PM »
ok try this!!
find this three item in the system32 folder.
kernel32.dll
winsock.dll
wsock32.dll
add it to the virus chest
but don't erase it. that very fragile element must have the copy in your chest
so that avast don't bother to catch this micro second speed metamorphic element.
just try and observe if effected.
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline wonderwrench

  • Sr. Member
  • ****
  • Posts: 226
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #3 on: March 17, 2010, 06:30:48 PM »
Do you also have high CPU usage?
I just checked on my main rig running Win 7 64 bit. No problems here. I do not have a XP box handy to test on. Have you tried disconnecting all non essential external devices. Have you tried disabling all non essential hardware devices in control panel one at a time while Avast is running to see if a device driver has a conflict with Avast? To test for a video driver conflict it would be necessary to uninstall the driver and use windows defaults.  Have you tried disabling all non essential drivers and software excluding Avast and MS services in msconfig.

I know this could turn out to be a lot of work but its the only way to prove what is going on. I wish I had a box with this problem so I could take a look for my self. It would be useful if people that have degraded performance when using Avast 5 would run DPC latency Checker and report back there findings. If they have high latency report their system specs and if they also have high CPU usage.
Link http://www.thesycon.de/deu/latency_check.shtml

IMO its going to take users going the extra mile to help ALWIL fix these type of problems. As it stands ALWIL can't fix what they can't reproduce.
« Last Edit: March 17, 2010, 07:22:58 PM by wonderwrench »
Main Box*i7 930*GB X58A-UD3R*3x4 gig Patriot DDR3 1600 EL*EVGA GTX 460 1 gig*Intel X25-M G2 80 gig*WD 2TB Green*ASUS DRW-24B3LT*Samsung SH-S223L*LG WH14NS40*Corsair AX750*Rosewill Challenger case*Windows 8 Pro 64 bit*Avast 8 Free 8.0.1482*MBAM Pro*Firefox 19.0.1*NoScript

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • My system Protector is avast
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #4 on: March 17, 2010, 06:39:11 PM »
cpu usage may have two causes.
1 bad registry depend upon the stability of the os
and this three elements.
another thing the scanning process
if it has a sound while scanning.
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline zeefrog

  • Newbie
  • *
  • Posts: 11
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #5 on: March 17, 2010, 07:06:50 PM »
thank you wonderwrench for the link for testing latency :)

i just ran one and it detected serious problems
turn avast off and ran the test again
guess what? not a problem at all
oh and i don't have high cpu usage if that helps


thank you avast for preventing me to stream anything since you imposed an update on me  >:(
« Last Edit: March 17, 2010, 07:11:34 PM by zeefrog »

Offline wonderwrench

  • Sr. Member
  • ****
  • Posts: 226
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #6 on: March 17, 2010, 07:24:58 PM »
thank you wonderwrench for the link for testing latency :)

i just ran one and it detected serious problems
turn avast off and ran the test again
guess what? not a problem at all
oh and i don't have high cpu usage if that helps


thank you avast for preventing me to stream anything since you imposed an update on me  >:(

Care to share your system spec's and any testing you have done to determine whats conflicting with Avast 5?
Main Box*i7 930*GB X58A-UD3R*3x4 gig Patriot DDR3 1600 EL*EVGA GTX 460 1 gig*Intel X25-M G2 80 gig*WD 2TB Green*ASUS DRW-24B3LT*Samsung SH-S223L*LG WH14NS40*Corsair AX750*Rosewill Challenger case*Windows 8 Pro 64 bit*Avast 8 Free 8.0.1482*MBAM Pro*Firefox 19.0.1*NoScript

Offline zeefrog

  • Newbie
  • *
  • Posts: 11
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #7 on: March 17, 2010, 07:32:21 PM »
what specs do you need
op system is xp
2 g ram
pentium(R) D cpu 2.80ghz x 2
« Last Edit: March 17, 2010, 07:35:56 PM by zeefrog »

Offline zeefrog

  • Newbie
  • *
  • Posts: 11
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #8 on: March 17, 2010, 07:41:27 PM »
and i am not confident enough in my knowledge of computers to start disabling drivers and the like

basically what is conflicting in my eyes is the new avast, my pc was and is fine without it
and many other people repport the same problem, with browsing, gaming or streaming
maybe the avast staff should look a bit more into it as opposed to us doing all the testing

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • My system Protector is avast
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #9 on: March 17, 2010, 08:05:46 PM »
the same peak rating here even i disable avast  ??? ???
i cannot find any difference :'(
maybe because my system is stable or simply too old that why it is not sensitive ;D ;D ;D 8) 8) 8)
« Last Edit: March 17, 2010, 08:11:29 PM by bong2x »
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline zeefrog

  • Newbie
  • *
  • Posts: 11
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #10 on: March 17, 2010, 08:14:10 PM »
have you try reseting the latency testing application after you disable avast, because at first i didn't and there was no difference but if you reset it you ll see everything is fine (well in my case at least)

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • My system Protector is avast
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #11 on: March 17, 2010, 08:16:17 PM »
yes that's SOP to all of machine or program to start again.
reset!!!!!
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline zeefrog

  • Newbie
  • *
  • Posts: 11
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #12 on: March 17, 2010, 08:20:13 PM »

LOL yeah i know what you mean...

you don't need to stop and restart the program, there is a reset button

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • My system Protector is avast
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #13 on: March 17, 2010, 08:41:36 PM »
LOL whatever i do is the same.
i mean what is the calibration of this software? what is the standard of using this software?
what is the required DPC per micro second?
as we can say that it is stable ???
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline wonderwrench

  • Sr. Member
  • ****
  • Posts: 226
Re: Severe DPC latency problems (avast free 5.0.462/5.0.418)
« Reply #14 on: March 17, 2010, 09:17:55 PM »
and i am not confident enough in my knowledge of computers to start disabling drivers and the like

basically what is conflicting in my eyes is the new avast, my pc was and is fine without it
and many other people repport the same problem, with browsing, gaming or streaming
maybe the avast staff should look a bit more into it as opposed to us doing all the testing

If you go to the download link in my previous post there are detailed instructions on how to disable hardware in device manager. If you can't do it you can't that's all there is to it. Do you know anybody that could handle doing some testing for you, friend or relative? I would guess ALWIL is pulling their hair out trying to reproduce these problems and will some day. A fix will come but it would be much faster if people with performance problems did more than complain about the problem. People that can't help find the cause of these problems would be best off switching to another product until the problem is fixed.

I think ALWIL could do more with this forum to allow better support for its customers. They need to start doing some moderating on these forums instead of just letting it buck. Having a single area for all Avast 5 versions and problem types makes it almost impossible to manage all the posts. This causes forum users to post a new thread about a problem that has many threads already. ALWIL employees need to be more active in this forum and request additional needed info when required. Forum users need to give complete info on the problem they are having along with system spec's both hardware and software related.
Main Box*i7 930*GB X58A-UD3R*3x4 gig Patriot DDR3 1600 EL*EVGA GTX 460 1 gig*Intel X25-M G2 80 gig*WD 2TB Green*ASUS DRW-24B3LT*Samsung SH-S223L*LG WH14NS40*Corsair AX750*Rosewill Challenger case*Windows 8 Pro 64 bit*Avast 8 Free 8.0.1482*MBAM Pro*Firefox 19.0.1*NoScript