Author Topic: avast4workstation connection failure  (Read 6340 times)

0 Members and 1 Guest are viewing this topic.

NeverAgain

  • Guest
avast4workstation connection failure
« on: March 30, 2010, 01:51:17 PM »
Hallo

I got a really surprising failure message for avast. Surprising because I never got any failure messages by avast.
...well, so on.

The failure message is by starting avast as GUI in Ubuntu 9.04:
"Failed to connect to files.avast.com
IP number 1: invalid number"

The effect is that avast do not update the virus list.

...so which one is the valid number?  ???
...and where I have to write to the valid number? ???

Have any one an idea?

thanx

NeverAgain
« Last Edit: March 30, 2010, 01:57:32 PM by NeverAgain »

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: avast4workstation connection failure
« Reply #1 on: March 30, 2010, 03:53:12 PM »
Hallo

I got a really surprising failure message for avast. Surprising because I never got any failure messages by avast.
...well, so on.

The failure message is by starting avast as GUI in Ubuntu 9.04:
"Failed to connect to files.avast.com
IP number 1: invalid number"

The effect is that avast do not update the virus list.

...so which one is the valid number?  ???
...and where I have to write to the valid number? ???

Have any one an idea?

thanx

NeverAgain

look here: http://forum.avast.com/index.php?topic=57775.0

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

NeverAgain

  • Guest
Re: avast4workstation connection failure
« Reply #2 on: March 30, 2010, 05:37:15 PM »
Hallo, Zilog!

So, if I have understand you right so I have to copy "sysctl -w kernel.shmmax=128000000" or "echo 128000000 >/proc/sys/kernel/shmmax" in /etc/init.d/rcS. ...right?

I tried both solution. But there is no change.

I get the same failure message:
"Failed to connect to files.avast.com IP number 1: Invalid argument"

Any idea?

Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: avast4workstation connection failure
« Reply #3 on: March 30, 2010, 07:28:48 PM »
Hallo, Zilog!

So, if I have understand you right so I have to copy "sysctl -w kernel.shmmax=128000000" or "echo 128000000 >/proc/sys/kernel/shmmax" in /etc/init.d/rcS. ...right?

I tried both solution. But there is no change.

I get the same failure message:
"Failed to connect to files.avast.com IP number 1: Invalid argument"

Any idea?

It's a command, and you should type it in a terminal, when logged as root. It's also wise to include those commands to system-wide startup script.
the first one, might need full path to the sysctl binary (/sbin/sysctl), and the second one expects the /proc filesystem to exist (= mounted). So maybe you placed it to wrong place, where this procfs isn't accessible yet.

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

NeverAgain

  • Guest
Re: avast4workstation connection failure
« Reply #4 on: March 31, 2010, 12:19:16 PM »
HELP FOR UBUNTU 9.10:

http://www.ubuntu-austria.at/viewtopic.php?t=3031

I hope that I could help some Ubuntu friends.

Regards

Never Again