Author Topic: ASWServ.exe using 100% of a CPU  (Read 9891 times)

0 Members and 1 Guest are viewing this topic.

pstolp

  • Guest
ASWServ.exe using 100% of a CPU
« on: March 23, 2010, 02:45:24 PM »
I am using Avast server edition on a Windows SBS server 2003 machine, but the problem is that the Avast process ASWServ.exe is using 100% cpu sometimes, this will make the server extremely instable. Please help!

wpn

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #1 on: March 23, 2010, 03:38:52 PM »
are you running scans on that moment?
planned scans
manual scans

if so what kind of scans?
what are the hardware specs?

pstolp

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #2 on: March 23, 2010, 03:47:14 PM »
I am running no scans at the moment, I even disabled the on access protection and still massive cpu load & I/O activity...
DELL XEON 3.0 ghz
1gb ram

pstolp

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #3 on: March 23, 2010, 03:51:13 PM »
Well sometimes the cpu is 100% now its about 50% because 2 out of 4 processor kernels are running 100%. And still lot's of disk activity

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: ASWServ.exe using 100% of a CPU
« Reply #4 on: March 23, 2010, 05:50:19 PM »
Please create a memory dump of the aswServ.exe process.
The process is described e.g. here:
http://forum.avast.com/index.php?topic=56551.msg477260#msg477260

(obviously replacing AvastUi by aswServ)

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

pstolp

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #5 on: March 24, 2010, 10:09:45 AM »
Yesterday the performance got so bad that I uninstalled avast!, now the server is working fine... This morning I reinstalled avast! and after an hour or 5 it hung, at least 50% cpu usage, I am using multicore processor... I tried to create a memory dump but there is no process aswServ.exe visible, only aswDisp.exe probably because aswServ.exe is a system process. Is there another way to create a memory dump?

wpn

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #6 on: March 24, 2010, 08:30:34 PM »
*nevermind this remark*
« Last Edit: March 24, 2010, 08:38:27 PM by wpn »

pstolp

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #7 on: March 25, 2010, 10:41:15 PM »
Can anyone help?

pstolp

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #8 on: March 30, 2010, 09:54:15 AM »
I would appreciate it when someone from Avast will respond to my call, I need help. I have no antivirus protection at this moment because Avast fails. I allready called the support devision in NL and explained the problem.. but after 1 week still no respons....

wpn

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #9 on: March 30, 2010, 08:17:05 PM »
call again to the dutch support devision.....

zhuweiping

  • Guest
Re: ASWServ.exe using 100% of a CPU
« Reply #10 on: April 12, 2010, 07:06:51 PM »
读起来真费劲!还是上中文论团自在!
The feeling is mutual