Author Topic: avast Vs NNTP  (Read 3490 times)

0 Members and 1 Guest are viewing this topic.

Offline jagemal

  • Newbie
  • *
  • Posts: 2
avast Vs NNTP
« on: April 25, 2010, 06:12:51 PM »
Hi ...

I recently upgrade to Avast 5 free, but now I've a problem
I can not access the NNTP server (neither by telnet nor by thunderbird)

if I stop the email protection, everything returns to work

I try to deactivate the scan of NNTP messages, add add the address of the server to the list
but proved useless


someone can help me?
thanks

(my configuration is: windows xp x64 and thunderbird 2.0.0.24)
(ah ... so sorry for my bad english  :-X )

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 84787
  • No support PMs thanks
Re: avast Vs NNTP
« Reply #1 on: April 25, 2010, 07:37:40 PM »
What error message is displayed ?
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline jagemal

  • Newbie
  • *
  • Posts: 2
Re: avast Vs NNTP
« Reply #2 on: April 25, 2010, 07:47:29 PM »
What error message is displayed ?

there's no error  :(

when I access with telnet, i write the command:

c:\bla..bla\>telnet news.fastwebnet.it 119
4-5 secs later it returns to the prompt

if I turn off email protection, it writes immediatly the welcome message:
"200 Fastweb News Server (Typhoon v2.1.1.371)"

doktornotor

  • Guest
Re: avast Vs NNTP
« Reply #3 on: April 25, 2010, 07:56:36 PM »
Code: [Select]
502 Permission Denied - Fastweb News Server - Permission Denied (Typhoon v2.1.1.
371)

is that I get w/ telnet and mail shield enabled (including NNTP). Note that a non-public news server which apparently also checks for IP address is something not useful for reproduction and debugging purposes.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 84787
  • No support PMs thanks
Re: avast Vs NNTP
« Reply #4 on: April 25, 2010, 08:59:10 PM »
What error message is displayed ?
<snip>
when I access with telnet, i write the command:

c:\bla..bla\>telnet news.fastwebnet.it 119
4-5 secs later it returns to the prompt

OK, I think it comes down to using telnet over port 119 as the Mail Shield will be redirecting 119 and it will be expecting NNTP protocol and that may be what the problem is.

if I turn off email protection, it writes immediatly the welcome message:
"200 Fastweb News Server (Typhoon v2.1.1.371)"


Rather than stop the Mail Shield you could edit the settings and disable the NNTP scan, if you aren't going to use NNTP protocol but telnet that is about all I can suggest, see image of Expert Settings, Main Settings screen.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re: avast Vs NNTP
« Reply #5 on: April 27, 2010, 11:19:30 AM »
You can find error messages from the mail scanner logged here:
C:\Documents and Settings\All Users\Alwil Software\Avast5\log\Mail.log