Author Topic: Scan Now screen is now problematic...  (Read 2616 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
Scan Now screen is now problematic...
« on: March 25, 2010, 02:59:54 PM »
Running Avast5 (5.0.426, all up to date) on XP Pro system (and it was working fine since it's release up to about a few weeks ago).

I have another issue, which is detailed in the post 'Long delay when desktop initializes, with big CPU hit (was working fine before)', but once that resolves itself, Avast seems to be running fine....


When I try and enter the Scan Now screen (which previously was working fine), there is a long delay (hourglass appears, and the interface is white if you minimize/defocus it, then return to it) before it finally resolves itself and appears.

Just wondering if that's a known issue, or what it might be.

All other sections of Avast work fine (nav icons take you directly to that particular section without delay... It's just the Scan Now section).

Task Manager shows AvastUI.exe going to about 50 (with System and Idle Process taking up about 30-40) while it's in the 'freeze' mode.

Like my other issue, this started occurring about a few weeks ago, and was working fine before.


  • Guest
Re: Scan Now screen is now problematic...
« Reply #1 on: March 28, 2010, 06:50:08 PM »
Anyone have any idea what could be happening here?  (Long delay for Scan Computer page)

Anyone else have the same issue?

I did a Repair on Avast, which reduced the other issue, but didn't remedy this Scan Computer issue...


  • Guest
Re: Scan Now screen is now problematic...
« Reply #2 on: March 29, 2010, 04:04:05 PM »
UPDATE: The delay is now back to being quite long again (several minutes), so the Repair fix was only temporary.

If I don't get any kind of response on this (even just theories on what it might be), I'm probably moving on to another anti-virus product.  I can't trust my computer's safety on a product that has an apparent flaw that the makers don't appear to know anything about, or won't comment on.  Might be something else, but no response = no answers.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 76213
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Scan Now screen is now problematic...
« Reply #3 on: March 29, 2010, 04:18:14 PM »
did u already try the option start avast after other systemsrelated sw?
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos):


  • Guest
Re: Scan Now screen is now problematic...
« Reply #4 on: March 29, 2010, 05:39:03 PM »
Yes.  With that on, only my internet connection is held back (as opposed to the ram cleaner, and the other standard windows taskbar items).

Avast initializes/loads... but the email and web shields (I believe) are disabled, and the Avast taskbar icon displays the exclamation mark.  At that point, the delay begins.  CPU goes through the roof, and continues so for several minutes.  Internet connection is still not established, and not much else can be done during this time.  Seems to be either AvastUI.exe or AvastSvc.exe (or whatever that file is called) that is using up the CPU... usually up to 65% (fluctuating frequently).  I usually click on Fix Now to try and activate the disabled Avast modules (as I'm not sure if they go on automatically after the CPU strain finishes).... but nothing happens (the program is too busy).

After several minutes, the CPU drain suddenly drops, the Avast interface refreshes to reveal that all disabled modules are now running again, and my internet suddenly gets activated (and Avast usually grabs the latest definition updates)... and things are back to normal.

So, I'm wondering what might be happening here, so I can further diagnose things... It doesn't appear to have anything to do with the update downloading, since it occurs before that stage.  Not sure why the certain modules are disabled on bootup each time.

I DID find one user who wrote about the same type of experience, and a new user gave what he claims is a solution he found.  He said the latest update DOESN'T fix things if installed the normal way, but instead needs to be installed in safe mode (...or something to that affect).  I'm not sure if this is a true fix, as he might have just temporarily fixed it by reinstalling Avast (...and it might just come back again).  I too was able to drastically reduce the delay by doing a repair on Avast... but the delay went back to 'several minutes' after a day... so, not a fix.

I've been hoping to get some official word on this issue... whether they know what is happening.... whether there is an official fix/repair method... etc.
« Last Edit: March 29, 2010, 05:47:11 PM by ladlon »