Author Topic: Avast 5 - stopping the window to appear at startup?  (Read 11595 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88455
  • No support PMs thanks
Re: Avast 5 - stopping the window to appear at startup?
« Reply #15 on: March 25, 2010, 03:50:26 PM »
Yes, I would certainly go back in to msconfig and uncheck that item again and reboot (twice if what Igor suggests is correct about the misleading msconfig message) and see if that resolves the problem and gets rid of the "message that it's running on a Diagnostic startup and tells me to return to Normal startup."

Whilst you can leave that option unchecked forever if you want, provided there are no recurrence of the duplicate avast UI popping up you could delete that entry in msconfig (but no rush).
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.10.6086 (build 23.10.8563.800) UI 1.0.784/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security


  • Guest
Re: Avast 5 - stopping the window to appear at startup?
« Reply #16 on: March 26, 2010, 11:00:22 AM »
I had the same problem on my XP system.  The Avast window started popping up a few days ago.  I checked MSconfig and found two identical entries for Avast in the startup tab.  I followed the instructions in this link:

The only difference for those instructions for me is I had to reboot after checking the disable box. When the mscongig gui appeared after boot, I closed the window, ignoring the warning and went straight to regedit and found the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\MSConfig\startupreg\worldclock  This key contained an enty pointing to AvastUI.exe.  There was already an entry for AvastUI.exe on my system under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run which exlains why I had duplicates in the MSconfig startup tab.

I backed up the registry and deleted that key.  Then I rebooted to test and the problem appears to be solved - no Avast popup window.  

Merely disabling the msconfig entries works, but when you reboot msconfig will launch on boot, informing you that you are running in "selective startup mode"  Subsequent boots did not fix this for me.  You could opt for the don't show this warning again, but I would be very leery of doing that.

Hope this helps!

« Last Edit: March 26, 2010, 11:05:43 AM by nigelb »


  • Guest
Re: Avast 5 - stopping the window to appear at startup?
« Reply #17 on: March 26, 2010, 06:46:08 PM »
I dug deeper to find out whats causing this bug. For XP users who may have the same problem, try going to your System Information, then navigate to Software Environment, then Startup Programs. Look for any other program other than avast5 which calls on the avastgui.exe /nogui command. In my case, it was a Cyberlink software that came free with one of my peripherals and which I barely use. I uninstalled the Cyberlink software, and that fixed the problem. Of course, if the software having conflict with Avast is one that you often use and really need, you may have to decide which software you want to keep. I don't know why this happened in the first place, but I hope this helps other users.

Thanks to everyone on this forum for all your help!


  • Guest
Re: Avast 5 - stopping the window to appear at startup?
« Reply #18 on: March 27, 2010, 03:08:53 AM »
Aha, thanks for that.  I now know what caused my duplicate entry.  I had installed a program called "World Clock" and then un-installed it later through the control panel.  Apparently it left a registry entry under the key "worldclock" which pointed to the Avast startup "AvastUI.exe

So the key, if you follow the instructions in my earlier post is to look under the MSconfig key for any entries in startupfolder/startupreg, or services and inspect the contents in the date field, looking for any Avast reference.