Author Topic: An error occured in avast! engine: Invalid argument  (Read 83786 times)

0 Members and 1 Guest are viewing this topic.

Offline HEP

  • Newbie
  • *
  • Posts: 2
Re: An error occured in avast! engine: Invalid argument
« Reply #15 on: August 17, 2010, 08:53:17 PM »
Thanks guys this has fixed the problem but on reading through forums I found out the comand needs to be added to init scripts
as a complete newbe I have no idea how to do this but I will give it a go thanks for help

Offline kostufan

  • Newbie
  • *
  • Posts: 1
Re: An error occured in avast! engine: Invalid argument
« Reply #16 on: December 01, 2010, 06:05:05 AM »
run this command
sudo sysctl -w kernel.shmmax=128000000
kernel.shmmax = 128000000

thanks a lot, it saved me!

On the second prompt the the system kicks in:
kernel.shmmax: command not found

but it still works, perfect job.


Offline zilog

  • Avast team
  • Advanced Poster
  • *
  • Posts: 957
  • or #f0; daa; add a,#a0; adc a,#40
Re: An error occured in avast! engine: Invalid argument
« Reply #17 on: December 06, 2010, 09:40:07 AM »
run this command
sudo sysctl -w kernel.shmmax=128000000
kernel.shmmax = 128000000

thanks a lot, it saved me!

On the second prompt the the system kicks in:
kernel.shmmax: command not found

but it still works, perfect job.



kernel.shmax is not command, it's the name of variable, which should be set using sysctl command:

sysctl -w kernel.shmmax=128000000

as written in the very first posts in this thread.

regards,
pc
May's Law: Software efficiency halves every 18 months, compensating Moore's Law. (David May, INMOS)

Offline Sn00pY

  • Newbie
  • *
  • Posts: 6
Re: An error occured in avast! engine: Invalid argument
« Reply #18 on: March 16, 2011, 12:17:35 AM »
run this command
sudo sysctl -w kernel.shmmax=128000000
kernel.shmmax = 128000000

worked. brilliantly :) thanks :)
*running mandriva 2010.2*

Offline User_1971

  • Newbie
  • *
  • Posts: 1
Re: An error occured in avast! engine: Invalid argument
« Reply #19 on: May 25, 2011, 02:28:25 PM »
I found out that if i added the line...   kernel.shmmax = 128000000  ..to the bottom of the sysctl.conf text file this seemed to do the trick, as far as i can tell anyway so far.

Using the 'File browser' i found out that the sysctl.conf is in the 'etc' folder, i found the file was a 'read only' text file, so i used Alt +F2 to open the 'Run application'  box and typed...   gksu gedit   ... this opened the text editor application Gedit as an administrator user , and opened the sysctl.conf text file by going through the application itself, now it was a writeable file so any changes could now be saved.

The reason i'm being as detailed as i can, is that finding out basic newbie information like accessing, and changing something in Ubuntu as an administrator was not as widespread information as it could have been.

Thanks for being so detailed ;D It's hard when you change to a new OS and have to learn everything new.


Ubuntu 10.10
eMachines e528

Offline markoboy

  • Newbie
  • *
  • Posts: 1
Re: An error occured in avast! engine: Invalid argument
« Reply #20 on: June 04, 2011, 04:35:43 PM »
I have a temp solution for you. using any text edit you like.

put this code into it

#!/bin/bash
sudo sysctl kernel.shmmax=10000000000
avastgui

save the file as avastfix.sh (or whatever you like as long as you know its for avast).

Make the file executable via permissions.

Double click it, when given the option select Run in terminal.

Avast will load without the error even after lastest update.

Offline vonkrieg

  • Newbie
  • *
  • Posts: 2
Re: An error occured in avast! engine: Invalid argument
« Reply #21 on: August 14, 2012, 01:44:22 AM »
run this command
sudo sysctl -w kernel.shmmax=128000000
kernel.shmmax = 128000000

Tks a lot ! Now, workin' fine !

Offline vonkrieg

  • Newbie
  • *
  • Posts: 2
Re: An error occured in avast! engine: Invalid argument
« Reply #22 on: August 14, 2012, 01:48:53 AM »
To Pure Blooded:
Tks a lot brow ! Now, it's workin' fine !

Offline AndrzejL

  • Jr. Member
  • **
  • Posts: 28
    • Wordpress on The Wardrobe
Re: An error occured in avast! engine: Invalid argument
« Reply #23 on: May 05, 2014, 01:52:25 PM »
Guys I appologize for the necroposting but for a several weeks now (cannot specify exactly when it started) the method mentioned above is not working anymore.

Code: [Select]
[root@wishmasus andrzejl]# grep shmmax /etc/sysctl.d/99-sysctl.conf
kernel.shmmax = 128000000

I am on Arch Linux with the kernel Linux wishmasus.loc 3.14.2-1-ARCH #1 SMP PREEMPT Sun Apr 27 11:28:45 CEST 2014 i686 GNU/Linux

Not sure what has changed but I get error message:

Quote
An error occured in avast! engine: Invalid argument

if I would run:

Code: [Select]
avastgui --verbose
it shows messages about missing folders "wxstd" and "avast".

It used to work just fine before the upgrade. Nothing has really changed here.

Quote
Name           : avast
Version        : 1.3.0-5
Description    : Avast4workstation antivirus (Home/Non-Commercial Only)
Architecture   : i686

Was there an upgrade that I am unaware of? Possibly the virus database has changed to the point where its incompatible with the old engine?

Cheers.

Andrzej

« Last Edit: May 05, 2014, 01:57:57 PM by AndrzejL »

Offline muellen

  • Newbie
  • *
  • Posts: 1
Re: An error occured in avast! engine: Invalid argument
« Reply #24 on: May 05, 2014, 06:28:13 PM »
Hi, you can use same method , but add bigger size. Probably because database of viruses is still bigger, after viruses database update Avast not working with old value. Now is in my puppylinux working this value: 155000000. Previous 128.. is too low now. In a future, this problem probably can be solved with same method, by increasing requested memory. Sorry for my bad english

Offline AndrzejL

  • Jr. Member
  • **
  • Posts: 28
    • Wordpress on The Wardrobe
Re: An error occured in avast! engine: Invalid argument
« Reply #25 on: May 09, 2014, 01:53:30 AM »
Hi, you can use same method , but add bigger size. Probably because database of viruses is still bigger, after viruses database update Avast not working with old value. Now is in my puppylinux working this value: 155000000. Previous 128.. is too low now. In a future, this problem probably can be solved with same method, by increasing requested memory. Sorry for my bad english

Your English is just fine and so is Your advice. It worked.

I feel stupid for not trying to increase the number... Oh well...

Thank You.

Andrzej