Author Topic: "The Package is Broken" Error Message  (Read 7946 times)

0 Members and 1 Guest are viewing this topic.

Sakurayume

  • Guest
"The Package is Broken" Error Message
« on: April 22, 2011, 02:08:31 AM »
Hello, I'm new to this forum so I apologize if this isn't the correct place to post this. I'm recieving an update error message that says "the package is broken." This is happening when updating virus definitions and the program. Is this a common error message or could my computer be affected by a virus that is not letting me update? Any help would be greatly appreciated.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86126
  • No support PMs thanks
Re: "The Package is Broken" Error Message
« Reply #1 on: April 22, 2011, 02:39:08 AM »
Try a manual virus definitions update from the avastUI, Maintenance, Update and see that works.

If not - Try a repair of avast. Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow. You may need to reboot after the repair.

Vista, win7 - Repair of avast. Control Panel, Programs & Features, uninstall a program, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.11.2500 (build 21.11.6809.528) UI 1.0.683/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Sakurayume

  • Guest
Re: "The Package is Broken" Error Message
« Reply #2 on: April 22, 2011, 03:55:56 AM »
Thank you for the quick response. I manually installed the most recent version of Avast and that seemed to work. Thanks again.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86126
  • No support PMs thanks
Re: "The Package is Broken" Error Message
« Reply #3 on: April 22, 2011, 04:11:25 AM »
No problem, glad I could help.

Welcome to the forums.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.11.2500 (build 21.11.6809.528) UI 1.0.683/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Kaden1956

  • Guest
Re: "The Package is Broken" Error Message
« Reply #4 on: May 18, 2011, 04:09:13 AM »
I'm hoping I can bump this up to the top.

I'm having the same problem as Sakurayume, broken package.
I did as David suggested..didn't work.
I don't know what to do now. I have the new (free) version. It automatically updated itself or I sure don't remember updating it..at all.

Would someone please help me?

Thanks, greatly appreciated.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86126
  • No support PMs thanks
Re: "The Package is Broken" Error Message
« Reply #5 on: May 18, 2011, 04:17:11 AM »
What error do you get when you try the Repair that I suggested ?

If it is saying you need to do a full update, then you will have to download and run the full virus database.

- Avast! Manual Virus Definitions Update Download - avast! Virus Definitions Update - Manual Download VPS Update (virus definitions, vpsupd.exe, approx 39.5MB). - Save the file to your hard disk, locate where you saved it and double click it and that should carry out the virus definitions update.

Note: Ignore the file name in the images of the page that is displayed after clicking the download link, they are for the main program, not for vpsupd.exe which will be downloaded.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.11.2500 (build 21.11.6809.528) UI 1.0.683/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Kaden1956

  • Guest
Re: "The Package is Broken" Error Message
« Reply #6 on: May 18, 2011, 04:41:11 AM »
Hi David,

Thanks for such a quick response.

When I try to "update engine and virus definition and update program", that's when it says the package is broken.

SafeSurf

  • Guest
Re: "The Package is Broken" Error Message
« Reply #7 on: May 18, 2011, 11:25:58 AM »
Try it again...the Avast servers have been very busy and Avast has been putting out what seems like larger VPS definitions.  I just recently had the same problem, but by manually updating after several times during off-peak hours, I was finally able to update.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86126
  • No support PMs thanks
Re: "The Package is Broken" Error Message
« Reply #8 on: May 18, 2011, 03:54:52 PM »
Hi David,

Thanks for such a quick response.

When I try to "update engine and virus definition and update program", that's when it says the package is broken.

You're welcome.

I doubt that the package is broken is related to servers being very busy (but I have never had that), I would have thought that would throw up a connection error (unable to connect, etc.). It doesn't appear that you tried the avast Repair mentioned in my Reply #1 as that would normally say you need to do a full update (in my Reply #5).

So did you try the full update downloading the complete virus database in my post Reply #5 above (The link to do that is the Blue text) ?
That is a big download and double clicking on that file once downloaded should update the complete virus database.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.11.2500 (build 21.11.6809.528) UI 1.0.683/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

kronhead

  • Guest
Re: "The Package is Broken" Error Message
« Reply #9 on: May 21, 2011, 06:30:56 AM »
Well, I am having this problem now. I had a BSOD earlier today - not saying it was caused by Avast - after I rebooted, Avast popped up a message saying last update failed - I figured it was because of the crash. Anyway, I clicked on update - got message saying Package is broken. Came here ... tried repair - it says "error processing packages - please use full update." Last things in log are:
20.05.2011 21:20:48 general: SelectCurrent: selected server 'Download332 AVAST5 Server' from 'main'
20.05.2011 21:20:48 internet: SYNCER: Type: use IE settings
20.05.2011 21:20:48 internet: SYNCER: Auth: another authentication, use WinInet
20.05.2011 21:20:54 general: Operation set to INST_OP_REPAIR
20.05.2011 21:20:54 general: Entered SetupProcessAIS::Do( INST_OP_REPAIR )
20.05.2011 21:20:54 general: Entered SetupProcessWin32Avast::Do( INST_OP_REPAIR )
20.05.2011 21:20:54 general: Entered SetupProcessWin32::Do( INST_OP_REPAIR )
20.05.2011 21:20:54 general: Entered SetupProcess::Do( INST_OP_REPAIR )
20.05.2011 21:20:54 general: Entered SetupProcessAIS::Do( INST_OP_UPDATE_INSTALL_PACKAGES )
20.05.2011 21:20:54 general: Entered SetupProcessWin32Avast::Do( INST_OP_UPDATE_INSTALL_PACKAGES )
20.05.2011 21:20:54 general: Entering:UpdateInstallPackages
20.05.2011 21:20:54 general: progress thread start
20.05.2011 21:20:54 package: LoadProductVpu: C:\Program Files\Alwil Software\Avast5\Setup\prod-ais.vpx
20.05.2011 21:20:54 package: ERROR: Unable to verify prod-ais.vpx, error 0x2000000B
20.05.2011 21:20:54 package: Error processing packages. 0x20000011

Tried the update option in setup - clicked check for update - got message "package is broken."
Last part of log:
20.05.2011 21:23:18 general: SelectCurrent: selected server 'Download333 AVAST5 Server' from 'main'
20.05.2011 21:23:18 internet: SYNCER: Type: use IE settings
20.05.2011 21:23:18 internet: SYNCER: Auth: another authentication, use WinInet
20.05.2011 21:23:18 internet: Used server: http://download333.avast.com/iavs5x
20.05.2011 21:23:18 file: GetFileWithRetry: prod-ais.vpx downloaded .
20.05.2011 21:23:18 file: prod-ais.vpx not changed, 1305912847
20.05.2011 21:23:18 package: LoadProductVpu: C:\Program Files\Alwil Software\Avast5\Setup\prod-ais.vpx
20.05.2011 21:23:18 package: ERROR: Unable to verify prod-ais.vpx, error 0x2000000B
20.05.2011 21:23:18 package: LoadAllDefs failed 0x20000011
20.05.2011 21:23:18 general: Error:The package is broken.

Downloaded full virus definitions - it says VPS database is up to date. But using Avast's Update Engine & Virus Definitions still gives "package is broken."

Hmm - virus definition in use is 110520-0. It says Your Virus Defs are out of date - latest 110520-1. So why did Full VPS download execution say it was up to date?

Current program version is 6.0.1125.

But - anyway - any suggestions? Unintall and re-install?

Thanks!
Dan

SafeSurf

  • Guest
Re: "The Package is Broken" Error Message
« Reply #10 on: May 21, 2011, 11:29:28 AM »
Others have also had similar problems except they are unable to update (not the package is broken).  You may want to take a look at this thread:
http://forum.avast.com/index.php?topic=78460.0.  Perhaps an uninstall/clean install can't hurt at this point.

kronhead

  • Guest
Re: "The Package is Broken" Error Message
« Reply #11 on: May 23, 2011, 01:54:01 AM »
Thanks - my problem actually went away the next day.

I was out of town the last 2 days, or I would have sent an update sooner.

Thanks again.
Dan