Author Topic: Outlook toolbar issues: feedback needed  (Read 27173 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #15 on: April 14, 2010, 05:11:52 AM »
4. regsvr32 /u asoutext.dll
7. regsvr32 asoutext.dll
Only works with admin rights.

Everything goes fine until step 7.
Starting Outlook, the toolbar is not be visible and the plugin, although listed, is disabled.
The best things in life are free.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #16 on: April 14, 2010, 09:58:58 AM »
Interesting. Let's try this:

0. Download AIS 5.504 and ensure that the debug logging is set
1. Stop Outlook (kill if necessary)
2. Start>Run>regedit
3. Go to HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\avastAddin
4. Change the value of LoadBehavior to 3
5. Start Outlook
6. Outlook should now start with avast enabled. Hopefully the addin will work. If not then I am looking forward to seeing the asoutext.log from you ;-)

Let me know how you get on

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #17 on: April 14, 2010, 08:10:31 PM »
k.u.r.t., right now my license file was banned and I can't update my avast.
But I think it should work as I have 5.0.504.
The behavior key was already on 3  ::)
So the plugin is not there  ::)
I'm sending you the log by email.
The best things in life are free.

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #18 on: April 14, 2010, 09:58:42 PM »
Hello

The toolbar of version 5.0.507 does not work on outlook 2007. Outlook crashes with no actions and disables the plugin avast!antispam.

The toolbar of version 5.0.492 worked well.

How to get the 5.0.492 version of Internet security SW?

I use AIS on W7 64bits ultimate.

Thanks

Patrice.

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #19 on: April 14, 2010, 10:17:51 PM »
I think SW version was 5.0.462, not 5.0.492
Sorry. So, how to get this version?
Patrice.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #20 on: April 15, 2010, 09:51:04 AM »
Hello

The toolbar of version 5.0.507 does not work on outlook 2007. Outlook crashes with no actions and disables the plugin avast!antispam.

The toolbar of version 5.0.492 worked well.

How to get the 5.0.492 version of Internet security SW?

I use AIS on W7 64bits ultimate.

Patrice.
Thanks
What does the log say?
Please go to Avast>Settings>Maintenance and check the Enable debug logging checkbox. Then restart Outlook, wait for the problem to appear and post your asOutExt.log here. (See the beginning of this topic for instructions)

Tech. Thanks, got your email, sent you a reply.

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #21 on: April 15, 2010, 10:10:39 AM »
Hello
Attached the log file (the plugin worked 1 time only, other times, it crashes outlook
Notice that the plugin works ok on outlook 2010.
Patrice.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #22 on: April 15, 2010, 12:45:44 PM »
Hi Francis,
thanks for the log. I need some more information to resolve this. Please check your email "at orange dot fr".

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #23 on: April 15, 2010, 12:48:52 PM »
Hello Tom
Done the actions as indicated in your mail
Now avast antispam is inactive in outlook and the toolbar never appears.
Also, no log generated.
If a revert back to the original file, outlook crashes. So, there is something wrong in the new module.
WBR
Patrice.
« Last Edit: April 15, 2010, 12:51:25 PM by Patrice_avast »

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #24 on: April 15, 2010, 01:10:09 PM »
Really? Maybe Outlook disabled our add-in due to the previous crash. Put the new one in place, start Outlook and make sure that avast add-in is not disabled (Tools>Trust center>Add-ins>Disabled). If it is disabled then it needs to be enabled. Let me know.
The add-in can also be manualy enabled via the registry. HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\avast Addin\LoadBehavior needs to be set to 3.
Additionaly you might also want to go to the avast directory and do "regsvr32 asoutext.dll" from the commandline

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #25 on: April 15, 2010, 02:00:23 PM »
Hello Tom

The plugin is not disabled, it is noted as inactive and I can do nothing on this via outllok menus.
And in the registry, the value you indicate is 3 also
Regarding the execution of the command "regsvr32 asoutext.dll", I get an error message (attached) that says:

"the asoutext.dll module has been loaded, but the call to DllRegisterServer has failed with error code 0x80070005
For more information on this problem, make a search in line with the corresponding error code"

WBR.
Patrice.
« Last Edit: April 15, 2010, 02:09:24 PM by Patrice_avast »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #26 on: April 15, 2010, 02:13:15 PM »
Tech. Thanks, got your email, sent you a reply.
I've send you another email.
I can't perform "exactly" the instructions you've gave me.
The best things in life are free.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #27 on: April 15, 2010, 02:18:26 PM »
Hello Tom

The plugin is not disabled, it is noted as inactive and I can do nothing on this via outllok menus.
And in the registry, the value you indicate is 3 also
Regarding the execution of the command "regsvr32 asoutext.dll", I get an error message (attached) that says:

"the asoutext.dll module has been loaded, but the call to DllRegisterServer has failed with error code 0x80070005
For more information on this problem, make a search in line with the corresponding error code"

WBR.
Patrice.
If the plugin is listed as inactive then it needs to be activated. This is how you do it in Outlook 2007:
Go to Tools > Trust center > Addins
From the "Manage" dropdown select "Disabled" and click "Go"
Tick the checkbox next to avast! Antispam.
Restart Outlook (kill process  if necessary) and send me the log.
« Last Edit: April 15, 2010, 02:30:51 PM by k.u.r.t »

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #28 on: April 15, 2010, 02:25:28 PM »
Hello Tom
Ok, it has been activated and outlook crashed as soon as started.
Attached log file
WBR
Patrice.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #29 on: April 15, 2010, 03:02:11 PM »
Thanks Patrice, just sent you another copy of the asoutext.dll for you to try. Still trying to pinpoint the problem, this time I am pretty close. Let me know how it goes.

Cheers
« Last Edit: April 15, 2010, 04:44:41 PM by k.u.r.t »