Author Topic: Outlook toolbar issues: feedback needed  (Read 27171 times)

0 Members and 1 Guest are viewing this topic.

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #30 on: April 15, 2010, 05:48:04 PM »
Hello Tom
Installed the new modiule and outlook is working ok with this module: the toolbar is displayed and we can use the different buttons
of the bar with no problem (tried 3 times opening closing outlook and also markin spam / unmarking spam messages with no problems)
I will try again  after restarting the PC >> Tried >> ehaviour is Ok (one try only)
Log file is attached.
WBR.
Patrice.
« Last Edit: April 15, 2010, 05:56:07 PM by Patrice_avast »

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #31 on: April 15, 2010, 06:14:27 PM »
Hello,
I made some other tests and outlook crashed again. Log file is attached.
WBR.
Patrice.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #32 on: April 16, 2010, 09:45:52 AM »
Thanks Patrice, I just sent you a new dll - the last crash occured in a different place from the previous one. Again, looking forward to your test results.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #33 on: April 16, 2010, 11:37:44 AM »
Tech,
I found out the culprit of your crashes. Many thanks for your feedback as this problem will very likely affect many of our users. The problem is with the PST file itself. Some contacts have an invalid email address even though Outlook claims that these addresses are valid. I will be checking for this condition from now on. Such contacts are stored twice in the PST file: once with a valid email address and once without one. The addin sees all the entries but to you Outlook only shows the valid contacts so you will not notice the issue when going through your contact list. The fix will appear in the next beta or release version. If you are interested I can send you the dll that corrects this issue by email (let me know please)

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #34 on: April 16, 2010, 12:16:02 PM »
Hello Tom,
Tried the new dll and no issue for the moment.
Attached is current log file.
WBR.
Patrice.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #35 on: April 16, 2010, 12:43:21 PM »
ok, keep trying and send me the log should anything fail ... cheers

deorum

  • Guest
Re: Not Satisfied with Antispam
« Reply #36 on: April 16, 2010, 12:45:19 PM »
Hi there,

Im currently in the trial version of AIS. I have the latest AIS update, and Outlook Express 6.

The antispam seems not working well.
It marks some mails with ***SPAM***, but it hasnt created any rule to send them on a different folder (i did manually)
And it doesnt have any button or option in right click to "mark as spam" or... "not spam" etc.

I tried some steps above with regsvr32 asoutext.dll etc, but nothing worked.

Any help appreciated.

k.u.r.t

  • Guest
Re: Not Satisfied with Antispam
« Reply #37 on: April 16, 2010, 12:57:12 PM »
Hi there,

Im currently in the trial version of AIS. I have the latest AIS update, and Outlook Express 6.

The antispam seems not working well.
It marks some mails with ***SPAM***, but it hasnt created any rule to send them on a different folder (i did manually)
And it doesnt have any button or option in right click to "mark as spam" or... "not spam" etc.

I tried some steps above with regsvr32 asoutext.dll etc, but nothing worked.

Any help appreciated.

Deorum,
the antispam consists of two modules:
1.the antispam core (generic)
2.the antispam toolbar (outlook only)
Outlook Express is a different product from Outlook - which is why you will not see the toolbar no matter what you do ...
The latter module is an enhancment which is meant to improve the performance of the first module by the mans to manually correct its spam/not spam decisions, automatically adding contact list addresses to whitelist, etc. If you do not use Outlook you can still specify the list of trusted/untrusted users manualy by going to Avast>Antispam&Blockers>Expert settings>Whitelist/Blacklist
« Last Edit: April 16, 2010, 01:01:56 PM by k.u.r.t »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #38 on: April 16, 2010, 07:45:02 PM »
If you are interested I can send you the dll that corrects this issue by email (let me know please)
Sure. I'll be glad to test and overwrite this dll.
The best things in life are free.

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #39 on: April 19, 2010, 01:47:32 PM »
Hi Tom,
After 3 days of tests, got two outlook crashes, when outlook starts
Attached is the current logfile (crashes are towards the end of the file). After a crash, I restart outlook and crash dose not occur again.
WBR.
Patrice.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #40 on: April 19, 2010, 04:05:18 PM »
Many thanks for that one, would you mind trying yet another one please? Depending on the outcome of this one I might decide to further investigate the possible causes of your behaviour or trying a whole new approach altogether (whic will require further testing ...)
Cheers

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #41 on: April 20, 2010, 02:15:58 PM »
Hi Tom,

Here is the log file after 4 crashes when opening outlook just 5 minutes ago.

WBR.
Patrice.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #42 on: April 20, 2010, 02:31:45 PM »
Outlook still marks emails as ***SPAM*** even with the toolbar missing and the plugin disabled ???
k.u.r.t., please, follow this.
The best things in life are free.

Patrice_avast

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #43 on: April 20, 2010, 03:12:56 PM »
Two other crashes in this one
Patrice

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #44 on: April 20, 2010, 04:11:30 PM »
Outlook still marks emails as ***SPAM*** even with the toolbar missing and the plugin disabled ???
k.u.r.t., please, follow this.

That is because the email was marked as spam by the mail shield (if you use outlook then it would have been done by ashOutXt.dll, otherwise it is done by ashMaiSv.dll)
The toolbar is a different dll that works on top of the two ...