Author Topic: Outlook 2007 crash when receiving spam  (Read 4541 times)

0 Members and 1 Guest are viewing this topic.

Offline OisteinR

  • Full Member
  • ***
  • Posts: 104
  • Why not...
Outlook 2007 crash when receiving spam
« on: April 29, 2010, 08:38:51 PM »
Outlook 2007 crashes when I receive spam-mails. It happens just before the spam toolbar appears. Everything is ok until the next spam-mail arrives - new crash...
Any ideas?



Avast IS 5.0.507
Windows7 64bit

i7 860 2.8GHZ, 8GB RAM, 1x250Gb Corsair SSD, 5x2TB HD, Windows 7 Professional 64bit, avast! V7.0.1401 AIS

k.u.r.t

  • Guest
Re: Outlook 2007 crash when receiving spam
« Reply #1 on: April 30, 2010, 08:23:04 AM »
OisteinR,
which module does Outlook claim to be responsible for the crash? Is it the avast! Antispam (asoutext.dll) or the ashoutxt.dll?

I can lead you to what you do if the former is the troublemaker.

You can go to avast > Settings > Maintenance > Enable debug logging. Doing so will output some information about what went wrong into
C:\Users\All Users\Alwil Software\Avast5\log\asOutExt.log

Also should the log file not provide me with enough information we will take care of this after you upgrade to the new beta (due out later today or this weekend) which will introduce some bugfixes as well as a new debug feature: crash dumps - these will tell us exactly where the app crashes (not yet available in the 507 build)

Offline OisteinR

  • Full Member
  • ***
  • Posts: 104
  • Why not...
Re: Outlook 2007 crash when receiving spam
« Reply #2 on: April 30, 2010, 09:51:27 AM »
It's AsOutExt.dll

The log entris before the crash looks normal (like the last one here)
After the crash occurs, the log looks like this:

30.04.2010   09:32:52   --- AsOutExt started ---
30.04.2010   09:32:52   OnStartup
30.04.2010   09:32:52   12.0.0.6514
30.04.2010   09:32:52   Active Explorer present
30.04.2010   09:32:53   OnSelectionChange
30.04.2010   09:32:53   TryCreateToolbar
30.04.2010   09:32:53   CToolbarWrapper(spExplorer)
30.04.2010   09:32:53   CreateGUI
30.04.2010   09:32:53   no bar

Obviously something is missing...
Then I start Outlook again without disabling the plugin - new crash:

30.04.2010   09:34:45   --- AsOutExt started ---
30.04.2010   09:34:45   OnStartup
30.04.2010   09:34:45   12.0.0.6514
30.04.2010   09:34:45   Active Explorer present
30.04.2010   09:34:46   OnSelectionChange
30.04.2010   09:34:46   TryCreateToolbar
30.04.2010   09:34:46   CToolbarWrapper(spExplorer)
30.04.2010   09:34:46   CreateGUI
30.04.2010   09:34:46   no bar

Now I disable the plugin, and enable it again in Outlook.
Opens Outlook - no crash:

30.04.2010   09:37:24   --- AsOutExt started ---
30.04.2010   09:37:24   OnStartup
30.04.2010   09:37:24   12.0.0.6514
30.04.2010   09:37:24   Active Explorer present
30.04.2010   09:37:25   OnSelectionChange
30.04.2010   09:37:25   TryCreateToolbar
30.04.2010   09:37:25   CToolbarWrapper(spExplorer)
30.04.2010   09:37:25   CreateGUI
30.04.2010   09:37:25   no bar
30.04.2010   09:37:25   Bar created
30.04.2010   09:37:25   S_OK
30.04.2010   09:37:25   LoadToolbarPosition
30.04.2010   09:37:25   olMail
30.04.2010   09:37:25   GetAvastSpamProperty
30.04.2010   09:37:25   Not marked as spam
30.04.2010   09:37:25   SetSpamButtonEnabled(1)
30.04.2010   09:37:25   SetNotSpamButtonEnabled(0)
30.04.2010   09:37:25   SetSpamAddrButtonEnabled(1)
30.04.2010   09:37:25   SetNotSpamAddrButtonEnabled(0)
30.04.2010   09:37:32   OnExplorerClose
30.04.2010   09:37:32   SaveToolbarPosition
30.04.2010   09:37:32   DestroyGUI
30.04.2010   09:37:32   ~CToolbarWrapper
30.04.2010   09:37:32   cleanup
30.04.2010   09:37:32   Unhooking app event handlers
30.04.2010   09:37:32   Unhooking other event handlers
30.04.2010   09:37:32   Event handlers unhooked
30.04.2010   09:37:32   OnDisconnection
30.04.2010   09:37:32   cleanup
30.04.2010   09:37:32   --- AsOutExt stopped ---

This looks more normal - until next crash...
BTW. it's not only when receiving junk-mail. That was just a coincidence.
i7 860 2.8GHZ, 8GB RAM, 1x250Gb Corsair SSD, 5x2TB HD, Windows 7 Professional 64bit, avast! V7.0.1401 AIS

Offline OisteinR

  • Full Member
  • ***
  • Posts: 104
  • Why not...
Re: Outlook 2007 crash when receiving spam
« Reply #3 on: May 04, 2010, 11:57:26 PM »
Almost solved.
The .533 Beta solved the crashing issue, but the spam toolbar always tries to make a separate toolbar. If you try to move the spam toolbar to combine it on an already existing toolbar, you get GUI flickering every time you open Outlook. Sometimes it just disappears...

i7 860 2.8GHZ, 8GB RAM, 1x250Gb Corsair SSD, 5x2TB HD, Windows 7 Professional 64bit, avast! V7.0.1401 AIS