Author Topic: Avast 5 - Cannot connect to Server - When Updating  (Read 23176 times)

0 Members and 1 Guest are viewing this topic.

Offline saxman

  • Newbie
  • *
  • Posts: 1
Avast 5 - Cannot connect to Server - When Updating
« on: April 30, 2010, 11:48:43 PM »
I have a computer running Windows 2000 SP4.  I had been running Avira Free AV on it without issues.  I decided to try Avast 5 on it and once installed it will not connect to the server to get definition updates.  I have the Ashampoo Firewall which I disabled.  I tried re-installing the Avast and that did not help.  I still get the cannot connect to server error when trying to update the definitions.  Is this newer version not compatible with Windows 2000?  I was going to try an older program version but thought I'd check here before doing so.

Thanks

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #1 on: May 01, 2010, 12:25:52 AM »
How did you get rid of Avira ?

Some firewalls even though supposedly disabled still have background processes that block unauthorised processes.

Does the firewall allow avast.setup internet access ?
- If it does delete the entry for it and do a manual update, this should force the firewall to ask permission again. 

The free version avast antivirus works with win2k, but it is conditional, it has to have SP4 (as you have) and some other rollup 1 update.
Please make sure you have the Update Rollup 1 installed (it's required for avast! 5):
http://www.microsoft.com/downloads/details.aspx?FamilyId=B54730CF-8850-4531-B52B-BF28B324C662&displaylang=en
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline slapbass

  • Newbie
  • *
  • Posts: 1
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #2 on: May 10, 2010, 02:08:49 PM »
Same here.

Win XP SP3, through a Linksys router and Ashampoo Firewall.
Yes, all mentioned executables have full access to the web, went through the steps mentioned above. Avast is not able to update itself, but if I choose "update" option from the uninstaller, it works. This is the only way.
I just don't get it...

Offline =SKY=

  • Super Poster
  • ***
  • Posts: 1442
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #3 on: May 10, 2010, 02:42:38 PM »
Is this newer version not compatible with Windows 2000?

Hello saxman,

it is compatible with Win 2000 SP4, I use it, too! ;)

Perhaps try the settings, that I've written in the following thread.
These settings helped me, as I installed avast on my PC:

http://forum.avast.com/index.php?topic=59529.0

Good luck! ;)
My oldest darling: W2k Pro SP4 & UR1 @ avast! Free Antivirus 8.0.1497 | MBAM Free | Firefox Portable & Opera Portable @ HDD | NO Desktop-FW |

Offline mak1965

  • Newbie
  • *
  • Posts: 6
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #4 on: May 10, 2010, 02:50:20 PM »
I had to find and install older 4.8, The new one was tried over and over and 5.0 did not work at all! See my post! Funny ?? I am sure these guys will find it. I run nothing except xp pro linksys router No Firewall. been the same until the 5.0 was installed! Mk

Offline kana

  • Newbie
  • *
  • Posts: 1
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #5 on: May 18, 2010, 02:46:06 AM »
I'm having the same issue as DavidR.

Windows XP with SP3
Ashampoo firewall

Deleted all Avast entries in the firewall
Tried manual update but cannot connect to server

Update works when uninstalling the software

Have neither figured out how to deal with this

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #6 on: May 18, 2010, 02:58:33 AM »
I'm not having a problem, but offering suggestions to saxman to try and get round a problem. Unfortunately he hasn't been back.

What happens if you reverse the process, uninstall ashampoo, reboot install avast, reboot and then install ashampoo.

Personally I haven't much confidence about the ashampoo range of products and no very little about their firewall. So if it has a learning mode I suggest putting it into learning mode and do an avast manual update and see if that helps it stick.

Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?

What other security based software do you have installed ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Marco Fumetti

  • Newbie
  • *
  • Posts: 17
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #7 on: May 18, 2010, 05:53:55 PM »
Hi guys. Does anybody found a solution? I updated my avast yesterday and I have the same problem. Version 4.8 always worked fine but version 5.0 doesn't get any update.
I have a glorious Windows 2000 Professional with Ashampoo firewall installed. All internet tools works fine (firefox, email, skype, emuIe, etc. etc.) except avast update. I tryed to turn off Ashampoo but the avast update still doesn't work. I tryed all 3 options of the avast proxy configuration (direct connection, auto detect and specify a (free) proxy) but it still doesn't works. Is there some hero who fixed this issue? Thanks!



P.S.
My avast was originally installed in italian so I tryed to add the english language. The download of the new components worked fine and now the product is in english language. But the virus definition update still doesn't work.


Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #8 on: May 18, 2010, 06:01:42 PM »
Have you read my first reply and taken the actions outlined in it ?

Disabling a firewall doesn't always work as it may still have the underlying device drivers running and that could still block items not allowed, etc.

You could also try putting ashampoo firewall into learning mode (if it has such a function) and try a manual update.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Marco Fumetti

  • Newbie
  • *
  • Posts: 17
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #9 on: May 19, 2010, 10:50:41 AM »
I did exactly this. I removed the old rules and I accepted the firewall requests for creating the new rules.

But the virus definitions update process still doesn't work. The only update that seems to work is the one that is available from the uninstall process, but unfortunately it doesn't update the virus definitions database.

It seems that in version 5.0 the connection method has changed and in some circumstances it doesn't work like it worked in 4.8.

« Last Edit: May 19, 2010, 10:57:10 AM by Marco Fumetti »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #10 on: May 19, 2010, 01:26:09 PM »
All I can suggest is try not restricting avast.setup to port 80, whilst it uses port 80 for the transmission of the actual update, I don't know if there is any communication to the download servers on another port.

Where are you starting that update from as the update process is usually carried out/displayed in the UI ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Marco Fumetti

  • Newbie
  • *
  • Posts: 17
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #11 on: May 19, 2010, 02:13:16 PM »
The update process that works, starts from control panel / add or remove programs / avast free / change-remove, but as I said before, it doesn't update the virus definitions database. This seems to be the "avast.setup" process. I granted the access to all ports but the behaviour is still the same.


The update process that doesn't work, it starts from the standard user interface. This seems to be the "AvastUI.exe" process and I always granted the access to all ports.

I'm afraid we're facing an incompatibility problem between Ashampoo Firewall and Avast 5.0...  What makes me angry is that with version 4.8 I never had any problem.

doktornotor

  • Guest
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #12 on: May 19, 2010, 02:25:49 PM »
You need to allow avast.setup on your firewall. NOT avastui.exe

Offline Marco Fumetti

  • Newbie
  • *
  • Posts: 17
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #13 on: May 19, 2010, 02:43:07 PM »


Please, post *only* meaningful assumptions, better if based on tested cases, thanks.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81777
  • No support PMs thanks
Re: Avast 5 - Cannot connect to Server - When Updating
« Reply #14 on: May 19, 2010, 02:44:36 PM »
Well that sounds more like a permissions issue as the avast.setup is the process that carries out the update and if your firewall was blocking it then it would block it from whatever location you ran it from.

The fact that it works from the add/remove, Update Components but not from the avastUI I think is because that has a higher permissions level and the avastUI on is a user based level. However the avast5 update from the UI is meant to elevate the permissions for the update. So I'm not sure what to do about this

The avastUI.exe doesn't actually need access for the updates to occur, that just starts the process of calling ashUpdSvc.exe which in turn creates and runs the avast.setup.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/